Changes 7.33.0:
* test code for testing the event based API * CURLM_ADDED_ALREADY: new error code * test TFTP server: support "writedelay" within * krb4 support has been removed * imap/pop3/smtp: added basic SASL XOAUTH2 support * darwinssl: add support for PKCS12 files for client authentication * darwinssl: enable BEAST workaround on iOS 7 & later * Pass password to OpenSSL engine by user interface * c-ares: Add support for various DNS binding options * cookies: add expiration * curl: added --oauth2-bearer option
This commit is contained in:
parent
61ee527644
commit
45bccd716e
4 changed files with 20 additions and 93 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.131 2013/08/13 17:07:32 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.132 2013/10/17 07:56:36 adam Exp $
|
||||
|
||||
DISTNAME= curl-7.32.0
|
||||
DISTNAME= curl-7.33.0
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://curl.haxx.se/download/ \
|
||||
ftp://ftp.sunet.se/pub/www/utilities/curl/
|
||||
|
@ -24,7 +24,7 @@ CONFIGURE_ARGS+= --with-ca-path=${SSLCERTS}
|
|||
CONFIGURE_ARGS+= --with-zlib=${BUILDLINK_PREFIX.zlib}
|
||||
PKGCONFIG_OVERRIDE= libcurl.pc.in
|
||||
|
||||
INSTALLATION_DIRS= share/doc/curl share/examples/curl
|
||||
INSTALLATION_DIRS= share/doc/curl
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
|
@ -40,16 +40,9 @@ PRIVILEGED_STAGES+= clean
|
|||
.include "options.mk"
|
||||
|
||||
post-install:
|
||||
for _f in MANUAL TheArtOfHttpScripting FAQ \
|
||||
curl-config.pdf curl.pdf; do \
|
||||
${INSTALL_DATA} ${WRKSRC}/docs/$${_f} \
|
||||
${DESTDIR}${PREFIX}/share/doc/curl/${_f}; \
|
||||
done
|
||||
for _f in ${WRKSRC}/docs/examples/*.c \
|
||||
${WRKSRC}/docs/examples/README; do \
|
||||
${INSTALL_DATA} $${_f} \
|
||||
${DESTDIR}${PREFIX}/share/examples/curl; \
|
||||
done
|
||||
.for f in MANUAL TheArtOfHttpScripting FAQ
|
||||
${INSTALL_DATA} ${WRKSRC}/docs/${f} ${DESTDIR}${PREFIX}/share/doc/curl/
|
||||
.endfor
|
||||
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.41 2013/08/13 17:07:32 adam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.42 2013/10/17 07:56:36 adam Exp $
|
||||
bin/curl
|
||||
bin/curl-config
|
||||
include/curl/curl.h
|
||||
|
@ -71,69 +71,3 @@ man/man3/libcurl.3
|
|||
share/doc/curl/FAQ
|
||||
share/doc/curl/MANUAL
|
||||
share/doc/curl/TheArtOfHttpScripting
|
||||
share/doc/curl/curl-config.pdf
|
||||
share/doc/curl/curl.pdf
|
||||
share/examples/curl/10-at-a-time.c
|
||||
share/examples/curl/README
|
||||
share/examples/curl/anyauthput.c
|
||||
share/examples/curl/cacertinmem.c
|
||||
share/examples/curl/certinfo.c
|
||||
share/examples/curl/chkspeed.c
|
||||
share/examples/curl/cookie_interface.c
|
||||
share/examples/curl/curlgtk.c
|
||||
share/examples/curl/curlx.c
|
||||
share/examples/curl/debug.c
|
||||
share/examples/curl/evhiperfifo.c
|
||||
share/examples/curl/externalsocket.c
|
||||
share/examples/curl/fileupload.c
|
||||
share/examples/curl/fopen.c
|
||||
share/examples/curl/ftp-wildcard.c
|
||||
share/examples/curl/ftpget.c
|
||||
share/examples/curl/ftpgetinfo.c
|
||||
share/examples/curl/ftpgetresp.c
|
||||
share/examples/curl/ftpsget.c
|
||||
share/examples/curl/ftpupload.c
|
||||
share/examples/curl/ftpuploadresume.c
|
||||
share/examples/curl/getinfo.c
|
||||
share/examples/curl/getinmemory.c
|
||||
share/examples/curl/ghiper.c
|
||||
share/examples/curl/hiperfifo.c
|
||||
share/examples/curl/href_extractor.c
|
||||
share/examples/curl/htmltidy.c
|
||||
share/examples/curl/http-post.c
|
||||
share/examples/curl/httpcustomheader.c
|
||||
share/examples/curl/httpput.c
|
||||
share/examples/curl/https.c
|
||||
share/examples/curl/imap.c
|
||||
share/examples/curl/multi-app.c
|
||||
share/examples/curl/multi-debugcallback.c
|
||||
share/examples/curl/multi-double.c
|
||||
share/examples/curl/multi-post.c
|
||||
share/examples/curl/multi-single.c
|
||||
share/examples/curl/multi-uv.c
|
||||
share/examples/curl/multithread.c
|
||||
share/examples/curl/opensslthreadlock.c
|
||||
share/examples/curl/persistant.c
|
||||
share/examples/curl/pop3s.c
|
||||
share/examples/curl/pop3slist.c
|
||||
share/examples/curl/post-callback.c
|
||||
share/examples/curl/postit2.c
|
||||
share/examples/curl/progressfunc.c
|
||||
share/examples/curl/resolve.c
|
||||
share/examples/curl/rtsp.c
|
||||
share/examples/curl/sampleconv.c
|
||||
share/examples/curl/sendrecv.c
|
||||
share/examples/curl/sepheaders.c
|
||||
share/examples/curl/sftpget.c
|
||||
share/examples/curl/simple.c
|
||||
share/examples/curl/simplepost.c
|
||||
share/examples/curl/simplesmtp.c
|
||||
share/examples/curl/simplessl.c
|
||||
share/examples/curl/smooth-gtk-thread.c
|
||||
share/examples/curl/smtp-multi.c
|
||||
share/examples/curl/smtp-tls.c
|
||||
share/examples/curl/synctime.c
|
||||
share/examples/curl/threaded-ssl.c
|
||||
share/examples/curl/url2file.c
|
||||
share/examples/curl/usercertinmem.c
|
||||
share/examples/curl/xmlstream.c
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.89 2013/10/12 04:31:48 richard Exp $
|
||||
$NetBSD: distinfo,v 1.90 2013/10/17 07:56:36 adam Exp $
|
||||
|
||||
SHA1 (curl-7.32.0.tar.bz2) = f6989fca0dac0c35628523436fc17869972d4251
|
||||
RMD160 (curl-7.32.0.tar.bz2) = 897c8eb19375774ac101f64251cc60712f37cbb2
|
||||
Size (curl-7.32.0.tar.bz2) = 2727587 bytes
|
||||
SHA1 (patch-aa) = 162b312c8f319d792e735344a8a0a5b04b61da50
|
||||
SHA1 (curl-7.33.0.tar.bz2) = b0dc79066f31a000190fd8a15277738e8c1940aa
|
||||
RMD160 (curl-7.33.0.tar.bz2) = 8041110d4abd7663ad427f67127010bcf14e05f5
|
||||
Size (curl-7.33.0.tar.bz2) = 2747507 bytes
|
||||
SHA1 (patch-aa) = 2f7f02985ba2063272a3d39334fd0a74c7db3269
|
||||
SHA1 (patch-curl-config.in) = 0dd49de806865c19fbf766ad208f8f2495824442
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
$NetBSD: patch-aa,v 1.23 2013/10/12 04:31:48 richard Exp $
|
||||
$NetBSD: patch-aa,v 1.24 2013/10/17 07:56:36 adam Exp $
|
||||
|
||||
builtin krb5-config in platforms such as solaris do not support
|
||||
the gssapi option, and need an explicit -lgss
|
||||
|
||||
--- configure.orig 2013-08-05 11:28:53.000000000 +0000
|
||||
--- configure.orig 2013-10-12 20:24:48.000000000 +0000
|
||||
+++ configure
|
||||
@@ -3646,6 +3646,7 @@ $as_echo "$as_me: $xc_bad_var_msg librar
|
||||
@@ -3642,6 +3642,7 @@ $as_echo "$as_me: $xc_bad_var_msg librar
|
||||
;;
|
||||
esac
|
||||
done
|
||||
|
@ -13,7 +13,7 @@ the gssapi option, and need an explicit -lgss
|
|||
if test $xc_bad_var_cflags = yes; then
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: using CFLAGS: $CFLAGS" >&5
|
||||
$as_echo "$as_me: using CFLAGS: $CFLAGS" >&6;}
|
||||
@@ -16644,7 +16645,7 @@ squeeze() {
|
||||
@@ -16614,7 +16615,7 @@ squeeze() {
|
||||
|
||||
|
||||
#
|
||||
|
@ -22,8 +22,8 @@ the gssapi option, and need an explicit -lgss
|
|||
#
|
||||
if test "$compiler_id" = "GNU_C" ||
|
||||
test "$compiler_id" = "CLANG"; then
|
||||
@@ -21360,7 +21361,12 @@ $as_echo "yes" >&6; }
|
||||
|
||||
@@ -21072,7 +21073,12 @@ $as_echo "yes" >&6; }
|
||||
|
||||
if test -z "$GSSAPI_INCS"; then
|
||||
if test -f "$GSSAPI_ROOT/bin/krb5-config"; then
|
||||
- GSSAPI_INCS=`$GSSAPI_ROOT/bin/krb5-config --cflags gssapi`
|
||||
|
@ -36,7 +36,7 @@ the gssapi option, and need an explicit -lgss
|
|||
elif test "$GSSAPI_ROOT" != "yes"; then
|
||||
GSSAPI_INCS="-I$GSSAPI_ROOT/include"
|
||||
fi
|
||||
@@ -21502,19 +21508,24 @@ $as_echo "#define HAVE_GSSAPI 1" >>confd
|
||||
@@ -21214,19 +21220,24 @@ $as_echo "#define HAVE_GSSAPI 1" >>confd
|
||||
;;
|
||||
*)
|
||||
if test -f "$GSSAPI_ROOT/bin/krb5-config"; then
|
||||
|
@ -65,7 +65,7 @@ the gssapi option, and need an explicit -lgss
|
|||
fi
|
||||
else
|
||||
CPPFLAGS="$save_CPPFLAGS"
|
||||
@@ -25080,19 +25091,19 @@ $as_echo "$as_me: WARNING: You need an l
|
||||
@@ -24793,19 +24804,19 @@ $as_echo "$as_me: WARNING: You need an l
|
||||
$as_echo "yes" >&6; }
|
||||
if test "x$OPENSSL_ENABLED" = "x1"; then
|
||||
versioned_symbols_flavour="OPENSSL_"
|
||||
|
|
Loading…
Reference in a new issue