Update to 0.4.
Changelog: 0.4 @ 2013-05-16 Fix buggy handling of -k option. Add --remote (-e) and --stripprefix (-s) options. Avoid recursion overflow on very large repos. The fast-import stream ops are now emitted in the same order git uses.
This commit is contained in:
parent
4fbaaa8e55
commit
45e2a6f338
4 changed files with 13 additions and 34 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.1 2013/04/20 09:40:49 apb Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2013/05/26 01:52:40 ryoon Exp $
|
||||
#
|
||||
|
||||
DISTNAME= cvs-fast-export-0.3
|
||||
DISTNAME= cvs-fast-export-0.4
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.catb.org/~esr/cvs-fast-export/
|
||||
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1 2013/04/20 09:40:49 apb Exp $
|
||||
$NetBSD: distinfo,v 1.2 2013/05/26 01:52:40 ryoon Exp $
|
||||
|
||||
SHA1 (cvs-fast-export-0.3.tar.gz) = 03da5312869f5889461172a2246055ba3d6be9d4
|
||||
RMD160 (cvs-fast-export-0.3.tar.gz) = 31af843e66bfe57d5256ef80a79138be66f97701
|
||||
Size (cvs-fast-export-0.3.tar.gz) = 45418 bytes
|
||||
SHA1 (patch-Makefile) = 262d99114bbce916e665f3263b80983ed5ae1cdd
|
||||
SHA1 (patch-main.c) = 521d6a11d87d880c2f4baac1ec51e861ce4aa9ab
|
||||
SHA1 (cvs-fast-export-0.4.tar.gz) = 528fa1881996c93b4afb3652b8445d2ec6bfd09e
|
||||
RMD160 (cvs-fast-export-0.4.tar.gz) = 7fdd19bfd050bac1a6f46fee6245922b2314553e
|
||||
Size (cvs-fast-export-0.4.tar.gz) = 83390 bytes
|
||||
SHA1 (patch-Makefile) = abbc0f75ba1276630588d3787805888f471633bf
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: patch-Makefile,v 1.1 2013/04/20 09:40:49 apb Exp $
|
||||
$NetBSD: patch-Makefile,v 1.2 2013/05/26 01:52:40 ryoon Exp $
|
||||
|
||||
* Add "all" target.
|
||||
* Use ${PREFIX} variable.
|
||||
* Install man pages in ${PREFIX}/${PKGMANDIR}, not ${PREFIX}/share/man.
|
||||
|
||||
--- Makefile.orig 2013-01-16 16:23:51.000000000 +0000
|
||||
--- Makefile.orig 2013-05-16 16:52:16.000000000 +0000
|
||||
+++ Makefile
|
||||
@@ -2,9 +2,12 @@
|
||||
#
|
||||
|
@ -18,9 +18,9 @@ $NetBSD: patch-Makefile,v 1.1 2013/04/20 09:40:49 apb Exp $
|
|||
target=$(DESTDIR)$(prefix)
|
||||
+mandir=$(PKGMANDIR)
|
||||
|
||||
VERSION=0.3
|
||||
VERSION=0.4
|
||||
|
||||
@@ -47,9 +50,9 @@ clean:
|
||||
@@ -49,9 +52,9 @@ clean:
|
||||
|
||||
install: cvs-fast-export.1 all
|
||||
$(INSTALL) -d "$(target)/bin"
|
||||
|
@ -30,5 +30,5 @@ $NetBSD: patch-Makefile,v 1.1 2013/04/20 09:40:49 apb Exp $
|
|||
- $(INSTALL) -m 644 cvs-fast-export.1 "$(target)/share/man/man1"
|
||||
+ $(INSTALL) -m 644 cvs-fast-export.1 "$(target)/$(mandir)/man1"
|
||||
|
||||
cppcheck:
|
||||
cppcheck --template gcc --enable=all -UUNUSED --suppress=unusedStructMember *.[ch]
|
||||
# Weird suppressions are required because of strange tricks in Bison.
|
||||
SUPPRESSIONS = -U__UNUSED__ -UYYPARSE_PARAM -UYYTYPE_INT16 -UYYTYPE_INT8 \
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
$NetBSD: patch-main.c,v 1.1 2013/04/20 09:40:49 apb Exp $
|
||||
|
||||
Fix parsing of "-k" and "--reposurgeon" command line options.
|
||||
Patch has been sent upstream, in email dated 25 Mar 2013.
|
||||
|
||||
--- main.c.orig 2013-01-14 00:17:55.000000000 +0000
|
||||
+++ main.c
|
||||
@@ -410,10 +410,10 @@ main (int argc, char **argv)
|
||||
{ "commit-time-window", 1, 0, 'w' },
|
||||
{ "author-map", 1, 0, 'A' },
|
||||
{ "revision-map", 1, 0, 'R' },
|
||||
- { "reposurgeon", 1, 0, 'r' },
|
||||
+ { "reposurgeon", 0, 0, 'r' },
|
||||
{ "graph", 0, 0, 'g' },
|
||||
};
|
||||
- int c = getopt_long(argc, argv, "+hVw:grvA:R:T", options, NULL);
|
||||
+ int c = getopt_long(argc, argv, "+hkVw:grvA:R:T", options, NULL);
|
||||
if (c < 0)
|
||||
break;
|
||||
switch (c) {
|
Loading…
Reference in a new issue