memtestplus: disable 'Block move' test as a hack.
The setup of this test causes hangs and reboots. I'm not sure if it's working, because time doesn't appear to be moving. Helps PR pkg/52962: memtestplus doesn't work if built with recent compilers.
This commit is contained in:
parent
f28e81d4ba
commit
45fdf5c1cf
3 changed files with 18 additions and 5 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.23 2018/01/29 11:52:10 maya Exp $
|
||||
# $NetBSD: Makefile,v 1.24 2018/01/29 13:55:30 maya Exp $
|
||||
#
|
||||
|
||||
# Note -- version number also in the do-install rule
|
||||
|
@ -7,7 +7,7 @@ MINVER=01
|
|||
|
||||
DISTNAME= memtest86+-${MAJVER}.${MINVER}
|
||||
PKGNAME= memtestplus-${MAJVER}.${MINVER}
|
||||
PKGREVISION= 2
|
||||
PKGREVISION= 3
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://www.memtest.org/download/${MAJVER}.${MINVER}/
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.13 2018/01/29 11:52:10 maya Exp $
|
||||
$NetBSD: distinfo,v 1.14 2018/01/29 13:55:30 maya Exp $
|
||||
|
||||
SHA1 (memtest86+-5.01.tar.gz) = eb4b6d70114db3c9ed320785da44c0ba8349c10c
|
||||
RMD160 (memtest86+-5.01.tar.gz) = 756b57d8f8a3b7408aba0b2fc0cadcdc1df966df
|
||||
|
@ -9,7 +9,7 @@ SHA1 (patch-ab) = 04ca819d23656c5a73625b457ad730c0cf33e751
|
|||
SHA1 (patch-ac) = 9186952e34139b4d4aab6c266a224921a4d39659
|
||||
SHA1 (patch-ad) = ab31fec30052fdd3c473ee885ba00d7e3676384f
|
||||
SHA1 (patch-controller.c) = 8509599b72f1f11115dc58605b0f438ddfca9b4a
|
||||
SHA1 (patch-main.c) = 82e1830d119394f83fa4fd69d492bcc38fe8946f
|
||||
SHA1 (patch-main.c) = 1d620fd9e1cc04a9fb739eb3c1e6515f8f8d5179
|
||||
SHA1 (patch-makeiso.sh) = 939056a96a1384e4d27772bf5612a755deca8145
|
||||
SHA1 (patch-nbstart.S) = d97a6e9c25a57d0f5510c3acf4dccf0f0c0c31b0
|
||||
SHA1 (patch-reboot.c) = 8103cb52d1a6e2cdb9099ad3535115617746ed26
|
||||
|
|
|
@ -1,7 +1,20 @@
|
|||
$NetBSD: patch-main.c,v 1.1 2015/03/21 02:18:39 tnn Exp $
|
||||
$NetBSD: patch-main.c,v 1.2 2018/01/29 13:55:30 maya Exp $
|
||||
|
||||
Disable one of the tests that causes reboots/hangs at setup
|
||||
(XXX figure out why - use btflag and btrace to debug this)
|
||||
Clang fix
|
||||
|
||||
--- main.c.orig 2013-08-10 02:01:58.000000000 +0000
|
||||
+++ main.c
|
||||
@@ -54,7 +54,7 @@ struct tseq tseq[] = {
|
||||
{1, 32, 3, 6, 0, "[Moving inversions, 1s & 0s Parallel] "},
|
||||
{1, 32, 5, 3, 0, "[Moving inversions, 8 bit pattern] "},
|
||||
{1, 32, 6, 30, 0, "[Moving inversions, random pattern] "},
|
||||
- {1, 32, 7, 81, 0, "[Block move] "},
|
||||
+ //{1, 32, 7, 81, 0, "[Block move] "},
|
||||
{1, 1, 8, 3, 0, "[Moving inversions, 32 bit pattern] "},
|
||||
{1, 32, 9, 48, 0, "[Random number sequence] "},
|
||||
{1, 32, 10, 6, 0, "[Modulo 20, Random pattern] "},
|
||||
@@ -217,7 +217,11 @@ static void run_at(unsigned long addr, i
|
||||
spin_lock(&barr->mutex);
|
||||
|
||||
|
|
Loading…
Reference in a new issue