add qt4-creator-1.3.1, a QT4 IDE, from fw@submerge.ch per pkgsrc-wip
(just changed the distfile to .tar.gz because the .zip doesn't extract properly with pkgsrc's unzip)
This commit is contained in:
parent
50bd871c06
commit
463f5f9e42
16 changed files with 410 additions and 0 deletions
10
x11/qt4-creator/DESCR
Normal file
10
x11/qt4-creator/DESCR
Normal file
|
@ -0,0 +1,10 @@
|
|||
Qt Creator is a new cross-platform integrated development environment (IDE)
|
||||
tailored to the needs of Qt developers. It includes:
|
||||
|
||||
* An advanced C++ code editor
|
||||
* Integrated GUI layout and forms designer
|
||||
* Project and build management tools
|
||||
* Integrated, context-sensitive help system
|
||||
* Visual debugger
|
||||
* Rapid code navigation tools
|
||||
* Supports multiple platforms
|
66
x11/qt4-creator/Makefile
Normal file
66
x11/qt4-creator/Makefile
Normal file
|
@ -0,0 +1,66 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2010/05/18 19:44:01 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= qt-creator-1.3.1-src
|
||||
PKGNAME= qt4-creator-1.3.1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://get.qt.nokia.com/qtcreator/
|
||||
|
||||
MAINTAINER= fw@submerge.ch
|
||||
HOMEPAGE= http://www.qtsoftware.com/
|
||||
COMMENT= Cross-platform IDE for Qt and C++
|
||||
LICENSE= gnu-lgpl-v2.1
|
||||
|
||||
USE_LANGUAGES= c c++
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= gmake
|
||||
|
||||
INSTALLATION_DIRS= bin lib/qtcreator lib/qtcreator/plugins/Nokia \
|
||||
share/doc/qtcreator share/pixmaps share/qtcreator \
|
||||
share/qtcreator/translations
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
BUILD_DEPENDS+= qt4-tools>=4.6.0:../../x11/qt4-tools \
|
||||
qt4-sqlite3>=4.6.0:../../x11/qt4-sqlite3
|
||||
|
||||
BUILD_TARGET= make_default qch_docs
|
||||
MAKE_ENV+= PREFIX=${PREFIX}
|
||||
|
||||
do-configure:
|
||||
cd ${WRKSRC} && env ${CONFIGURE_ENV} ${QTDIR}/bin/qmake
|
||||
|
||||
do-install:
|
||||
${LIBTOOL} --mode=install \
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bin/qtcreator.bin \
|
||||
${DESTDIR}${PREFIX}/bin/qtcreator
|
||||
${LIBTOOL} --mode=install \
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bin/qtcreator_process_stub \
|
||||
${DESTDIR}${PREFIX}/bin/
|
||||
${LIBTOOL} --mode=install \
|
||||
${INSTALL_LIB} ${WRKSRC}/lib/qtcreator/*.la \
|
||||
${DESTDIR}${PREFIX}/lib/qtcreator/
|
||||
${LIBTOOL} --mode=install \
|
||||
${INSTALL_LIB} ${WRKSRC}/lib/qtcreator/plugins/Nokia/*.la \
|
||||
${DESTDIR}${PREFIX}/lib/qtcreator/plugins/Nokia/
|
||||
${LIBTOOL} --mode=install \
|
||||
${INSTALL_DATA} ${WRKSRC}/lib/qtcreator/plugins/Nokia/*.pluginspec \
|
||||
${DESTDIR}${PREFIX}/lib/qtcreator/plugins/Nokia/
|
||||
${INSTALL_DATA} \
|
||||
${WRKSRC}/src/plugins/coreplugin/images/qtcreator_logo*.png \
|
||||
${DESTDIR}${PREFIX}/share/pixmaps/
|
||||
${INSTALL_DATA} ${WRKSRC}/share/doc/qtcreator/qtcreator.qch \
|
||||
${DESTDIR}${PREFIX}/share/doc/qtcreator/
|
||||
${INSTALL_DATA} ${WRKSRC}/share/qtcreator/translations/*.qm \
|
||||
${DESTDIR}${PREFIX}/share/qtcreator/translations/
|
||||
cd ${WRKSRC}/share/qtcreator && ${FIND} designer gdbmacros \
|
||||
schemes snippets templates -type d -exec \
|
||||
${INSTALL_DATA_DIR} "${WRKSRC}/share/qtcreator/{}" \
|
||||
"${DESTDIR}${PREFIX}/share/qtcreator/{}" ";"
|
||||
cd ${WRKSRC}/share/qtcreator && ${FIND} designer gdbmacros \
|
||||
schemes snippets templates -type f \! -name "*.orig" -exec \
|
||||
${INSTALL_DATA} "${WRKSRC}/share/qtcreator/{}" \
|
||||
"${DESTDIR}${PREFIX}/share/qtcreator/{}" ";"
|
||||
|
||||
|
||||
.include "../../x11/qt4-tools/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
120
x11/qt4-creator/PLIST
Normal file
120
x11/qt4-creator/PLIST
Normal file
|
@ -0,0 +1,120 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2010/05/18 19:44:01 drochner Exp $
|
||||
bin/qtcreator
|
||||
bin/qtcreator_process_stub
|
||||
lib/qtcreator/libAggregation.la
|
||||
lib/qtcreator/libCPlusPlus.la
|
||||
lib/qtcreator/libDebuggingHelper.la
|
||||
lib/qtcreator/libExtensionSystem.la
|
||||
lib/qtcreator/libQtConcurrent.la
|
||||
lib/qtcreator/libUtils.la
|
||||
lib/qtcreator/plugins/Nokia/BinEditor.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/Bookmarks.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/CMakeProjectManager.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/CVS.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/CodePaster.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/Core.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/CppEditor.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/CppTools.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/Debugger.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/Designer.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/FakeVim.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/Find.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/GenericProjectManager.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/Help.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/Locator.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/Perforce.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/ProjectExplorer.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/QmlEditor.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/QmlProjectManager.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/Qt4ProjectManager.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/QtScriptEditor.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/ResourceEditor.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/ScmGit.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/Subversion.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/TextEditor.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/VCSBase.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/Welcome.pluginspec
|
||||
lib/qtcreator/plugins/Nokia/libBinEditor.la
|
||||
lib/qtcreator/plugins/Nokia/libBookmarks.la
|
||||
lib/qtcreator/plugins/Nokia/libCMakeProjectManager.la
|
||||
lib/qtcreator/plugins/Nokia/libCVS.la
|
||||
lib/qtcreator/plugins/Nokia/libCodePaster.la
|
||||
lib/qtcreator/plugins/Nokia/libCore.la
|
||||
lib/qtcreator/plugins/Nokia/libCppEditor.la
|
||||
lib/qtcreator/plugins/Nokia/libCppTools.la
|
||||
lib/qtcreator/plugins/Nokia/libDebugger.la
|
||||
lib/qtcreator/plugins/Nokia/libDesigner.la
|
||||
lib/qtcreator/plugins/Nokia/libFakeVim.la
|
||||
lib/qtcreator/plugins/Nokia/libFind.la
|
||||
lib/qtcreator/plugins/Nokia/libGenericProjectManager.la
|
||||
lib/qtcreator/plugins/Nokia/libHelp.la
|
||||
lib/qtcreator/plugins/Nokia/libLocator.la
|
||||
lib/qtcreator/plugins/Nokia/libPerforce.la
|
||||
lib/qtcreator/plugins/Nokia/libProjectExplorer.la
|
||||
lib/qtcreator/plugins/Nokia/libQmlEditor.la
|
||||
lib/qtcreator/plugins/Nokia/libQmlProjectManager.la
|
||||
lib/qtcreator/plugins/Nokia/libQt4ProjectManager.la
|
||||
lib/qtcreator/plugins/Nokia/libQtScriptEditor.la
|
||||
lib/qtcreator/plugins/Nokia/libResourceEditor.la
|
||||
lib/qtcreator/plugins/Nokia/libScmGit.la
|
||||
lib/qtcreator/plugins/Nokia/libSubversion.la
|
||||
lib/qtcreator/plugins/Nokia/libTextEditor.la
|
||||
lib/qtcreator/plugins/Nokia/libVCSBase.la
|
||||
lib/qtcreator/plugins/Nokia/libWelcome.la
|
||||
share/doc/qtcreator/qtcreator.qch
|
||||
share/pixmaps/qtcreator_logo_128.png
|
||||
share/pixmaps/qtcreator_logo_16.png
|
||||
share/pixmaps/qtcreator_logo_24.png
|
||||
share/pixmaps/qtcreator_logo_256.png
|
||||
share/pixmaps/qtcreator_logo_32.png
|
||||
share/pixmaps/qtcreator_logo_48.png
|
||||
share/pixmaps/qtcreator_logo_512.png
|
||||
share/pixmaps/qtcreator_logo_64.png
|
||||
share/qtcreator/designer/templates.xml
|
||||
share/qtcreator/designer/templates/Dialog_with_Buttons_Bottom.ui
|
||||
share/qtcreator/designer/templates/Dialog_with_Buttons_Right.ui
|
||||
share/qtcreator/designer/templates/Dialog_without_Buttons.ui
|
||||
share/qtcreator/designer/templates/Main_Window.ui
|
||||
share/qtcreator/designer/templates/Widget.ui
|
||||
share/qtcreator/gdbmacros/LGPL_EXCEPTION.TXT
|
||||
share/qtcreator/gdbmacros/LICENSE.LGPL
|
||||
share/qtcreator/gdbmacros/gdbmacros.cpp
|
||||
share/qtcreator/gdbmacros/gdbmacros.h
|
||||
share/qtcreator/gdbmacros/gdbmacros.pro
|
||||
share/qtcreator/gdbmacros/gdbmacros_p.h
|
||||
share/qtcreator/gdbmacros/test/dumpertest.pro
|
||||
share/qtcreator/gdbmacros/test/main.cpp
|
||||
share/qtcreator/schemes/MS_Visual_C++.kms
|
||||
share/qtcreator/schemes/Xcode.kms
|
||||
share/qtcreator/snippets/class_generic.snp
|
||||
share/qtcreator/snippets/class_qobject.snp
|
||||
share/qtcreator/snippets/class_qwidget.snp
|
||||
share/qtcreator/snippets/comment.snp
|
||||
share/qtcreator/snippets/for.snp
|
||||
share/qtcreator/snippets/foreach.snp
|
||||
share/qtcreator/snippets/if.snp
|
||||
share/qtcreator/snippets/ifelse.snp
|
||||
share/qtcreator/templates/qt4project/customwidgetwizard/tpl_collection.cpp
|
||||
share/qtcreator/templates/qt4project/customwidgetwizard/tpl_collection.h
|
||||
share/qtcreator/templates/qt4project/customwidgetwizard/tpl_plugin.pro
|
||||
share/qtcreator/templates/qt4project/customwidgetwizard/tpl_resources.qrc
|
||||
share/qtcreator/templates/qt4project/customwidgetwizard/tpl_single.cpp
|
||||
share/qtcreator/templates/qt4project/customwidgetwizard/tpl_single.h
|
||||
share/qtcreator/templates/qt4project/customwidgetwizard/tpl_widget.cpp
|
||||
share/qtcreator/templates/qt4project/customwidgetwizard/tpl_widget.h
|
||||
share/qtcreator/templates/qt4project/customwidgetwizard/tpl_widget_include.pri
|
||||
share/qtcreator/templates/qt4project/customwidgetwizard/tpl_widget_lib.pro
|
||||
share/qtcreator/templates/qt4project/main.cpp
|
||||
share/qtcreator/templates/qt4project/mywidget.cpp
|
||||
share/qtcreator/templates/qt4project/mywidget.h
|
||||
share/qtcreator/templates/qt4project/mywidget_form.cpp
|
||||
share/qtcreator/templates/qt4project/mywidget_form.h
|
||||
share/qtcreator/templates/qt4project/widget.ui
|
||||
share/qtcreator/translations/qtcreator_de.qm
|
||||
share/qtcreator/translations/qtcreator_es.qm
|
||||
share/qtcreator/translations/qtcreator_fr.qm
|
||||
share/qtcreator/translations/qtcreator_it.qm
|
||||
share/qtcreator/translations/qtcreator_ja.qm
|
||||
share/qtcreator/translations/qtcreator_pl.qm
|
||||
share/qtcreator/translations/qtcreator_ru.qm
|
||||
share/qtcreator/translations/qtcreator_sl.qm
|
17
x11/qt4-creator/distinfo
Normal file
17
x11/qt4-creator/distinfo
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2010/05/18 19:44:02 drochner Exp $
|
||||
|
||||
SHA1 (qt-creator-1.3.1-src.tar.gz) = 49b61c3e8010d94d6d595fef38d3da737b26cd80
|
||||
RMD160 (qt-creator-1.3.1-src.tar.gz) = 37bebc4566cfef85d5a7901c1efd8b917b3a0584
|
||||
Size (qt-creator-1.3.1-src.tar.gz) = 10623442 bytes
|
||||
SHA1 (patch-aa) = 908f98fcfcd7341aef924efa74938409b51e5b09
|
||||
SHA1 (patch-ab) = f0acd533050e7f310dba5981eef0f51992d3a41c
|
||||
SHA1 (patch-ac) = 80f3a0669ba9c830ac9ddc79dd0e56bbc95bb693
|
||||
SHA1 (patch-ad) = d416f3d5f0e28f2b825aa3943499f0cd9896e8b6
|
||||
SHA1 (patch-ae) = 8fa1abb214473b438926d5c0d8cec7671f5c8397
|
||||
SHA1 (patch-af) = 199ab3a05c40c9d171e553713ea560367952995e
|
||||
SHA1 (patch-ag) = bbfd6e80e323f0a1cf11bc5ef345d2a23edcffc5
|
||||
SHA1 (patch-ah) = 56000810ffefa7fbb12d3d36bc656b428c7231cc
|
||||
SHA1 (patch-ai) = 6bf785c891cf8a41ce23810975a9c7b3f8afa5b1
|
||||
SHA1 (patch-aj) = 82e4a688fc287e08c0c425d601e78f95252d5011
|
||||
SHA1 (patch-ak) = 5c33cd0733f84c850856bf7c178fdb0596e1592b
|
||||
SHA1 (patch-al) = b8e116a70ec00c4b5bb50f5c2181d438e81de54f
|
13
x11/qt4-creator/patches/patch-aa
Normal file
13
x11/qt4-creator/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2010/05/18 19:44:02 drochner Exp $
|
||||
|
||||
--- doc/doc.pri.orig 2010-01-15 17:36:52 +0000
|
||||
+++ doc/doc.pri
|
||||
@@ -24,7 +24,7 @@ qch_docs.depends += html_docs
|
||||
qch_docs.files = $$QCH_FILE
|
||||
|
||||
unix:!macx {
|
||||
- qch_docs.path = /share/doc/qtcreator
|
||||
+ qch_docs.path = $(PREFIX)/share/doc/qtcreator
|
||||
qch_docs.CONFIG += no_check_exist
|
||||
INSTALLS += qch_docs
|
||||
}
|
11
x11/qt4-creator/patches/patch-ab
Normal file
11
x11/qt4-creator/patches/patch-ab
Normal file
|
@ -0,0 +1,11 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2010/05/18 19:44:02 drochner Exp $
|
||||
|
||||
--- share/qtcreator/gdbmacros/gdbmacros.pro.orig 2010-01-15 17:36:52 +0000
|
||||
+++ share/qtcreator/gdbmacros/gdbmacros.pro
|
||||
@@ -16,3 +16,6 @@ else {
|
||||
}
|
||||
exists($$QMAKE_INCDIR_QT/QtCore/private/qobject_p.h):DEFINES += HAS_QOBJECT_P_H
|
||||
HEADERS += gdbmacros_p.h
|
||||
+
|
||||
+target.path = $$OUT_PWD
|
||||
+INSTALLS += target
|
31
x11/qt4-creator/patches/patch-ac
Normal file
31
x11/qt4-creator/patches/patch-ac
Normal file
|
@ -0,0 +1,31 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2010/05/18 19:44:02 drochner Exp $
|
||||
|
||||
--- share/qtcreator/static.pro.orig 2010-01-15 17:36:52 +0000
|
||||
+++ share/qtcreator/static.pro
|
||||
@@ -6,7 +6,7 @@ CONFIG -= qt
|
||||
QT =
|
||||
LIBS =
|
||||
|
||||
-isEmpty(vcproj) {
|
||||
+!isEmpty(vcproj) {
|
||||
QMAKE_LINK = @: IGNORE THIS LINE
|
||||
OBJECTS_DIR =
|
||||
win32:CONFIG -= embed_manifest_exe
|
||||
@@ -16,7 +16,7 @@ isEmpty(vcproj) {
|
||||
phony_src.input = PHONY_DEPS
|
||||
phony_src.output = phony.c
|
||||
phony_src.variable_out = GENERATED_SOURCES
|
||||
- phony_src.commands = echo int main() { return 0; } > phony.c
|
||||
+ phony_src.commands = echo \"int main() { return 0; }\" > phony.c
|
||||
phony_src.name = CREATE phony.c
|
||||
phony_src.CONFIG += combine
|
||||
QMAKE_EXTRA_COMPILERS += phony_src
|
||||
@@ -60,7 +60,7 @@ DATA_DIRS = \
|
||||
!macx {
|
||||
for(data_dir, DATA_DIRS) {
|
||||
eval($${data_dir}.files = $$quote($$PWD/$$data_dir))
|
||||
- eval($${data_dir}.path = /share/qtcreator)
|
||||
+ eval($${data_dir}.path = $(PREFIX)/share/qtcreator)
|
||||
INSTALLS += $$data_dir
|
||||
}
|
||||
}
|
29
x11/qt4-creator/patches/patch-ad
Normal file
29
x11/qt4-creator/patches/patch-ad
Normal file
|
@ -0,0 +1,29 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2010/05/18 19:44:02 drochner Exp $
|
||||
|
||||
--- share/qtcreator/translations/translations.pro.orig 2010-01-15 17:36:52 +0000
|
||||
+++ share/qtcreator/translations/translations.pro
|
||||
@@ -43,7 +43,7 @@ updateqm.name = LRELEASE ${QMAKE_FILE_IN
|
||||
updateqm.CONFIG += no_link
|
||||
QMAKE_EXTRA_COMPILERS += updateqm
|
||||
|
||||
-isEmpty(vcproj) {
|
||||
+!isEmpty(vcproj) {
|
||||
QMAKE_LINK = @: IGNORE THIS LINE
|
||||
OBJECTS_DIR =
|
||||
win32:CONFIG -= embed_manifest_exe
|
||||
@@ -53,13 +53,13 @@ isEmpty(vcproj) {
|
||||
phony_src.input = PHONY_DEPS
|
||||
phony_src.output = phony.c
|
||||
phony_src.variable_out = GENERATED_SOURCES
|
||||
- phony_src.commands = echo int main() { return 0; } > phony.c
|
||||
+ phony_src.commands = echo \"int main() { return 0; }\" > phony.c
|
||||
phony_src.name = CREATE phony.c
|
||||
phony_src.CONFIG += combine
|
||||
QMAKE_EXTRA_COMPILERS += phony_src
|
||||
}
|
||||
|
||||
qmfiles.files = $$prependAll(LANGUAGES, $$OUT_PWD/qtcreator_,.qm)
|
||||
-qmfiles.path = /share/qtcreator/translations
|
||||
+qmfiles.path = $(PREFIX)/share/qtcreator/translations
|
||||
qmfiles.CONFIG += no_check_exist
|
||||
INSTALLS += qmfiles
|
13
x11/qt4-creator/patches/patch-ae
Normal file
13
x11/qt4-creator/patches/patch-ae
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ae,v 1.1.1.1 2010/05/18 19:44:02 drochner Exp $
|
||||
|
||||
--- src/app/app.pro.orig 2010-01-15 17:36:52 +0000
|
||||
+++ src/app/app.pro
|
||||
@@ -28,7 +28,7 @@ win32 {
|
||||
} else {
|
||||
LIBS *= -lExtensionSystem -lAggregation
|
||||
|
||||
- target.path = /bin
|
||||
+ target.path = $(PREFIX)/bin
|
||||
INSTALLS += target
|
||||
}
|
||||
|
13
x11/qt4-creator/patches/patch-af
Normal file
13
x11/qt4-creator/patches/patch-af
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-af,v 1.1.1.1 2010/05/18 19:44:02 drochner Exp $
|
||||
|
||||
--- src/libs/extensionsystem/extensionsystem.pro.orig 2010-01-15 17:36:52 +0000
|
||||
+++ src/libs/extensionsystem/extensionsystem.pro
|
||||
@@ -4,7 +4,7 @@ DEFINES += EXTENSIONSYSTEM_LIBRARY
|
||||
include(../../qtcreatorlibrary.pri)
|
||||
include(extensionsystem_dependencies.pri)
|
||||
|
||||
-unix:!macx:!freebsd*:LIBS += -ldl
|
||||
+unix:!macx:!freebsd*:!netbsd*:LIBS += -ldl
|
||||
|
||||
DEFINES += IDE_TEST_DIR=\\\"$$IDE_SOURCE_TREE\\\"
|
||||
|
11
x11/qt4-creator/patches/patch-ag
Normal file
11
x11/qt4-creator/patches/patch-ag
Normal file
|
@ -0,0 +1,11 @@
|
|||
$NetBSD: patch-ag,v 1.1.1.1 2010/05/18 19:44:02 drochner Exp $
|
||||
|
||||
--- src/libs/utils/process_stub.pro.orig 2010-01-15 17:36:52 +0000
|
||||
+++ src/libs/utils/process_stub.pro
|
||||
@@ -20,5 +20,5 @@ unix {
|
||||
LIBS += -lshell32
|
||||
}
|
||||
|
||||
-target.path = /bin # FIXME: libexec, more or less
|
||||
+target.path = $(PREFIX)/bin # FIXME: libexec, more or less
|
||||
INSTALLS += target
|
13
x11/qt4-creator/patches/patch-ah
Normal file
13
x11/qt4-creator/patches/patch-ah
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ah,v 1.1.1.1 2010/05/18 19:44:02 drochner Exp $
|
||||
|
||||
--- src/plugins/coreplugin/coreplugin.pro.orig 2010-01-15 17:36:52 +0000
|
||||
+++ src/plugins/coreplugin/coreplugin.pro
|
||||
@@ -168,7 +168,7 @@ RESOURCES += core.qrc \
|
||||
fancyactionbar.qrc
|
||||
unix:!macx {
|
||||
images.files = images/qtcreator_logo_*.png
|
||||
- images.path = /share/pixmaps
|
||||
+ images.path = $(PREFIX)/share/pixmaps
|
||||
INSTALLS += images
|
||||
}
|
||||
OTHER_FILES += Core.pluginspec
|
22
x11/qt4-creator/patches/patch-ai
Normal file
22
x11/qt4-creator/patches/patch-ai
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ai,v 1.1.1.1 2010/05/18 19:44:02 drochner Exp $
|
||||
|
||||
--- src/plugins/debugger/gdb/gdbengine.cpp.orig 2010-01-15 17:36:52 +0000
|
||||
+++ src/plugins/debugger/gdb/gdbengine.cpp
|
||||
@@ -806,7 +806,7 @@ void GdbEngine::flushCommand(const GdbCo
|
||||
cmd.command = cmd.command.arg(currentToken());
|
||||
gdbInputAvailable(LogInput, cmd.command);
|
||||
|
||||
- m_gdbAdapter->write(cmd.command.toLatin1() + "\r\n");
|
||||
+ m_gdbAdapter->write(cmd.command.toLatin1() + "\n");
|
||||
|
||||
m_commandTimer->start();
|
||||
|
||||
@@ -996,7 +996,7 @@ void GdbEngine::executeDebuggerCommand(c
|
||||
return;
|
||||
}
|
||||
|
||||
- m_gdbAdapter->write(command.toLatin1() + "\r\n");
|
||||
+ m_gdbAdapter->write(command.toLatin1() + "\n");
|
||||
}
|
||||
|
||||
// Called from CoreAdapter and AttachAdapter
|
13
x11/qt4-creator/patches/patch-aj
Normal file
13
x11/qt4-creator/patches/patch-aj
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aj,v 1.1.1.1 2010/05/18 19:44:02 drochner Exp $
|
||||
|
||||
--- src/plugins/projectexplorer/debugginghelper.cpp.orig 2010-01-15 17:36:52 +0000
|
||||
+++ src/plugins/projectexplorer/debugginghelper.cpp
|
||||
@@ -217,7 +217,7 @@ QString DebuggingHelperLibrary::buildDeb
|
||||
output += newline;;
|
||||
if (!makeFullPath.isEmpty()) {
|
||||
output += QCoreApplication::translate("ProjectExplorer::DebuggingHelperLibrary", "Running %1 ...\n").arg(makeFullPath);
|
||||
- proc.start(makeFullPath, QStringList());
|
||||
+ proc.start(makeFullPath, QStringList() << "install");
|
||||
proc.waitForFinished();
|
||||
output += proc.readAll();
|
||||
} else {
|
13
x11/qt4-creator/patches/patch-ak
Normal file
13
x11/qt4-creator/patches/patch-ak
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ak,v 1.1.1.1 2010/05/18 19:44:02 drochner Exp $
|
||||
|
||||
--- src/qtcreatorlibrary.pri.orig 2010-01-15 17:36:52 +0000
|
||||
+++ src/qtcreatorlibrary.pri
|
||||
@@ -17,7 +17,7 @@ contains(QT_CONFIG, reduce_exports):CONF
|
||||
target.path = /bin
|
||||
target.files = $$DESTDIR/$${TARGET}.dll
|
||||
} else {
|
||||
- target.path = /$$IDE_LIBRARY_BASENAME/qtcreator
|
||||
+ target.path = $(PREFIX)/lib/qtcreator
|
||||
}
|
||||
INSTALLS += target
|
||||
}
|
15
x11/qt4-creator/patches/patch-al
Normal file
15
x11/qt4-creator/patches/patch-al
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-al,v 1.1.1.1 2010/05/18 19:44:02 drochner Exp $
|
||||
|
||||
--- src/qtcreatorplugin.pri.orig 2010-01-15 17:36:52 +0000
|
||||
+++ src/qtcreatorplugin.pri
|
||||
@@ -43,8 +43,8 @@ contains(QT_CONFIG, reduce_exports):CONF
|
||||
CONFIG += plugin plugin_with_soname
|
||||
|
||||
!macx {
|
||||
- target.path = /$$IDE_LIBRARY_BASENAME/qtcreator/plugins/$$PROVIDER
|
||||
+ target.path = $(PREFIX)/lib/qtcreator/plugins/$$PROVIDER
|
||||
pluginspec.files += $${TARGET}.pluginspec
|
||||
- pluginspec.path = /$$IDE_LIBRARY_BASENAME/qtcreator/plugins/$$PROVIDER
|
||||
+ pluginspec.path = $(PREFIX)/lib/qtcreator/plugins/$$PROVIDER
|
||||
INSTALLS += target pluginspec
|
||||
}
|
Loading…
Reference in a new issue