Changes 1.7.20:
* Removed the call to png_read_transform_info() when the system libpng is being used, so it can be built with a system libpng. Changes 1.7.19: * pngcrush-1.7.18 failed to read interlaced PNGs. Reverted the change from calling png_read_transform_info() to png_read_update_info(). Since png_read_transform_info() is not exported we again cannot build with the system libpng15. Changes 1.7.18: * This version will work with either a "system" libpng14 or libpng15, or with the embedded libpng15. The deprecated usage of libpng png_struct members and unexported functions has been removed. * Revised the format of the time report (all on one line so you can get a nice compact report by piping the output to "grep coding").
This commit is contained in:
parent
35a64b80e6
commit
465948b074
3 changed files with 20 additions and 23 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.49 2011/10/04 09:36:01 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.50 2011/10/14 17:56:24 adam Exp $
|
||||
|
||||
DISTNAME= pngcrush-1.7.17
|
||||
DISTNAME= pngcrush-1.7.20-nolib
|
||||
PKGNAME= ${DISTNAME:C/-nolib//}
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=pmt/}
|
||||
|
@ -16,13 +16,13 @@ PKG_DESTDIR_SUPPORT= user-destdir
|
|||
NO_CONFIGURE= yes
|
||||
INSTALLATION_DIRS= bin
|
||||
|
||||
#do-build:
|
||||
# cd ${WRKSRC} && ${CC} -DPNG_USE_LOCAL_ARRAYS \
|
||||
# ${CFLAGS} `libpng-config --cflags` -o pngcrush pngcrush.c \
|
||||
# ${LDFLAGS} `libpng-config --ldflags` -lz
|
||||
do-build:
|
||||
cd ${WRKSRC} && ${CC} -DPNG_USE_LOCAL_ARRAYS \
|
||||
${CFLAGS} `libpng-config --cflags` -o pngcrush pngcrush.c \
|
||||
${LDFLAGS} `libpng-config --ldflags` -lz
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/pngcrush ${DESTDIR}${PREFIX}/bin
|
||||
|
||||
#.include "../../graphics/png/buildlink3.mk"
|
||||
.include "../../graphics/png/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.32 2011/10/04 09:36:01 adam Exp $
|
||||
$NetBSD: distinfo,v 1.33 2011/10/14 17:56:24 adam Exp $
|
||||
|
||||
SHA1 (pngcrush-1.7.17.tar.bz2) = b7c5857a04ffa986d711d69a445594198f39a56c
|
||||
RMD160 (pngcrush-1.7.17.tar.bz2) = 0a9da7ee940c3ef271bc6048a7e002ade9654826
|
||||
Size (pngcrush-1.7.17.tar.bz2) = 370782 bytes
|
||||
SHA1 (patch-aa) = 5c82c5afc9923110254ac40b607fdff6d6863cc2
|
||||
SHA1 (pngcrush-1.7.20-nolib.tar.bz2) = 7eb2ad9c6413838940e24451d0aa3a533815c6af
|
||||
RMD160 (pngcrush-1.7.20-nolib.tar.bz2) = a935741d1ce197f6944456ad12dfe3c5223f7ecb
|
||||
Size (pngcrush-1.7.20-nolib.tar.bz2) = 49392 bytes
|
||||
SHA1 (patch-aa) = fc0fd239c05513469554264a7e62dd8a722ab522
|
||||
|
|
|
@ -1,27 +1,24 @@
|
|||
$NetBSD: patch-aa,v 1.10 2011/01/28 20:46:11 adam Exp $
|
||||
$NetBSD: patch-aa,v 1.11 2011/10/14 17:56:24 adam Exp $
|
||||
|
||||
--- Makefile.orig 2011-01-28 20:28:50.000000000 +0000
|
||||
--- Makefile.orig 2011-01-21 23:04:44.000000000 +0000
|
||||
+++ Makefile
|
||||
@@ -14,17 +14,13 @@
|
||||
#ZINC = ../../zlib
|
||||
#ZLIB = ../../zlib
|
||||
@@ -17,14 +17,10 @@ PNGLIB = ${HOME}/lib
|
||||
ZINC = ${HOME}/include
|
||||
ZLIB = ${HOME}/lib
|
||||
|
||||
-CC = gcc
|
||||
-LD = gcc
|
||||
RM = rm -f
|
||||
#CFLAGS = -I. -O -Wall
|
||||
#CFLAGS = -I. -O2 -fomit-frame-pointer -Wall
|
||||
#CFLAGS = -I. -O3 -fomit-frame-pointer -Wall
|
||||
#CFLAGS = -I. -Os -fomit-frame-pointer -Wall
|
||||
-CFLAGS = -I. -O3 -funroll-loops -fomit-frame-pointer -Wall -Wshadow
|
||||
#CFLAGS = -I${ZINC} -I. -O3 -fomit-frame-pointer -Wall
|
||||
-CFLAGS = -I${ZINC} -I. -g -O3 -fomit-frame-pointer -Wall
|
||||
# [note that -Wall is a gcc-specific compilation flag ("all warnings on")]
|
||||
-LDFLAGS =
|
||||
O = .o
|
||||
E =
|
||||
|
||||
@@ -63,7 +59,7 @@ pngcrush$(O): pngcrush.c png.h pngconf.h
|
||||
$(CC) -c $(CFLAGS) $<
|
||||
@@ -68,7 +64,7 @@ pngcrush$(O): pngcrush.c cexcept.h
|
||||
# $(CC) -c $(CFLAGS) $<
|
||||
|
||||
$(PNGCRUSH)$(E): $(OBJS)
|
||||
- $(LD) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
|
||||
|
|
Loading…
Reference in a new issue