Use a more elegant method to solve the problem with the confliction
definition of the abs() macro. Based on a suggestion by Roland Illig.
This commit is contained in:
parent
3c07d3e676
commit
4667bb6be4
2 changed files with 17 additions and 6 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.7 2005/02/04 09:57:12 tron Exp $
|
||||
$NetBSD: distinfo,v 1.8 2005/02/17 23:16:44 tron Exp $
|
||||
|
||||
SHA1 (vnc-3.3.3r2_unixsrc.tgz) = 98e9d2e2c2d0f4f9cb9cafee22d21a868189b176
|
||||
Size (vnc-3.3.3r2_unixsrc.tgz) = 2072772 bytes
|
||||
|
@ -15,4 +15,4 @@ SHA1 (patch-af) = 369961aa3e089195653980da91e8fba53807fc53
|
|||
SHA1 (patch-ag) = 89ce8a6ac8d51ffd4d4be4588e59b7dd53366716
|
||||
SHA1 (patch-ah) = 0f9f3f3c9b167a2743e8dab2df430b0526346867
|
||||
SHA1 (patch-ai) = 0e8e49a44fbe2cf8f371a1224e0064b7cb28597c
|
||||
SHA1 (patch-aj) = 3999e7514907d722d4884adcb245022b80d7182b
|
||||
SHA1 (patch-aj) = 46f177a1dd199e72a0a8f02801941ab99e6f55d1
|
||||
|
|
|
@ -1,13 +1,24 @@
|
|||
$NetBSD: patch-aj,v 1.1 2005/02/04 09:57:12 tron Exp $
|
||||
$NetBSD: patch-aj,v 1.2 2005/02/17 23:16:44 tron Exp $
|
||||
|
||||
--- Xvnc/programs/Xserver/include/misc.h.orig 1996-12-23 07:09:29.000000000 +0000
|
||||
+++ Xvnc/programs/Xserver/include/misc.h 2005-02-04 09:51:52.000000000 +0000
|
||||
@@ -159,7 +159,7 @@
|
||||
+++ Xvnc/programs/Xserver/include/misc.h 2005-02-17 23:05:46.000000000 +0000
|
||||
@@ -83,6 +83,10 @@
|
||||
#include <X11/Xmd.h>
|
||||
#include <X11/X.h>
|
||||
|
||||
+#ifdef __NetBSD__
|
||||
+#include <stdlib.h>
|
||||
+#endif
|
||||
+
|
||||
#ifndef NULL
|
||||
#ifndef X_NOT_STDC_ENV
|
||||
#include <stddef.h>
|
||||
@@ -159,7 +166,7 @@
|
||||
#define min(a, b) (((a) < (b)) ? (a) : (b))
|
||||
#define max(a, b) (((a) > (b)) ? (a) : (b))
|
||||
#if !defined(AMOEBA) && !defined(__EMX__)
|
||||
-#ifndef abs
|
||||
+#if !defined(abs) && !defined(__NetBSD__)
|
||||
+#if !defined(abs)
|
||||
#define abs(a) ((a) > 0 ? (a) : -(a))
|
||||
#endif
|
||||
#else /* AMOEBA || __EMX__ */
|
||||
|
|
Loading…
Reference in a new issue