Make this package build on Linux by defining S_IREAD, S_IWRITE, and
u_long correctly.
This commit is contained in:
parent
1f5f23cb87
commit
467b6bffe9
2 changed files with 28 additions and 1 deletions
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.2 2001/04/18 13:47:17 agc Exp $
|
||||
$NetBSD: distinfo,v 1.3 2004/08/02 21:12:48 minskim Exp $
|
||||
|
||||
SHA1 (7pl225sr.tgz) = 9c393e8f6968d24ec469fbca45ade65a5c6d52fc
|
||||
Size (7pl225sr.tgz) = 65122 bytes
|
||||
SHA1 (7pl210mg.tgz) = 7acc708cabf8d166f74bd398940fb71aac2c7495
|
||||
Size (7pl210mg.tgz) = 31095 bytes
|
||||
SHA1 (patch-aa) = 73efc40a0dc294fdce0abc52dd8810c8d2ff9ba6
|
||||
|
|
26
ham/7plus/patches/patch-aa
Normal file
26
ham/7plus/patches/patch-aa
Normal file
|
@ -0,0 +1,26 @@
|
|||
$NetBSD: patch-aa,v 1.1 2004/08/02 21:12:48 minskim Exp $
|
||||
|
||||
--- 7plus.h.orig 2000-01-10 09:03:02.000000000 -0600
|
||||
+++ 7plus.h
|
||||
@@ -225,6 +225,12 @@
|
||||
#include <string.h>
|
||||
#include <linux/limits.h>
|
||||
#include <sys/ioctl.h>
|
||||
+ #ifndef S_IREAD
|
||||
+ #define S_IREAD S_IRUSR
|
||||
+ #endif
|
||||
+ #ifndef S_IWRITE
|
||||
+ #define S_IWRITE S_IWUSR
|
||||
+ #endif
|
||||
#endif /* __linux__ */
|
||||
|
||||
#ifdef __NetBSD__
|
||||
@@ -343,7 +349,7 @@
|
||||
|
||||
/** shorthands for unsigned types **/
|
||||
typedef unsigned char byte; /* 8bit unsigned char */
|
||||
-#ifdef __unix__
|
||||
+#if defined(__unix__) && !defined(__linux__)
|
||||
#ifdef __vax__
|
||||
typedef u_long ulong;
|
||||
#endif
|
Loading…
Reference in a new issue