Fix two C99 constructs to make this pkg build with gcc 2.95.
This commit is contained in:
parent
89368bbb35
commit
4692028288
2 changed files with 35 additions and 1 deletions
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.6 2005/05/27 12:09:27 salo Exp $
|
||||
$NetBSD: distinfo,v 1.7 2005/05/31 21:33:11 kristerw Exp $
|
||||
|
||||
SHA1 (gxine-0.4.5.tar.gz) = e18fea29164b10a93f9a4bc0de45db0db0d82fdd
|
||||
RMD160 (gxine-0.4.5.tar.gz) = b6ffce9caf73b244cfa674faed5def17edda9755
|
||||
Size (gxine-0.4.5.tar.gz) = 1322811 bytes
|
||||
SHA1 (patch-aa) = 168f7149dbffd7b191721a30193c6d58320534fc
|
||||
SHA1 (patch-ab) = 581122a87dd3ea1a61b434ba721866efd3455ab6
|
||||
SHA1 (patch-ac) = b4db5fbfb45f283937b38db2d2e22110b7e113be
|
||||
SHA1 (patch-ad) = 1a0cf404f16806bc75cb12659a6f0f86e5e52705
|
||||
|
|
33
multimedia/gxine/patches/patch-aa
Normal file
33
multimedia/gxine/patches/patch-aa
Normal file
|
@ -0,0 +1,33 @@
|
|||
$NetBSD: patch-aa,v 1.3 2005/05/31 21:33:11 kristerw Exp $
|
||||
|
||||
--- src/post.c.orig Tue May 31 23:11:08 2005
|
||||
+++ src/post.c Tue May 31 23:12:30 2005
|
||||
@@ -81,6 +81,7 @@
|
||||
const xine_post_in_t *in = xine_post_input (plugin, "parameters");
|
||||
const xine_post_api_t *api;
|
||||
const xine_post_api_descr_t *param_desc;
|
||||
+ char *params;
|
||||
|
||||
if (!in)
|
||||
return NULL;
|
||||
@@ -88,7 +89,7 @@
|
||||
api = in->data;
|
||||
param_desc = api->get_param_descr ();
|
||||
|
||||
- char *params = malloc (param_desc->struct_size);
|
||||
+ params = malloc (param_desc->struct_size);
|
||||
api->get_parameters (plugin, params);
|
||||
|
||||
for (;;)
|
||||
@@ -494,9 +495,10 @@
|
||||
while ((++param)->type != POST_PARAM_TYPE_LAST)
|
||||
{
|
||||
GtkWidget *widget;
|
||||
+ gpointer param_p;
|
||||
info->conf_w = realloc (info->conf_w,
|
||||
(param_count + 2) * sizeof (GtkWidget *));
|
||||
- gpointer param_p = info->params + param->offset;
|
||||
+ param_p = info->params + param->offset;
|
||||
switch (param->type)
|
||||
{
|
||||
case POST_PARAM_TYPE_INT:
|
Loading…
Reference in a new issue