import streamripper-1.64.3
This is the newest version of streamripper. A user visible difference to current pkgsrc/audio/streamripper is that it doesn't create id3v1 tags per default. (It should also get some testing with non-ASCII locales.)
This commit is contained in:
parent
c2822832b1
commit
4699e6e402
7 changed files with 84 additions and 0 deletions
5
audio/streamripper-current/DESCR
Normal file
5
audio/streamripper-current/DESCR
Normal file
|
@ -0,0 +1,5 @@
|
|||
Using information which a SHOUTcast server can optionally send, this program
|
||||
breaks an audio stream into "tracks," stores them in separate files as they
|
||||
arrive, and names the files by appending ".mp3" to the name of the track.
|
||||
The tracks can be listened to at the user's leisure with an MPEG Layer 3
|
||||
audio player.
|
29
audio/streamripper-current/Makefile
Normal file
29
audio/streamripper-current/Makefile
Normal file
|
@ -0,0 +1,29 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2009/01/07 18:51:28 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= streamripper-1.64.3
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=streamripper/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://streamripper.sourceforge.net/
|
||||
COMMENT= Splits SHOUTcast stream into tracks
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --without-included-tre
|
||||
BUILDLINK_API_DEPENDS.tre+= tre>=0.7.5nb1
|
||||
CONFIGURE_ARGS+= --without-included-libmad
|
||||
USE_TOOLS+= pkg-config
|
||||
|
||||
PTHREAD_OPTS+= require
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
.include "../../audio/libmad/buildlink3.mk"
|
||||
.include "../../converters/libiconv/buildlink3.mk"
|
||||
.include "../../devel/tre/buildlink3.mk"
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
audio/streamripper-current/PLIST
Normal file
3
audio/streamripper-current/PLIST
Normal file
|
@ -0,0 +1,3 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2009/01/07 18:51:28 drochner Exp $
|
||||
bin/streamripper
|
||||
man/man1/streamripper.1
|
7
audio/streamripper-current/distinfo
Normal file
7
audio/streamripper-current/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2009/01/07 18:51:28 drochner Exp $
|
||||
|
||||
SHA1 (streamripper-1.64.3.tar.gz) = 08dff7b4e48e16ad581e0b28fb77bdcddeeee0bb
|
||||
RMD160 (streamripper-1.64.3.tar.gz) = d0d5d18fc7e5086bb768e6a51e566e16f0ced730
|
||||
Size (streamripper-1.64.3.tar.gz) = 857175 bytes
|
||||
SHA1 (patch-ac) = b22e18723d4888d78f0e5e01e0db40f010b15f96
|
||||
SHA1 (patch-ad) = 583dbf02c8adf75eccdfea8c0e8aa181e89256de
|
14
audio/streamripper-current/options.mk
Normal file
14
audio/streamripper-current/options.mk
Normal file
|
@ -0,0 +1,14 @@
|
|||
# $NetBSD: options.mk,v 1.1.1.1 2009/01/07 18:51:28 drochner Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.streamripper
|
||||
PKG_SUPPORTED_OPTIONS= ogg
|
||||
PKG_SUGGESTED_OPTIONS= ogg
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mogg)
|
||||
. include "../../audio/libvorbis/buildlink3.mk"
|
||||
CONFIGURE_ARGS+= --with-ogg=${BUILDLINK_PREFIX.libvorbis}
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-ogg
|
||||
.endif
|
13
audio/streamripper-current/patches/patch-ac
Normal file
13
audio/streamripper-current/patches/patch-ac
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2009/01/07 18:51:28 drochner Exp $
|
||||
|
||||
--- lib/argv.c.orig 2007-08-14 17:33:03.000000000 +0200
|
||||
+++ lib/argv.c
|
||||
@@ -33,7 +33,7 @@ void freeargv (char **vector);
|
||||
|
||||
/* Routines imported from standard C runtime libraries. */
|
||||
|
||||
-#ifdef ANSI_PROTOTYPES
|
||||
+#if 1
|
||||
|
||||
#include <stddef.h>
|
||||
#include <string.h>
|
13
audio/streamripper-current/patches/patch-ad
Normal file
13
audio/streamripper-current/patches/patch-ad
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2009/01/07 18:51:28 drochner Exp $
|
||||
|
||||
--- ./lib/mchar.c.orig 2008-12-11 05:48:39.000000000 +0100
|
||||
+++ ./lib/mchar.c
|
||||
@@ -48,7 +48,7 @@
|
||||
#define vsnprintf _vsnprintf
|
||||
// #define vswprintf _vsnwprintf
|
||||
#else
|
||||
- #define ICONV_WCHAR "WCHAR_T"
|
||||
+ #define ICONV_WCHAR "ucs-4"
|
||||
/* This prototype is missing in some systems */
|
||||
// int vswprintf (wchar_t * ws, size_t n, const wchar_t * format, va_list arg);
|
||||
#endif
|
Loading…
Reference in a new issue