- Drop patch-ab, the lines of code to patch deleted.
   (there are still ifdef __FreeBSD__ remaining at other files,
    need to watch, sorry and thanks)
(upstream)
 - Update 2.6.0 to 2.7.0
---------------------
These are the Release Notes for Revision 2.7.0 of netperf:

*) Add bits/s (-f b) and Bytes/s (-f B) as selectable throughput
   units. This may make life easier for folks doing post-processing of
   things like interim results.

*) Miscelaneous fixes

*) Much of the now-seeming kruft for things peripheral to netperf's
   core mission - have been removed though the code itself remains in
   the repository.  So, things like looking-up egress interface,
   driver/slot information etc have been disabled in a manner
   requiring more than just a ./configure to bring-back.

   It wasn't clear those features were being used.  This is a test of
   that hypothesis.
This commit is contained in:
mef 2015-08-16 01:05:09 +00:00
parent 3fe84a8612
commit 46b2bb3f34
3 changed files with 6 additions and 21 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.10 2014/04/01 11:13:27 adam Exp $
# $NetBSD: Makefile,v 1.11 2015/08/16 01:05:09 mef Exp $
DISTNAME= netperf-2.6.0
DISTNAME= netperf-2.7.0
CATEGORIES= benchmarks
MASTER_SITES= ftp://ftp.netperf.org/netperf/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.9 2014/09/23 13:55:00 jperkin Exp $
$NetBSD: distinfo,v 1.10 2015/08/16 01:05:09 mef Exp $
SHA1 (netperf-2.6.0.tar.bz2) = 3e1be4e7c3f7a838c4d5c00c6d20a619b320bfef
RMD160 (netperf-2.6.0.tar.bz2) = c3adf0b67e1d8e8a51c229910aa7347182991df2
Size (netperf-2.6.0.tar.bz2) = 1032953 bytes
SHA1 (netperf-2.7.0.tar.bz2) = 415ecd4877cf8e24cefe6943564e511e6f1e2215
RMD160 (netperf-2.7.0.tar.bz2) = a3b9b89999362ae4077efcffa509140683d2982b
Size (netperf-2.7.0.tar.bz2) = 1024430 bytes
SHA1 (patch-ab) = 096eed1eccf6a2f7003898711384ed67019800d7
SHA1 (patch-ah) = b2ee5c6312ed987d6b796fa462dcc3557146580f
SHA1 (patch-ak) = 68628408979f164f2843bbe0eac0cb122af3b4fc

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ab,v 1.4 2014/04/01 11:13:27 adam Exp $
* sendfile(2) of DragonFly is FreeBSD in origin.
--- src/nettest_bsd.c.orig 2012-06-19 20:32:47.000000000 +0000
+++ src/nettest_bsd.c
@@ -4560,7 +4560,7 @@ Size (bytes)\n\
sv.sfv_off = send_ring->offset;
sv.sfv_len = send_ring->length;
if ((len = sendfilev(send_socket, &sv, 1, &scratch_len)) != send_size)
-#elif defined(__FreeBSD__)
+#elif defined(__FreeBSD__) || defined(__DragonFly__)
/* so close to HP-UX and yet so far away... :) */
if ((sendfile(send_ring->fildes,
send_socket,