ClamAV 0.98 includes many new features, across many different components

of ClamAV. There are new scanning options, extensions to the libclamav API,
support for additional filetypes, and internal upgrades.
This commit is contained in:
adam 2013-10-02 18:30:13 +00:00
parent 338fd9c787
commit 46b3c4aee0
7 changed files with 63 additions and 16 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.12 2013/04/23 18:27:41 adam Exp $
# $NetBSD: Makefile,v 1.13 2013/10/02 18:30:13 adam Exp $
DISTNAME= clamav-0.97.8
DISTNAME= clamav-0.98
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=clamav/}
@ -17,8 +17,8 @@ SET_LIBDIR= yes
CONFIGURE_ARGS+= --disable-clamav
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
CONFIGURE_ARGS+= --with-dbdir=${CLAMAV_DBDIR}
CONFIGURE_ARGS+= --with-user=${CLAMAV_USER}
CONFIGURE_ARGS+= --with-group=${CLAMAV_GROUP}
CONFIGURE_ARGS+= --with-user=${CLAMAV_USER}
CONFIGURE_ARGS+= --with-ltdl-include=${BUILDLINK_PREFIX.libltdl}/include
CONFIGURE_ARGS+= --with-ltdl-lib=${BUILDLINK_PREFIX.libltdl}/lib
CONFIGURE_ARGS+= --with-zlib=${BUILDLINK_PREFIX.zlib}
@ -26,7 +26,7 @@ CONFIGURE_ARGS+= --with-zlib=${BUILDLINK_PREFIX.zlib}
# bomb the build
CONFIGURE_ARGS+= --disable-zlib-vcheck
CHECK_PORTABILITY_SKIP= contrib/* unit_tests/*
CHECK_PORTABILITY_SKIP= contrib/* unit_tests/* win32/*
.include "../../mk/bsd.prefs.mk"
@ -55,14 +55,19 @@ FILES_SUBST+= CLAMAV_DBDIR=${CLAMAV_DBDIR}
OWN_DIRS_PERMS= ${CLAMAV_DBDIR} ${CLAMAV_USER} ${CLAMAV_GROUP} 0775
CONF_FILES= # empty
CONF_FILES_PERMS= # empty
.for i in clamd.conf freshclam.conf
.for i in clamav-milter.conf clamd.conf freshclam.conf
CONF_FILES+= ${EGDIR}/${i} ${PKG_SYSCONFDIR}/${i}
.endfor
INSTALL_MAKE_FLAGS= ${MAKE_FLAGS} CFGINST=${EGDIR} DBINST=${EGDIR}
INSTALLATION_DIRS+= ${EGDIR}
.include "options.mk"
post-install:
.for i in clamav-milter.conf clamd.conf freshclam.conf
${INSTALL_DATA} ${WRKSRC}/etc/${i}.sample ${DESTDIR}${EGDIR}/${i}
.endfor
.include "../../archivers/bzip2/buildlink3.mk"
.include "../../devel/libltdl/buildlink3.mk"
.include "../../devel/ncurses/buildlink3.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2012/07/02 07:12:58 adam Exp $
@comment $NetBSD: PLIST,v 1.4 2013/10/02 18:30:13 adam Exp $
bin/clamav-config
bin/clambc
bin/clamconf
@ -25,6 +25,8 @@ man/man5/freshclam.conf.5
man/man8/clamav-milter.8
man/man8/clamd.8
sbin/clamd
${PLIST.milter}sbin/clamav-milter
share/examples/clamav/clamav-milter.conf
share/examples/clamav/clamd.conf
share/examples/clamav/freshclam.conf
share/examples/rc.d/clamd

View file

@ -1,3 +0,0 @@
@comment $NetBSD: PLIST.milter,v 1.1.1.1 2010/12/24 07:11:05 kefren Exp $
sbin/clamav-milter
share/examples/clamav/clamav-milter.conf

View file

@ -1,10 +1,12 @@
$NetBSD: distinfo,v 1.9 2013/04/23 18:27:41 adam Exp $
$NetBSD: distinfo,v 1.10 2013/10/02 18:30:13 adam Exp $
SHA1 (clamav-0.97.8.tar.gz) = 078c0ac2b4e69d27eecd7544a8361abcd859e73c
RMD160 (clamav-0.97.8.tar.gz) = a7215aeaad0966eea1e0323b562fc9fc58f9537c
Size (clamav-0.97.8.tar.gz) = 14609966 bytes
SHA1 (clamav-0.98.tar.gz) = 1e6a7284721387646c713a8d32fa8b5a897985db
RMD160 (clamav-0.98.tar.gz) = e45ca4b549e0e2ea157ae74ad9cd6220e60839e3
Size (clamav-0.98.tar.gz) = 37075245 bytes
SHA1 (patch-Makefile.in) = c463edcef69422ff4b654f95d053e8600e34e313
SHA1 (patch-aa) = 8539a90ac5591c86f7e9f6b8c073f36523f221a5
SHA1 (patch-ab) = fea995ea944c2ae0f51a41e1a1076badf65c6c8b
SHA1 (patch-ad) = c862658ceba98ac415b0c193fc205c5862ac4970
SHA1 (patch-af) = d217633ed33c72b6d01a9aeef03f0f5dd33b4336
SHA1 (patch-ag) = cf4a0040a53c81402e8d15478407bc854af6fb30
SHA1 (patch-configure) = e5d27c543ca63baa0a11dd0066013bdb79178b13

View file

@ -1,10 +1,12 @@
# $NetBSD: options.mk,v 1.1.1.1 2010/12/24 07:11:05 kefren Exp $
# $NetBSD: options.mk,v 1.2 2013/10/02 18:30:13 adam Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.clamav
PKG_SUPPORTED_OPTIONS= milter clamav-experimental
.include "../../mk/bsd.options.mk"
PLIST_VARS+= milter
.if !empty(PKG_OPTIONS:Mmilter)
# force use of pkgsrc version of libmilter -- clamav uses the sendmail binary
# to check API compatibility(!), so it must build with as new a version of
@ -12,7 +14,7 @@ PKG_SUPPORTED_OPTIONS= milter clamav-experimental
USE_BUILTIN.libmilter= no
. include "../../mail/libmilter/buildlink3.mk"
CONFIGURE_ARGS+= --enable-milter
PLIST_SRC+= ${PKGDIR}/PLIST.milter
PLIST.milter= yes
.else
CONFIGURE_ARGS+= --disable-milter
# XXX --disable-milter doesn't work as expected, so we need this

View file

@ -0,0 +1,15 @@
$NetBSD: patch-Makefile.in,v 1.1 2013/10/02 18:30:13 adam Exp $
Install etc files manually.
--- Makefile.in.orig 2013-10-02 13:06:10.000000000 +0000
+++ Makefile.in
@@ -379,7 +379,7 @@ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = libltdl libclamav clamscan clamd clamdscan freshclam sigtool clamconf database docs etc clamav-milter test clamdtop clambc unit_tests
+SUBDIRS = libltdl libclamav clamscan clamd clamdscan freshclam sigtool clamconf database docs clamav-milter test clamdtop clambc unit_tests
EXTRA_DIST = FAQ examples BUGS shared libclamav.pc.in libclamunrar_iface/Makefile.am libclamunrar_iface/Makefile.in UPGRADE COPYING.bzip2 COPYING.lzma COPYING.unrar COPYING.LGPL COPYING.llvm COPYING.file COPYING.zlib COPYING.getopt COPYING.regex COPYING.sha256 platform.h.in clamdscan/clamdscan.map win32
bin_SCRIPTS = clamav-config
pkgconfigdir = $(libdir)/pkgconfig

View file

@ -0,0 +1,24 @@
$NetBSD: patch-configure,v 1.1 2013/10/02 18:30:13 adam Exp $
Don't harcode -rpath for zlib, or configure fails on systems without rpaths.
--- configure.orig 2013-10-02 09:25:40.000000000 +0000
+++ configure
@@ -15952,7 +15952,7 @@ $as_echo "$as_me: WARNING: ****** stabil
if test "$ZLIB_HOME" != "/usr"; then
CPPFLAGS="$CPPFLAGS -I$ZLIB_HOME/include"
save_LDFLAGS="$LDFLAGS"
- LDFLAGS="$LDFLAGS -Wl,-rpath=$ZLIB_HOME/lib"
+ LDFLAGS="$LDFLAGS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for inflateEnd in -lz" >&5
$as_echo_n "checking for inflateEnd in -lz... " >&6; }
if ${ac_cv_lib_z_inflateEnd+:} false; then :
@@ -15990,7 +15990,7 @@ fi
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_z_inflateEnd" >&5
$as_echo "$ac_cv_lib_z_inflateEnd" >&6; }
if test "x$ac_cv_lib_z_inflateEnd" = xyes; then :
- LIBCLAMAV_LIBS="$LIBCLAMAV_LIBS -Wl,-rpath=$ZLIB_HOME/lib -lz"; FRESHCLAM_LIBS="$FRESHCLAM_LIBS -Wl,-rpath=$ZLIB_HOME/lib -lz"
+ LIBCLAMAV_LIBS="$LIBCLAMAV_LIBS -lz"; FRESHCLAM_LIBS="$FRESHCLAM_LIBS -lz"
else
as_fn_error $? "Please install zlib and zlib-devel packages" "$LINENO" 5
fi