update to 2.29
many fixes and improvements
This commit is contained in:
parent
2c1029c6d1
commit
46fc520afa
4 changed files with 14 additions and 32 deletions
|
@ -1,9 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.5 2011/11/01 06:01:08 sbd Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2012/01/12 11:39:38 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= scite225
|
||||
PKGNAME= scite-2.25
|
||||
PKGREVISION= 3
|
||||
DISTNAME= scite229
|
||||
PKGNAME= scite-2.29
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=scintilla/}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2011/04/08 14:01:08 drochner Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2012/01/12 11:39:38 drochner Exp $
|
||||
bin/SciTE
|
||||
share/applications/SciTE.desktop
|
||||
share/pixmaps/Sci48M.png
|
||||
|
@ -47,6 +47,7 @@ share/scite/forth.properties
|
|||
share/scite/fortran.properties
|
||||
share/scite/freebasic.properties
|
||||
share/scite/gap.properties
|
||||
share/scite/haskell.properties
|
||||
share/scite/html.properties
|
||||
share/scite/inno.properties
|
||||
share/scite/kix.properties
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.2 2011/04/08 14:01:08 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.3 2012/01/12 11:39:38 drochner Exp $
|
||||
|
||||
SHA1 (scite225.tgz) = 6b33f254cc4760fdd861223573524e270b735a0b
|
||||
RMD160 (scite225.tgz) = 3b86042411f2272fa87428883386e5a7e5d86653
|
||||
Size (scite225.tgz) = 1843570 bytes
|
||||
SHA1 (patch-aa) = 72bea1ac6869236e9a9608ea64d58d514d9181a6
|
||||
SHA1 (scite229.tgz) = 153cc063b77d7ad95d265327f76ff6b4ed91c108
|
||||
RMD160 (scite229.tgz) = 5afa506eb5848e4bc99ef597ac0c5f1988afdbf9
|
||||
Size (scite229.tgz) = 1883704 bytes
|
||||
SHA1 (patch-aa) = ebe6ab3fe31fd85c09bb16c39441b69a6690f608
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2011/03/11 14:42:46 drochner Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2012/01/12 11:39:38 drochner Exp $
|
||||
|
||||
--- gtk/makefile.orig 2010-10-27 21:16:07.000000000 +0000
|
||||
--- gtk/makefile.orig 2011-08-01 02:49:29.000000000 +0000
|
||||
+++ gtk/makefile
|
||||
@@ -84,13 +84,13 @@ deps:
|
||||
@@ -97,7 +97,7 @@ deps:
|
||||
$(CC) -MM $(CONFIGFLAGS) $(CXXFLAGS) *.cxx ../src/*.cxx | sed -e 's/\/usr.* //' | grep [a-zA-Z] >deps.mak
|
||||
|
||||
# make should be run in ../../scintilla/gtk to compile all the lexers.
|
||||
|
@ -10,22 +10,4 @@ $NetBSD: patch-aa,v 1.1.1.1 2011/03/11 14:42:46 drochner Exp $
|
|||
+COMPLIB=$(prefix)/lib/scintilla.a
|
||||
|
||||
$(PROG): SciTEGTK.o GUIGTK.o Widget.o \
|
||||
FilePath.o SciTEBase.o SciTEBuffers.o SciTEIO.o StringList.o Exporters.o StringHelpers.o \
|
||||
PropSetFile.o MultiplexExtension.o DirectorExtension.o SciTEProps.o StyleWriter.o Utf8_16.o \
|
||||
JobQueue.o GTKMutex.o IFaceTable.o $(COMPLIB) $(LUA_OBJS)
|
||||
- $(CC) `$(CONFIGTHREADS)` -rdynamic -Wl,--as-needed -Wl,--version-script lua.vers -DGTK $^ -o $@ $(CONFIGLIB) -ldl -lstdc++
|
||||
+ $(CC) `$(CONFIGTHREADS)` -rdynamic -Wl,--as-needed -Wl,--version-script lua.vers -DGTK $^ -o $@ $(CONFIGLIB) -lstdc++
|
||||
|
||||
# Automatically generate header dependencies with "make deps"
|
||||
include deps.mak
|
||||
@@ -109,8 +109,8 @@ install:
|
||||
done
|
||||
|
||||
ifdef gnomeprefix
|
||||
- $(INSTALL) -m 755 -D SciTE.desktop $(DESTDIR)$(datadir)/applications/SciTE.desktop
|
||||
- $(INSTALL) -m 644 -D Sci48M.png $(DESTDIR)$(pixmapdir)/Sci48M.png
|
||||
+ $(INSTALL) -m 755 SciTE.desktop $(DESTDIR)$(datadir)/applications/SciTE.desktop
|
||||
+ $(INSTALL) -m 644 Sci48M.png $(DESTDIR)$(pixmapdir)/Sci48M.png
|
||||
endif
|
||||
|
||||
uninstall:
|
||||
FilePath.o SciTEBase.o Credits.o SciTEBuffers.o SciTEIO.o StringList.o Exporters.o StringHelpers.o \
|
||||
|
|
Loading…
Reference in a new issue