Updated to libctl-1.4.

2001-02-22  Steven G. Johnson  <stevenj@alum.mit.edu>

	* configure.in: fixed cppflags order

2001-02-20  Steven G. Johnson  <stevenj@alum.mit.edu>

	* base/ctl.h.in, base/main.c, base/math-utils.scm, base/subplex.c,
	ChangeLog, configure.in, NEWS: added minimize-multiple-expert fmin
	parameter, after a suggestion from Dale Fried

2001-02-04  Steven G. Johnson  <stevenj@alum.mit.edu>

	* base/ctl.h.in, base/main.c: added hook functions to help us use
	MPI (where we need to call MPI_Init and MPI_Finalize)

	* base/interaction.scm: cleanups, and made sure output is flushed

	* base/extern-funcs.scm, base/help.scm, base/interaction.scm,
	base/math-utils.scm, base/simplex.scm, base/utils.scm,
	doc/user-ref.html, NEWS, utils/ctl-io.scm: display-many -> print,
	added print-ok?

2001-01-21  Steven G. Johnson  <stevenj@alum.mit.edu>

	* base/ctl.h.in: whoops, fixed prototype

	* base/ctl.c, base/ctl.h.in: put ctl_get_list etc. back in because
	MPB configure script looks for it

	* base/ctl.c, base/ctl.h.in: whoops, fixed 'function support

	* base/class.scm, base/ctl.c, base/ctl.h.in, doc/developer.html,
	NEWS: add support for 'function type

	* utils/ctl-io.scm: put class input & destruction headers in
	ctl-io.h so that they can be used elsewhere if desired

	* examples/example.c, examples/example.scm: added function-passing
	example

	* base/class.scm: slight clarification in comment

2001-01-20  Steven G. Johnson  <stevenj@alum.mit.edu>

	* doc/guile-links.html: another minor change

	* doc/guile-links.html: minor change

	* doc/license.html: spelling correction

	* doc/advanced-user.html: Fixed command-line parameter order
	(whoops).

2001-01-07  Steven G. Johnson  <stevenj@alum.mit.edu>

	* doc/guile-links.html: updated links

	* base/main.c, base/math-utils.scm, base/matrix3x3.scm,
	base/simplex.scm, base/utils.scm, base/vector3.scm,
	doc/license.html, examples/example.c, examples/example.scm,
	examples/Makefile.in, examples/run.ctl, utils/ctlgeom.h,
	utils/ctl-io.scm, utils/gen-ctl-io.1, utils/gen-ctl-io.in,
	utils/geom.c, utils/geom.scm, base/class.scm, base/ctl.c,
	base/ctl-f77-glue.c, base/ctl.h.in, base/ctl.scm,
	base/extern-funcs.scm, base/help.scm, base/include.scm,
	base/interaction.scm, base/io-vars.scm, COPYRIGHT: 2001 copyright
	year update

	* ChangeLog, configure.in, NEWS: bumped version for new release
This commit is contained in:
jtb 2001-02-24 13:42:06 +00:00
parent 20d4fafb4f
commit 4702dfd3ae
7 changed files with 20 additions and 97 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.6 2001/02/16 14:38:34 wiz Exp $
# $NetBSD: Makefile,v 1.7 2001/02/24 13:42:06 jtb Exp $
DISTNAME= libctl-1.3
DISTNAME= libctl-1.4
CATEGORIES= devel
MASTER_SITES= http://superjdj.mit.edu/libctl/
@ -8,20 +8,19 @@ MAINTAINER= jtb@netbsd.org
HOMEPAGE= http://ab-initio.mit.edu/libctl/
COMMENT= Guile-based flexible control file library for scientific simulations
DEPENDS+= guile-[0-9]*:../../lang/guile
BUILD_DEPENDS+= ${LOCALBASE}/bin/autoreconf:../../devel/autoconf
DEPENDS+= guile>=1.4:../../lang/guile
WRKSRC= ${WRKDIR}/${DISTNAME}
GNU_CONFIGURE= YES
USE_LIBTOOL= YES
pre-configure:
(cd ${WRKSRC} && ${LOCALBASE}/bin/autoreconf)
GNU_CONFIGURE= #defined
post-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/libctl
${INSTALL_DATA} ${WRKSRC}/doc/* ${PREFIX}/share/doc/libctl
@for f in COPYING COPYRIGHT ChangeLog NEWS README ; do \
${INSTALL_DATA} ${WRKSRC}/$$f ${PREFIX}/share/doc/libctl ; done
@for f in ${WRKSRC}/doc/*; do \
i="${INSTALL_DATA} $$f ${PREFIX}/share/doc/libctl/"; \
${ECHO} $$i; $$i; \
done
@for f in COPYING COPYRIGHT ChangeLog NEWS README ; do \
i="${INSTALL_DATA} ${WRKSRC}/$$f ${PREFIX}/share/doc/libctl/"; \
${ECHO} $$i; $$i; \
done
.include "../../mk/bsd.pkg.mk"

View file

@ -1,3 +1,3 @@
$NetBSD: md5,v 1.2 2001/01/21 04:49:45 jtb Exp $
$NetBSD: md5,v 1.3 2001/02/24 13:42:06 jtb Exp $
MD5 (libctl-1.3.tar.gz) = 1f042d3ba3d171aca7d4ae06ebd487f1
MD5 (libctl-1.4.tar.gz) = b8ba5aa4234a420d5c2b8826d63d4f29

View file

@ -1,5 +1,6 @@
$NetBSD: patch-sum,v 1.5 2001/01/29 05:39:59 jtb Exp $
$NetBSD: patch-sum,v 1.6 2001/02/24 13:42:06 jtb Exp $
MD5 (patch-aa) = f6a80f7596a418bcd0cf6febacc99fa0
MD5 (patch-ab) = 9b4977c5edbb3f0ad321a08be53f2edf
MD5 (patch-ac) = a5c696e2cd5a5e9ac5c21f97522c54fd
This placeholder file is generated by the ``makepatchsum'' target
whenever the patches directory is empty or missing. Its purpose
is to ensure that the presence of any obsolete patches will cause
the proper error to be emitted at build time.

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aa,v 1.2 2001/01/21 04:49:45 jtb Exp $
--- configure.in.orig
+++ configure.in
@@ -115,7 +115,7 @@
# so that examples/Makefile.in can be used as-is for other programs:
CPPFLAGS="$CPPFLAGS -I`pwd`/$srcdir/base -I`pwd`/$srcdir/utils"
LDFLAGS="$LDFLAGS -L`pwd`/$srcdir/base"
-LIBS="-lctl $LIBS"
+#LIBS="-lctl $LIBS"
LIBCTL_DIR="`pwd`/$srcdir"
AC_SUBST(LIBCTL_DIR)

View file

@ -1,47 +0,0 @@
$NetBSD: patch-ab,v 1.5 2001/01/29 05:39:59 jtb Exp $
--- base/Makefile.in.orig Thu Jul 13 20:40:36 2000
+++ base/Makefile.in
@@ -12,7 +12,7 @@
INSTALL = @INSTALL@
prefix = @prefix@
-AR = ar
+#AR = ar
all: libs
@@ -20,18 +20,17 @@
math-utils.scm vector3.scm extern-funcs.scm interaction.scm \
matrix3x3.scm simplex.scm
OBJECTS = ctl.o subplex.o
-LIBNAME = libctl.a
+LIBNAME = libctl.la
libs: $(LIBNAME)
-libctl.a: $(OBJECTS)
- rm -f $@
- $(AR) r $@ $(OBJECTS)
- $(RANLIB) $@
+libctl.la: $(OBJECTS)
+ $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -o $@ $(OBJECTS:.o=.lo) \
+ $(LIBS) -rpath $(prefix)/lib -version-info 0:0
install:
$(INSTALL) -d $(prefix)/lib
- $(INSTALL) -m 0644 $(LIBNAME) $(prefix)/lib
+ $(LIBTOOL) --mode=install $(BSD_INSTALL_DATA) $(LIBNAME) $(prefix)/lib
$(INSTALL) -d $(prefix)/include
$(INSTALL) -m 0644 ctl.h $(prefix)/include
$(INSTALL) -d $(prefix)/share/libctl/base
@@ -41,7 +40,7 @@
$(INSTALL) -m 0644 main.c $(prefix)/share/libctl/base
.c.o:
- $(CC) -c $(CPPFLAGS) $(CFLAGS) $< -o $@
+ $(LIBTOOL) --mode=compile $(CC) -c $(CPPFLAGS) $(CFLAGS) $< -o $@
clean:
- rm -f $(OBJECTS) core $(LIBNAME)
+ rm -fr $(OBJECTS) $(OBJECTS:.o=.lo) core $(LIBNAME) .libs

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ac,v 1.4 2001/01/21 04:49:45 jtb Exp $
--- Makefile.in.orig Sun Jan 21 03:58:06 2001
+++ Makefile.in
@@ -16,7 +16,7 @@
# Subdirectories to make in:
LIBSUBDIRS = base utils
-SUBDIRS = $(LIBSUBDIRS) examples
+SUBDIRS = $(LIBSUBDIRS)
all: all-recursive

View file

@ -1,12 +1,8 @@
@comment $NetBSD: PLIST,v 1.5 2001/01/21 05:01:08 jtb Exp $
@comment $NetBSD: PLIST,v 1.6 2001/02/24 13:42:07 jtb Exp $
bin/gen-ctl-io
include/ctl.h
include/ctlgeom.h
lib/libctl.a
lib/libctl.la
lib/libctl.so
lib/libctl.so.0
lib/libctl.so.0.0
man/man1/gen-ctl-io.1
share/doc/libctl/COPYING
share/doc/libctl/COPYRIGHT