remove a patch which is either wrong or triggers a bug in NetBSD's

ld.elf_so, seen by Zafer Aydogan and myself
bump PKGREVISION
This commit is contained in:
drochner 2010-02-23 20:19:27 +00:00
parent 1c4848bd01
commit 470b72653f
3 changed files with 3 additions and 60 deletions

View file

@ -1,10 +1,10 @@
# $NetBSD: Makefile,v 1.170 2010/02/19 11:44:56 roy Exp $
# $NetBSD: Makefile,v 1.171 2010/02/23 20:19:27 drochner Exp $
# When updating glib2, please apply patch-ak to configure.in
# Then run a matching version of autoconf to regen patch-aa.
DISTNAME= glib-2.22.4
PKGNAME= ${DISTNAME:S/glib/glib2/}
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= devel
MASTER_SITES= ftp://ftp.gtk.org/pub/glib/2.22/ \
${MASTER_SITE_GNOME:=sources/glib/2.22/}

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.129 2010/02/19 22:45:42 roy Exp $
$NetBSD: distinfo,v 1.130 2010/02/23 20:19:27 drochner Exp $
SHA1 (glib-2.22.4.tar.bz2) = be135a25c233a199f043161777d31ac30e42f435
RMD160 (glib-2.22.4.tar.bz2) = 66dc6ec0f1b1d422f50f6d55700bee8d526318cc
@ -15,7 +15,6 @@ SHA1 (patch-ai) = ff1963c05cf82059de692cd5bf08872544297b7f
SHA1 (patch-aj) = 9e5a7ccf081e3ebdf7888a67b027b696f632177c
SHA1 (patch-ak) = 04e3d1eb9648186776dee81d2db9507c0df0c62e
SHA1 (patch-al) = 6c8b7c569fb5fae5eff719ebd2925d79f5df3b2e
SHA1 (patch-am) = a8fa06f905a9c7c6d005151655674627a853861d
SHA1 (patch-an) = e4a4b88a029c534f5be552eb301607ac57961915
SHA1 (patch-ba) = b235c2037bce84e0cdd9c87abaac274550ec0c95
SHA1 (patch-cb) = 0f084c33fb67fbb8e12448034450699da26289ff

View file

@ -1,56 +0,0 @@
$NetBSD: patch-am,v 1.4 2010/02/19 19:46:53 roy Exp $
We should only check the module itself for g_module_check_init and
g_module_unload functions.
This also makes loading a module a lot faster if these functions do
not exist and the module as a lot of dependencies.
Upstream URL
https://bugzilla.gnome.org/show_bug.cgi?id=610489
--- gmodule/gmodule.c 2010-02-18 19:59:34.000000000 +0000
+++ gmodule/gmodule.c 2010-02-18 20:18:06.000000000 +0000
@@ -474,25 +474,33 @@
module->cp_file_name = g_locale_from_utf8 (file_name, -1,
NULL, NULL, NULL);
#endif
- module->handle = handle;
+ /* we set RTLD_NEXT so we only load private functions from
+ * the module and not any dependencies */
+ module->handle = RTLD_NEXT;
module->ref_count = 1;
module->is_resident = FALSE;
module->unload = NULL;
module->next = modules;
modules = module;
+
+ /* load private functions */
+ g_module_symbol (module, "g_module_check_init", (gpointer) &check_init);
+ g_module_symbol (module, "g_module_unload", (gpointer) &module->unload);
+
+ /* now set the real handle */
+ module->handle = handle;
/* check initialization */
- if (g_module_symbol (module, "g_module_check_init", (gpointer) &check_init) && check_init != NULL)
- check_failed = check_init (module);
-
- /* we don't call unload() if the initialization check failed. */
- if (!check_failed)
- g_module_symbol (module, "g_module_unload", (gpointer) &module->unload);
-
- if (check_failed)
+ if (check_init != NULL)
+ check_failed = check_init(module);
+
+ if (check_failed != NULL)
{
gchar *error;
+ /* we don't call unload() if the initialization check failed. */
+ module->unload = NULL;
+
error = g_strconcat ("GModule (",
file_name ? file_name : "NULL",
") initialization check failed: ",