Fix import; apparently importing a package that used to exist does not
go well.
This commit is contained in:
parent
544809ca9b
commit
473de3c98d
3 changed files with 46 additions and 0 deletions
20
security/py-crypto/Makefile
Normal file
20
security/py-crypto/Makefile
Normal file
|
@ -0,0 +1,20 @@
|
|||
# $NetBSD: Makefile,v 1.16 2010/07/22 19:34:11 gdt Exp $
|
||||
#
|
||||
|
||||
DISTNAME= pycrypto-2.1.0
|
||||
PKGNAME= ${PYPKGPREFIX}-crypto-2.1.0
|
||||
CATEGORIES= security python
|
||||
MASTER_SITES= http://ftp.dlitz.net/pub/dlitz/crypto/pycrypto/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.dlitz.net/software/pycrypto/
|
||||
COMMENT= Cryptographic and hash functions for Python
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
PYDISTUTILSPKG= yes
|
||||
|
||||
.include "../../devel/gmp/buildlink3.mk"
|
||||
.include "../../lang/python/extension.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
6
security/py-crypto/distinfo
Normal file
6
security/py-crypto/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.4 2010/07/22 19:34:11 gdt Exp $
|
||||
|
||||
SHA1 (pycrypto-2.1.0.tar.gz) = b4baa1b5f349a7e5c497f4c7b4070c3f630519f8
|
||||
RMD160 (pycrypto-2.1.0.tar.gz) = 57589935b0aad4bee9008a840fda9b12c8e8c0f5
|
||||
Size (pycrypto-2.1.0.tar.gz) = 265388 bytes
|
||||
SHA1 (patch-ab) = 3a2839d62e5d7d26cf8128ca0ee34a8e86820ea7
|
20
security/py-crypto/patches/patch-ab
Normal file
20
security/py-crypto/patches/patch-ab
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-ab,v 1.3 2010/07/22 19:34:11 gdt Exp $
|
||||
|
||||
Something in the build fails to detect that we have wchar.h. This
|
||||
change make it build on NetBSD; a better fix is welcome.
|
||||
|
||||
--- src/libtom/tomcrypt_pk.h.orig 2009-12-13 20:39:29.000000000 +0000
|
||||
+++ src/libtom/tomcrypt_pk.h
|
||||
@@ -495,12 +495,7 @@ int der_length_printable_string(const un
|
||||
int der_printable_char_encode(int c);
|
||||
int der_printable_value_decode(int v);
|
||||
|
||||
-/* UTF-8 */
|
||||
-#if (defined(SIZE_MAX) || __STDC_VERSION__ >= 199901L || defined(WCHAR_MAX) || defined(_WCHAR_T) || defined(_WCHAR_T_DEFINED)) && !defined(LTC_NO_WCHAR)
|
||||
#include <wchar.h>
|
||||
-#else
|
||||
-typedef ulong32 wchar_t;
|
||||
-#endif
|
||||
|
||||
int der_encode_utf8_string(const wchar_t *in, unsigned long inlen,
|
||||
unsigned char *out, unsigned long *outlen);
|
Loading…
Reference in a new issue