audio/libopenspc: Fix configure script bad grep pattern

DragonFly's modern gnu grep caught use of "[:space:]" rather than
the correct "[[:space:]]" in the Gentoo ltmain sanity check, and
returned an error breaking the configure script.  The m4 file was
correct though, so the configure wasn't really generated.  In any
case, this Gentoo error is widespread, so expect the same patch for
other packages as they are discovered.

It's possible platforms using BSD grep aren't affected.
No PKGREVISION bump required.
This commit is contained in:
marino 2011-11-21 07:12:24 +00:00
parent 96ce51bbcc
commit 47c746dd50
2 changed files with 15 additions and 1 deletions

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2007/01/26 16:44:00 drochner Exp $
$NetBSD: distinfo,v 1.2 2011/11/21 07:12:24 marino Exp $
SHA1 (OpenSPC_snap-20050926.tar.bz2) = 5f12938f07612b0f0138557263338ad74f7a83d5
RMD160 (OpenSPC_snap-20050926.tar.bz2) = e7d64c9209f0acf376978cadf40724328daa038e
Size (OpenSPC_snap-20050926.tar.bz2) = 240382 bytes
SHA1 (patch-aa) = d590025599d640a833fe28aac0d10fb6f33adff2

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1 2011/11/21 07:12:24 marino Exp $
--- configure.orig 2005-09-26 23:32:26.000000000 +0000
+++ configure
@@ -6320,7 +6320,7 @@ echo "${ECHO_T}no" >&6
exit 1
fi
gentoo_lt_version="1.5.18"
-gentoo_ltmain_version=`grep '^[:space:]*VERSION=' $ltmain | sed -e 's|^[:space:]*VERSION=||'`
+gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
echo "$as_me:$LINENO: result: no" >&5
echo "${ECHO_T}no" >&6