Changes 3.1.14:
* Regression Bug 3261: Could not create a DNS socket and exit Changes 3.1.13: * Regression Bug 3239: problems with myip/myport upgrade * Bug 3153: hung ICAP RESPMOD transactions * Update ssl_crtd to use 'OK' status inline with other helpers
This commit is contained in:
parent
8e73d79e51
commit
47df111bba
4 changed files with 38 additions and 7 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.31 2011/05/11 04:26:15 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.32 2011/07/20 11:44:26 adam Exp $
|
||||
|
||||
DISTNAME= squid-3.1.12
|
||||
DISTNAME= squid-3.1.14
|
||||
PKGNAME= ${DISTNAME} # Necessary for "pkgsrc/www/squid/options.mk"
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://www.squid-cache.org/Versions/v3/3.1/ \
|
||||
${SQUID_MASTER_SITES}
|
||||
|
|
|
@ -1,9 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.28 2011/04/15 09:48:56 adam Exp $
|
||||
$NetBSD: distinfo,v 1.29 2011/07/20 11:44:26 adam Exp $
|
||||
|
||||
SHA1 (squid-3.1.12.tar.bz2) = 44c259d671c4d126c60ae95a00160bd3f867e62f
|
||||
RMD160 (squid-3.1.12.tar.bz2) = ffb8cdb5d4ef715d3bb4b12c9cfdc47ec68e758d
|
||||
Size (squid-3.1.12.tar.bz2) = 2491613 bytes
|
||||
SHA1 (squid-3.1.14.tar.bz2) = 3bd958e90ad7de1c7c6b8e8288441e7d34abed6a
|
||||
RMD160 (squid-3.1.14.tar.bz2) = 283b01bd4004175a93103b342eeba775ce2dd8bd
|
||||
Size (squid-3.1.14.tar.bz2) = 2510694 bytes
|
||||
SHA1 (patch-ad) = 2e8c05f220374240e5681efdd46379851c6bb50e
|
||||
SHA1 (patch-ae) = 944c24b28cf11f7a876150f8f0e131af5f3e354d
|
||||
SHA1 (patch-aj) = 9f250b7f645b2ee77243a617c1a7faa5c7956339
|
||||
SHA1 (patch-al) = 6fec093f8969aed96cb8ffb115d96f9d21ac1f63
|
||||
SHA1 (patch-src_base_TidyPointer.h) = d616bc21f7ab640622b7c34cf9da8222d2ddb5cf
|
||||
SHA1 (patch-src_ssl_gadgets.cc) = c631940ffd3fc7f44bc1586169eb4fe13a79ab35
|
||||
|
|
17
www/squid31/patches/patch-src_base_TidyPointer.h
Normal file
17
www/squid31/patches/patch-src_base_TidyPointer.h
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-src_base_TidyPointer.h,v 1.1 2011/07/20 11:44:27 adam Exp $
|
||||
|
||||
Define NULL if not defined.
|
||||
|
||||
--- src/base/TidyPointer.h.orig 2011-07-08 09:42:57.000000000 +0000
|
||||
+++ src/base/TidyPointer.h
|
||||
@@ -5,6 +5,10 @@
|
||||
#ifndef SQUID_BASE_TIDYPOINTER_H
|
||||
#define SQUID_BASE_TIDYPOINTER_H
|
||||
|
||||
+#ifndef NULL
|
||||
+#define NULL ((void *)0)
|
||||
+#endif
|
||||
+
|
||||
/**
|
||||
* A pointer that deletes the object it points to when the pointer's owner or
|
||||
* context is gone. Similar to std::auto_ptr but without confusing assignment
|
13
www/squid31/patches/patch-src_ssl_gadgets.cc
Normal file
13
www/squid31/patches/patch-src_ssl_gadgets.cc
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-src_ssl_gadgets.cc,v 1.1 2011/07/20 11:44:27 adam Exp $
|
||||
|
||||
Include correct config.h as there might be other impostors wandering around.
|
||||
|
||||
--- src/ssl/gadgets.cc.orig 2011-07-20 10:55:12.000000000 +0000
|
||||
+++ src/ssl/gadgets.cc
|
||||
@@ -3,5 +3,5 @@
|
||||
*/
|
||||
|
||||
-#include "config.h"
|
||||
+#include "include/config.h"
|
||||
#include "ssl/gadgets.h"
|
||||
|
Loading…
Reference in a new issue