Update to battleball-2.1.

- - Now compiles "out of the box" with g++ 2.8.0 and later.
- - Game window is now taller, for a better view.
- - Now alway double-buffered.
- - OpenGL rendering mode. (Disabled by default in the package.
	Set USE_MESA=YES to build in support for Mesa.)
This commit is contained in:
fredb 2000-01-06 08:36:07 +00:00
parent 3d8ba37e92
commit 481e26228b
7 changed files with 30 additions and 122 deletions

View file

@ -1,20 +1,33 @@
# $NetBSD: Makefile,v 1.2 1998/08/20 15:16:54 tsarna Exp $
# $NetBSD: Makefile,v 1.3 2000/01/06 08:36:07 fredb Exp $
DISTNAME= battleball.20.src
PKGNAME= battleball-2.0
CATEGORIES= games x11
MASTER_SITES= http://www.cs.utexas.edu/users/pahardin/
DISTNAME= battleball.21.src
PKGNAME= battleball-2.1
CATEGORIES= games x11
MASTER_SITES= http://linuxberg.prover.com.br/files/x11/entertain/
MAINTAINER= root@garbled.net
HOMEPAGE= http://www.cs.utexas.edu/users/pahardin/bb.html
MAINTAINER= root@garbled.net
HOMEPAGE= http://www.cs.utexas.edu/users/pahardin/bb.html
WRKSRC= ${WRKDIR}/bb-2.0
USE_X11= YES
WRKSRC= ${WRKDIR}/battleball-2.1-src
NO_INSTALL_MANPAGES= yes
USE_GMAKE= yes
USE_IMAKE= yes
CPPFLAGS+= -I${X11BASE}/include
SED_CMDS= -e '/^INCS/s|$$|${CPPFLAGS}|' -e '/^LIBS/s|$$|${LDFLAGS}|'
post-patch:
${TOUCH} ${WRKSRC}/battleball.man
do-configure:
${CP} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.orig; \
${SED} ${SED_CMDS} < ${WRKSRC}/Makefile.orig > ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/battleball ${PREFIX}/bin/
.include "../../mk/bsd.pkg.mk"
.if !defined(USE_MESA)
CPPFLAGS+= -DNO_OPENGL
SED_CMDS+= -e '/^GLINCS/s|^|\#|' -e '/^GLLIBS/s|^|\#|'
.else
# Note to Maintainers: Wildcard needs to match all possible Mesa-glx
# variations so the build doesn't fail if Mesa-glx is already installed.
DEPENDS+= Mesa-*:../../graphics/Mesa
.endif

View file

@ -1,3 +1,3 @@
$NetBSD: md5,v 1.3 1999/08/07 10:36:16 fredb Exp $
$NetBSD: md5,v 1.4 2000/01/06 08:36:10 fredb Exp $
MD5 (battleball.20.src.tar.gz) = fd23bc6529d04608e21cb8bfb1b04d73
MD5 (battleball.21.src.tar.gz) = d0ed7beee19194cea86e738fed2b69c4

View file

@ -1,6 +1,3 @@
$NetBSD: patch-sum,v 1.1 2000/01/02 03:34:14 wiz Exp $
$NetBSD: patch-sum,v 1.2 2000/01/06 08:36:10 fredb Exp $
MD5 (patch-aa) = 676cdbebdc45a9b890e29aedba5a327b
MD5 (patch-ab) = 822a31d9361ea421c92c22178d439b29
MD5 (patch-ac) = da30a6e33f4ed358eb749db198ac5139
MD5 (patch-ad) = 5fe705a90234c798a0cd0db4650e005e
MD5 (patch-aa) = d555ae31206498fe9346537789e6a5e7

View file

@ -1,66 +0,0 @@
$NetBSD: patch-aa,v 1.1 1999/08/07 10:36:17 fredb Exp $
--- lib3d/rect3d.h.orig Wed Aug 5 20:55:33 1998
+++ lib3d/rect3d.h Sat Aug 7 03:18:21 1999
@@ -13,31 +13,30 @@
/************************************************************************/
-/* pnt = N-dimensional point type which delimits the bounds of the rect
- pnts = container of pts
+/* pt3d = N-dimensional point type which delimits the bounds of the rect
+ table<pt3d> = container of pts
*/
-template <class pnt, class pnts>
-struct rect {
- pnt low,
+struct rect3d {
+ pt3d low,
high;
- bool Contains(const pnt& p) const
+ bool Contains(const pt3d& p) const
{return p.IsBetween(low,high);};
- bool ContainsInclusively(const pnt& p) const
+ bool ContainsInclusively(const pt3d& p) const
{return p.IsBetweenInclusively(low,high);};
- bool ContainsExclusively(const pnt& p) const
+ bool ContainsExclusively(const pt3d& p) const
{return p.IsBetweenExclusively(low,high);};
-// Center used to return "const pnt& "
- pnt Center() const
+// Center used to return "const pt3d& "
+ pt3d Center() const
{return (low+high)/2;};
- void MakeBoundingBox(const pnts& pts, pnt::coord& farthestDist) {
- pnt::coord d;
+ void MakeBoundingBox(const table<pt3d>& pts, pt3d::coord& farthestDist) {
+ pt3d::coord d;
farthestDist= 0;
if (pts.Num()==0) {
- low= pnt(0,0,0);
- high= pnt(0,0,0);
+ low= pt3d(0,0,0);
+ high= pt3d(0,0,0);
return;
}
@@ -45,7 +44,7 @@
high= pts[0];
forii(pts.Num()) {
- d= (pnt::coord) pts[i].Dist();
+ d= (pt3d::coord) pts[i].Dist();
if (d >farthestDist)
farthestDist= d;
low.SetMin(pts[i]);
@@ -55,7 +54,5 @@
};
-
-typedef rect<pt3d,table<pt3d> > rect3d;
#endif

View file

@ -1,14 +0,0 @@
$NetBSD: patch-ab,v 1.1 1999/08/07 10:36:17 fredb Exp $
--- bb/player.C.orig Wed Aug 5 21:00:47 1998
+++ bb/player.C Sat Aug 7 03:18:21 1999
@@ -12,7 +12,9 @@
#ifdef __GNUC__
+# if (__GNUC__ < 3) && (__GNUC_MINOR__ < 91)
char __stl_temp_buffer[__stl_buffer_size];
+# endif
#else
#include "tempbuf.cpp" // quasi-hack necessary to use STL's stable_sort()
#endif

View file

@ -1,10 +0,0 @@
$NetBSD: patch-ac,v 1.1 1999/08/07 10:36:17 fredb Exp $
--- Imakefile.orig Thu Oct 9 18:37:08 1997
+++ Imakefile Sat Aug 7 03:18:22 1999
@@ -1,4 +1,5 @@
CXX = g++
+CXXOPTIONS = -funroll-loops -Wall
PROGRAMS = battleball
XCOMM If your compiler doesn't have STL in its default include path, add

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ad,v 1.1 1999/08/07 10:36:18 fredb Exp $
--- lib3d/general.C.orig Wed Aug 5 20:55:48 1998
+++ lib3d/general.C Sat Aug 7 03:30:27 1999
@@ -6,6 +6,7 @@
#include <math.h>
#include <sys/time.h> // to get select()
//#include <sys/select.h> // to get select() on some other systems
+#include <unistd.h> // to get select() on NetBSD
#include "general.h"
#include "ang2d.h"