Add DragonFly support.

This commit is contained in:
joerg 2005-10-03 19:52:03 +00:00
parent 957ca17ce6
commit 482296f1b4
3 changed files with 57 additions and 7 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.11 2005/02/23 17:36:10 wiz Exp $
$NetBSD: distinfo,v 1.12 2005/10/03 19:52:03 joerg Exp $
SHA1 (Eterm-0.9.3.tar.gz) = df12cb09676ca265d65b8b5ac61f1ec88d58c692
RMD160 (Eterm-0.9.3.tar.gz) = 4e9f57807f1658cf8bea90219e296f4184f31452
@ -15,5 +15,6 @@ Size (Eterm-bg-tile.tar.gz) = 1568166 bytes
SHA1 (patch-aa) = e47c20515232098f660a166af4d4c52a2f044d73
SHA1 (patch-ab) = ad802e27730e4d6451d4d64de09750811afcf7b7
SHA1 (patch-ad) = f70a92e4eb84466e379653cbd3a9188db6d408c8
SHA1 (patch-ah) = 81dac9571b5184d803003a0681c9cc8a0a62e389
SHA1 (patch-ah) = 87c9e0e9ebd7409be7c04e0d6fe5e91510983635
SHA1 (patch-ai) = a8499316ec96198ca2deceaf1838d68f36ba100d
SHA1 (patch-aj) = b6782d1de8d8cd85a0e8a2fdd2a4f459bffdd8f7

View file

@ -1,7 +1,16 @@
$NetBSD: patch-ah,v 1.3 2002/12/26 04:58:45 wiz Exp $
$NetBSD: patch-ah,v 1.4 2005/10/03 19:52:04 joerg Exp $
--- src/utmp.c.orig Thu Jun 27 14:15:53 2002
+++ src/utmp.c Sat Dec 14 21:44:17 2002
@@ -47,8 +47,13 @@
@@ -38,7 +38,7 @@ static const char cvs_ident[] = "$Id: ut
# endif
/* don't go off end of ut_id & remember if an entry has been made */
-# if defined(USE_SYSV_UTMP) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__bsdi__)
+# if defined(USE_SYSV_UTMP) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__bsdi__) || defined(__DragonFly__)
static char ut_id[5]; /* remember if entry to utmp made */
# else
static int utmp_pos; /* BSD position of utmp-stamp */
@@ -47,8 +47,13 @@ static int utmp_pos; /* BSD p
# ifdef USE_SYSV_UTMP
# ifdef HAVE_UTMPX_H
@ -16,7 +25,7 @@ $NetBSD: patch-ah,v 1.3 2002/12/26 04:58:45 wiz Exp $
# define update_wtmp updwtmpx
# else /* HAVE_UTMPX_H */
@@ -128,9 +133,9 @@
@@ -128,9 +133,9 @@ add_utmp_entry(const char *pty, const ch
privileges(INVOKE);
# ifdef HAVE_UTMPX_H
getutmp(&utmp, &utmp2);
@ -28,7 +37,7 @@ $NetBSD: patch-ah,v 1.3 2002/12/26 04:58:45 wiz Exp $
# endif
/* set up the new entry */
@@ -152,16 +157,15 @@
@@ -152,16 +157,15 @@ add_utmp_entry(const char *pty, const ch
/*
* write a utmp entry to the utmp file
*/
@ -47,7 +56,7 @@ $NetBSD: patch-ah,v 1.3 2002/12/26 04:58:45 wiz Exp $
privileges(REVERT);
return;
fd = 0;
@@ -177,19 +181,19 @@
@@ -177,19 +181,19 @@ remove_utmp_entry(void)
if (!ut_id[0])
return; /* entry not made */
@ -75,3 +84,30 @@ $NetBSD: patch-ah,v 1.3 2002/12/26 04:58:45 wiz Exp $
# else /* HAVE_UTMPX_H */
struct utmp *putmp;
@@ -222,7 +226,7 @@ remove_utmp_entry(void)
# else /* USE_SYSV_UTMP */
/* BSD utmp support */
-# if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__bsdi__)
+# if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__bsdi__) || defined(__DragonFly__)
/* used to hold the line we are using */
static char ut_line[32];
@@ -348,7 +352,7 @@ add_utmp_entry(const char *pty, const ch
return;
}
-# if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__bsdi__)
+# if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__bsdi__) || defined(__DragonFly__)
strncpy(ut_line, pty, 31);
strncpy(utmp.ut_line, pty, UT_LINESIZE);
@@ -376,7 +380,7 @@ add_utmp_entry(const char *pty, const ch
void
remove_utmp_entry(void)
{
-# if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__bsdi__)
+# if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__bsdi__) || defined(__DragonFly__)
logout(ut_line);
logwtmp(ut_line, "", "");
# else /* __FreeBSD__ */

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aj,v 1.1 2005/10/03 19:52:04 joerg Exp $
--- src/eterm_utmp.h.orig 2005-07-31 00:03:43.000000000 +0000
+++ src/eterm_utmp.h
@@ -69,7 +69,7 @@
# ifdef HAVE_LASTLOG_H
# include <lastlog.h>
# endif
-# if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__bsdi__)
+# if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__bsdi__) || defined(__DragonFly__)
# include <ttyent.h>
# endif