Fix errno.

This commit is contained in:
joerg 2006-01-09 23:00:09 +00:00
parent c746cd1e56
commit 4840259c86
5 changed files with 54 additions and 1 deletions

View file

@ -1,7 +1,11 @@
$NetBSD: distinfo,v 1.6 2005/10/15 23:07:21 tonio Exp $
$NetBSD: distinfo,v 1.7 2006/01/09 23:00:09 joerg Exp $
SHA1 (elk-3.99.6.tar.gz) = 10fb17ab7e06a34ad3067be323482091fa79d398
RMD160 (elk-3.99.6.tar.gz) = f7e7861bae4e996b4eac2f6d3c004f5631b73e38
Size (elk-3.99.6.tar.gz) = 847811 bytes
SHA1 (patch-aa) = 8eafcd683ad0a87003d3727a6a37e321ef92b0a4
SHA1 (patch-ab) = e28bb6c96d315dfb3010036e3bc40b0e50b3b2b2
SHA1 (patch-ac) = 41f932913d0e6ddb853d51c1cd93a129eaae9df6
SHA1 (patch-ad) = 0b98ffb107079c163e940e3c1080ed16bb652c28
SHA1 (patch-ae) = 247fb8a9c8a59970db0a495ca9cb511f5bbe8351
SHA1 (patch-af) = aff5c0494b3ac27593d0d0e9e24c786d8dfbe354

12
lang/elk/patches/patch-ac Normal file
View file

@ -0,0 +1,12 @@
$NetBSD: patch-ac,v 1.5 2006/01/09 23:00:09 joerg Exp $
--- src/io.c.orig 2006-01-09 22:17:25.000000000 +0000
+++ src/io.c
@@ -48,7 +48,6 @@
extern void Flush_Output (Object);
-extern int errno;
extern char *getenv();
Object Curr_Input_Port, Curr_Output_Port;

12
lang/elk/patches/patch-ad Normal file
View file

@ -0,0 +1,12 @@
$NetBSD: patch-ad,v 1.4 2006/01/09 23:00:09 joerg Exp $
--- src/libelk.c.orig 2003-12-05 12:38:37.000000000 +0000
+++ src/libelk.c
@@ -172,7 +172,6 @@ void Elk_Init (int ac, char **av, int in
int debug = 0, heap = HEAP_SIZE;
Object file;
struct stat st;
- extern int errno;
#if defined(CAN_DUMP)
# define foo (av[0][0])
#else

13
lang/elk/patches/patch-ae Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-ae,v 1.4 2006/01/09 23:00:09 joerg Exp $
--- src/print.c.orig 2006-01-09 22:23:12.000000000 +0000
+++ src/print.c
@@ -49,8 +49,6 @@
extern void Print_Bignum (Object, Object);
-extern int errno;
-
void Flush_Output (Object);
void Print_String (Object, register char *, register unsigned int);
void Pr_Char (Object, register int);

12
lang/elk/patches/patch-af Normal file
View file

@ -0,0 +1,12 @@
$NetBSD: patch-af,v 1.5 2006/01/09 23:00:09 joerg Exp $
--- lib/unix/unix.h.orig 2006-01-09 22:28:37.000000000 +0000
+++ lib/unix/unix.h
@@ -46,7 +46,6 @@
#include "scheme.h"
-extern int errno;
extern char *index();
extern Object Unix_Errobj, V_Call_Errhandler;