Fix qmake to handle DESTDIR during installation.
From Niclas Rosenvik. Bump PKGREVISION.
This commit is contained in:
parent
84866bd5af
commit
4847dddd6b
3 changed files with 15 additions and 9 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.100 2014/08/13 09:17:35 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.101 2014/08/23 20:09:31 wiz Exp $
|
||||
|
||||
PKGNAME= qt4-libs-${QTVERSION}
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
COMMENT= C++ X GUI toolkit
|
||||
|
||||
.include "../../x11/qt4-libs/Makefile.common"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.91 2014/08/10 17:36:09 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.92 2014/08/23 20:09:31 wiz Exp $
|
||||
|
||||
SHA1 (qt-everywhere-opensource-src-4.8.6.tar.gz) = ddf9c20ca8309a116e0466c42984238009525da6
|
||||
RMD160 (qt-everywhere-opensource-src-4.8.6.tar.gz) = 0220d4e76ac761c9ecfb8ddab6f2c1dc6ad70c33
|
||||
|
@ -7,7 +7,7 @@ SHA1 (patch-aa) = 9b5f8bd980d8c3f38fd3c541380fd42d2a93a609
|
|||
SHA1 (patch-ab) = 447a888cbc784a54935f23d1005d6977374a484d
|
||||
SHA1 (patch-ac) = 078ddafefc719f248740f40e2063dae07cd601e5
|
||||
SHA1 (patch-ad) = ca1dfb801ea16ba4b10797e4121fa05f585fd87b
|
||||
SHA1 (patch-ae) = d2dfd606ff82fa6db285d62a77e476f68ac93af7
|
||||
SHA1 (patch-ae) = 132e25722f2d78249e76c6d748cd671105e329de
|
||||
SHA1 (patch-af) = 86bab4c9090a346d44f378a00f4f434da9ded714
|
||||
SHA1 (patch-ag) = 8ba8839a110375c7343c42225945138c5a378e8b
|
||||
SHA1 (patch-ah) = 62c50fe48b9ff1ce9fb757b432c8b1db7693e112
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-ae,v 1.11 2012/01/12 22:59:58 adam Exp $
|
||||
$NetBSD: patch-ae,v 1.12 2014/08/23 20:09:31 wiz Exp $
|
||||
|
||||
--- qmake/generators/unix/unixmake.cpp.orig 2011-02-22 12:02:48.000000000 +0000
|
||||
--- qmake/generators/unix/unixmake.cpp.orig 2013-06-07 05:17:01.000000000 +0000
|
||||
+++ qmake/generators/unix/unixmake.cpp
|
||||
@@ -356,27 +356,29 @@ UnixMakefileGenerator::init()
|
||||
if(libtoolify[i].startsWith("QMAKE_LINK") || libtoolify[i] == "QMAKE_AR_CMD") {
|
||||
|
@ -50,7 +50,7 @@ $NetBSD: patch-ae,v 1.11 2012/01/12 22:59:58 adam Exp $
|
|||
if(targetdir.right(1) != Option::dir_sep)
|
||||
targetdir += Option::dir_sep;
|
||||
|
||||
@@ -779,10 +780,14 @@ UnixMakefileGenerator::defaultInstall(co
|
||||
@@ -779,11 +780,19 @@ UnixMakefileGenerator::defaultInstall(co
|
||||
QString src_targ = target;
|
||||
if(src_targ == "$(TARGET)")
|
||||
src_targ = "$(TARGETL)";
|
||||
|
@ -59,12 +59,18 @@ $NetBSD: patch-ae,v 1.11 2012/01/12 22:59:58 adam Exp $
|
|||
if(QDir::isRelativePath(dst_dir))
|
||||
- dst_dir = Option::fixPathToTargetOS(Option::output_dir + Option::dir_sep + dst_dir);
|
||||
- ret = "-$(LIBTOOL) --mode=install cp \"" + src_targ + "\" \"" + filePrefixRoot(root, dst_dir) + "\"";
|
||||
- uninst.append("-$(LIBTOOL) --mode=uninstall \"" + src_targ + "\"");
|
||||
+ dst_dir = Option::fixPathToTargetOS(dst_dir);
|
||||
+ if(!ret.isEmpty())
|
||||
+ ret += "\n\t";
|
||||
+ ret += "-$(LIBTOOL) --mode=install cp \"" + src_targ + "\" \"" + filePrefixRoot(root, dst_dir) + "\"";
|
||||
+ if(project->first("TEMPLATE") == "app") {
|
||||
+ ret += "-$(LIBTOOL) --mode=install cp \"" + Option::fixPathToTargetOS(destdir + src_targ, false) + "\" \"" + filePrefixRoot(root, dst_dir) + "\"";
|
||||
+ } else {
|
||||
+ ret += "-$(LIBTOOL) --mode=install cp \"" + src_targ + "\" \"" + filePrefixRoot(root, dst_dir) + "\"";
|
||||
+ }
|
||||
+ if(!uninst.isEmpty())
|
||||
+ uninst.append("\n\t");
|
||||
uninst.append("-$(LIBTOOL) --mode=uninstall \"" + src_targ + "\"");
|
||||
+ uninst.append("-$(LIBTOOL) --mode=uninstall \"" + src_targ + "\"");
|
||||
} else {
|
||||
QString src_targ = target;
|
||||
if(!destdir.isEmpty())
|
||||
|
|
Loading…
Reference in a new issue