* Fix build problem of ruby-mini-magick package correcting URL parameter
to rakefile to fix build problem with newer rake's strict checking. * Add LICENSE. No PKGREVISION bump since there is no change with built package.
This commit is contained in:
parent
606d783b2d
commit
484bc2d722
3 changed files with 21 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2008/04/30 16:22:47 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2009/06/12 13:35:40 taca Exp $
|
||||
|
||||
DISTNAME= mini_magick-1.2.3
|
||||
PKGNAME= ${RUBYGEM_PKGPREFIX}-${DISTNAME:S/_/-/}
|
||||
|
@ -7,6 +7,7 @@ CATEGORIES= graphics
|
|||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://mini_magick.rubyforge.org/
|
||||
COMMENT= Ruby wrapper for ImageMagick command line
|
||||
LICENSE= mit
|
||||
|
||||
# MiniMagick uses identify(1) and mogrify(1) from ImageMagick.
|
||||
DEPENDS+= ImageMagick-[0-9]*:../../graphics/ImageMagick
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2008/04/30 16:22:47 jlam Exp $
|
||||
$NetBSD: distinfo,v 1.2 2009/06/12 13:35:40 taca Exp $
|
||||
|
||||
SHA1 (mini_magick-1.2.3.gem) = b2c3595081bb5b6dafde84d4034cbc693c9c876a
|
||||
RMD160 (mini_magick-1.2.3.gem) = fce4ab12531cee6e6f1cac7f142146abcc734983
|
||||
Size (mini_magick-1.2.3.gem) = 823296 bytes
|
||||
SHA1 (patch-aa) = de83ed96379c2e30e89451c1ca84ad7d16bda3ea
|
||||
|
|
17
graphics/ruby-mini-magick/patches/patch-aa
Normal file
17
graphics/ruby-mini-magick/patches/patch-aa
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-aa,v 1.1 2009/06/12 13:35:40 taca Exp $
|
||||
|
||||
Correct URL parameter to rakefile to fix build problem with newer rake's
|
||||
strict checking.
|
||||
|
||||
--- Rakefile.orig 2009-06-12 16:44:00.000000000 +0900
|
||||
+++ Rakefile
|
||||
@@ -10,7 +10,8 @@ Hoe.new('mini_magick', MiniMagick::VERSI
|
||||
p.email = 'probablycorey+ruby@gmail.com'
|
||||
p.summary = 'A simple image manipulation library based on ImageMagick.'
|
||||
p.description = p.paragraphs_of('README.txt', 2..5).join("\n\n")
|
||||
- #p.url = p.paragraphs_of('README.txt', 0).first.split(/\n/)[1..-1]
|
||||
+ p.url = [ 'http://mini_magick.rubyforge.org/',
|
||||
+ '"A ruby wrapper for ImageMagick command line.']
|
||||
p.changes = p.paragraphs_of('History.txt', 0..1).join("\n\n")
|
||||
end
|
||||
|
Loading…
Reference in a new issue