Fix build with bison-3.0.
This commit is contained in:
parent
536e96d3c8
commit
4861142f5d
2 changed files with 40 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.32 2011/12/19 11:14:25 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.33 2013/08/16 09:01:48 wiz Exp $
|
||||
|
||||
SHA1 (libgnomeprint-2.18.8.tar.bz2) = cfb77148923b24b1651982a21b3cb55e312ff6d5
|
||||
RMD160 (libgnomeprint-2.18.8.tar.bz2) = 4f786ad61dc27177c350a5baa27cfc8b1140c32e
|
||||
|
@ -7,3 +7,4 @@ SHA1 (patch-aa) = 73dffa07cb1218b41784563dc822c08b3455fd59
|
|||
SHA1 (patch-ab) = 04499f4ce10315b894d85228588c24e9576f4df3
|
||||
SHA1 (patch-ac) = 907b2ec2c194ae10d7fe7eea6e2e52a128b5ca14
|
||||
SHA1 (patch-ad) = c414b9176635c90b95764ca9291a14718f7cfa00
|
||||
SHA1 (patch-libgnomeprint_grammar.y) = 57551905603957304b5b8b09d19ed38587a5ccaa
|
||||
|
|
38
print/libgnomeprint/patches/patch-libgnomeprint_grammar.y
Normal file
38
print/libgnomeprint/patches/patch-libgnomeprint_grammar.y
Normal file
|
@ -0,0 +1,38 @@
|
|||
$NetBSD: patch-libgnomeprint_grammar.y,v 1.1 2013/08/16 09:01:48 wiz Exp $
|
||||
|
||||
Fix build with bison-3.0.
|
||||
|
||||
--- libgnomeprint/grammar.y.orig 2010-02-09 12:32:51.000000000 +0000
|
||||
+++ libgnomeprint/grammar.y
|
||||
@@ -1,3 +1,4 @@
|
||||
+%parse-param {graph_t *graph}
|
||||
%{
|
||||
#include <glib.h>
|
||||
|
||||
@@ -98,8 +99,6 @@ gnome_print_filter_parse_prop (GnomePrin
|
||||
g_value_unset (&v);
|
||||
}
|
||||
|
||||
-static int yylex (void *lvalp);
|
||||
-static int yyerror (const char *s);
|
||||
%}
|
||||
|
||||
%union {
|
||||
@@ -184,7 +183,7 @@ graph: filter {
|
||||
|
||||
%%
|
||||
|
||||
-static int
|
||||
+int
|
||||
yyerror (const char *s)
|
||||
{
|
||||
return -1;
|
||||
@@ -194,7 +193,7 @@ int _gnome_print_fil
|
||||
struct yy_buffer_state *_gnome_print_filter_parse_yy_scan_string (char *);
|
||||
void _gnome_print_filter_parse_yy_delete_buffer (struct yy_buffer_state *);
|
||||
|
||||
-static int
|
||||
+int
|
||||
yylex (void *lvalp)
|
||||
{
|
||||
return _gnome_print_filter_parse_yylex ((YYSTYPE *) lvalp);
|
Loading…
Reference in a new issue