net/tinc: account for different header path on dfly
On DragonFly BSD, tun and tap headers are under net/tun/ and net/tap/ and not directly in net/. Due to this, tinc does not properly set up the tun devices in runtime. Bump PKGREVISION. ok@ wiz
This commit is contained in:
parent
7148486a03
commit
486ace2647
5 changed files with 66 additions and 5 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.15 2010/05/01 16:56:40 tonnerre Exp $
|
||||
# $NetBSD: Makefile,v 1.16 2011/02/13 00:20:24 rumko Exp $
|
||||
#
|
||||
|
||||
DISTNAME= tinc-1.0.13
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.tinc-vpn.org/packages/
|
||||
|
||||
|
|
|
@ -1,7 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.8 2010/05/01 16:56:40 tonnerre Exp $
|
||||
$NetBSD: distinfo,v 1.9 2011/02/13 00:20:24 rumko Exp $
|
||||
|
||||
SHA1 (tinc-1.0.13.tar.gz) = d84070502d693cf46c93d324cdf1686d67617db4
|
||||
RMD160 (tinc-1.0.13.tar.gz) = 72e3063887546fb82e5c740a71b52840bd04237d
|
||||
Size (tinc-1.0.13.tar.gz) = 508903 bytes
|
||||
SHA1 (patch-aa) = c507d0a7ec69ca7842d9854662d0762407a6575d
|
||||
SHA1 (patch-ab) = 791738ffd137d280d61d3da18417b521554d288e
|
||||
SHA1 (patch-ab) = f7bc392e63fcd7a799f7e87ab23576c455cfba87
|
||||
SHA1 (patch-ac) = cd397a99a54683273637d40c5b5f6e6cfb4052e0
|
||||
SHA1 (patch-ad) = 628a2305dfed1f83e45ddc5b131eaea1325cd20b
|
||||
|
|
|
@ -1,8 +1,10 @@
|
|||
$NetBSD: patch-ab,v 1.3 2010/05/01 16:56:41 tonnerre Exp $
|
||||
$NetBSD: patch-ab,v 1.4 2011/02/13 00:20:24 rumko Exp $
|
||||
|
||||
DragonFly BSD support (see https://github.com/gsliepen/tinc/pull/1)
|
||||
|
||||
--- configure.orig 2010-04-11 17:49:06.000000000 +0000
|
||||
+++ configure
|
||||
@@ -4723,7 +4723,7 @@ $as_echo "#define HAVE_LINUX 1" >>confde
|
||||
@@ -4723,7 +4723,7 @@
|
||||
|
||||
rm -f src/device.c; ln -sf linux/device.c src/device.c
|
||||
;;
|
||||
|
@ -11,3 +13,12 @@ $NetBSD: patch-ab,v 1.3 2010/05/01 16:56:41 tonnerre Exp $
|
|||
|
||||
$as_echo "#define HAVE_FREEBSD 1" >>confdefs.h
|
||||
|
||||
@@ -5019,7 +5019,7 @@
|
||||
|
||||
done
|
||||
|
||||
-for ac_header in net/if.h net/if_types.h linux/if_tun.h net/if_tun.h net/if_tap.h net/ethernet.h net/if_arp.h netinet/in_systm.h netinet/in.h netinet/in6.h
|
||||
+for ac_header in net/if.h net/if_types.h linux/if_tun.h net/if_tun.h net/tun/if_tun.h net/if_tap.h net/tap/if_tap.h net/ethernet.h net/if_arp.h netinet/in_systm.h netinet/in.h netinet/in6.h
|
||||
do :
|
||||
as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
|
||||
ac_fn_c_check_header_compile "$LINENO" "$ac_header" "$as_ac_Header" "#include \"have.h\"
|
||||
|
|
22
net/tinc/patches/patch-ac
Normal file
22
net/tinc/patches/patch-ac
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ac,v 1.1 2011/02/13 00:20:24 rumko Exp $
|
||||
|
||||
DragonFly BSD support (see https://github.com/gsliepen/tinc/pull/1)
|
||||
|
||||
--- config.h.in.orig 2010-04-11 19:49:08 +0200
|
||||
+++ config.h.in
|
||||
@@ -167,9 +167,15 @@
|
||||
/* Define to 1 if you have the <net/if_tap.h> header file. */
|
||||
#undef HAVE_NET_IF_TAP_H
|
||||
|
||||
+/* Define to 1 if you have the <net/tap/if_tap.h> header file. */
|
||||
+#undef HAVE_NET_TAP_IF_TAP_H
|
||||
+
|
||||
/* Define to 1 if you have the <net/if_tun.h> header file. */
|
||||
#undef HAVE_NET_IF_TUN_H
|
||||
|
||||
+/* Define to 1 if you have the <net/tun/if_tun.h> header file. */
|
||||
+#undef HAVE_NET_TUN_IF_TUN_H
|
||||
+
|
||||
/* Define to 1 if you have the <net/if_types.h> header file. */
|
||||
#undef HAVE_NET_IF_TYPES_H
|
||||
|
25
net/tinc/patches/patch-ad
Normal file
25
net/tinc/patches/patch-ad
Normal file
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-ad,v 1.1 2011/02/13 00:20:24 rumko Exp $
|
||||
|
||||
DragonFly BSD support (see https://github.com/gsliepen/tinc/pull/1)
|
||||
|
||||
--- have.h.orig 2010-03-13 18:53:33 +0100
|
||||
+++ have.h 2011-01-30 21:15:07 +0100
|
||||
@@ -123,10 +123,18 @@
|
||||
#include <net/if_tun.h>
|
||||
#endif
|
||||
|
||||
+#ifdef HAVE_NET_TUN_IF_TUN_H
|
||||
+#include <net/tun/if_tun.h>
|
||||
+#endif
|
||||
+
|
||||
#ifdef HAVE_NET_IF_TAP_H
|
||||
#include <net/if_tap.h>
|
||||
#endif
|
||||
|
||||
+#ifdef HAVE_NET_TAP_IF_TAP_H
|
||||
+#include <net/tap/if_tap.h>
|
||||
+#endif
|
||||
+
|
||||
#ifdef HAVE_NETINET_IN_SYSTM_H
|
||||
#include <netinet/in_systm.h>
|
||||
#endif
|
Loading…
Reference in a new issue