security/zoneminder: Add workaround for stricter compiler
Add [0] to unspecified array; gcc 7 errors while gcc 5 was ok with the previous code. (Temporary until this package is updated.)
This commit is contained in:
parent
476e5d287c
commit
4881a4b4af
2 changed files with 20 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.14 2020/03/29 01:06:11 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.15 2020/07/12 16:58:42 gdt Exp $
|
||||
|
||||
SHA1 (ZoneMinder-1.28.1.tar.gz) = 3e173ae1aac529b60d79a5fc668c107f0679d0a2
|
||||
RMD160 (ZoneMinder-1.28.1.tar.gz) = b3cc305656cb5b73d4ac0e21fe937c237467cdd1
|
||||
|
@ -12,6 +12,7 @@ SHA1 (patch-src_Makefile_am) = 0f6571c9d5a3e688544f93d687d266e1b71f0f43
|
|||
SHA1 (patch-src_zm__event.cpp) = 5258e89486b1152f0ddcac9b0a6fd68b70f24256
|
||||
SHA1 (patch-src_zm__image.cpp) = 0cb4f56bdf2f4fb99ec673b5a4f81589a7bdfdb0
|
||||
SHA1 (patch-src_zm__monitor.cpp) = dcc3816686a6a7c375d4716d3663b4c922c90439
|
||||
SHA1 (patch-src_zm__rtp__ctrl.h) = 052b41bf09d41d1d5f980db011603b3b04f6142f
|
||||
SHA1 (patch-src_zm__rtp__source.cpp) = 5341938eefe5def49dc8f3e3b760d86cabd17772
|
||||
SHA1 (patch-src_zm__sdp.cpp) = ed89bc14ae557281bb43baca9c90b78d801d8eb1
|
||||
SHA1 (patch-src_zm__stream.cpp) = 64655550ff36576377cfdea918fe85253428e227
|
||||
|
|
18
security/zoneminder/patches/patch-src_zm__rtp__ctrl.h
Normal file
18
security/zoneminder/patches/patch-src_zm__rtp__ctrl.h
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-src_zm__rtp__ctrl.h,v 1.1 2020/07/12 16:58:42 gdt Exp $
|
||||
|
||||
Work around:
|
||||
zm_rtp_ctrl.h:128:31: error: flexible array member 'RtpCtrlThread::RtcpPacket::<unnamed union>::Bye::srcN' in an otherwise empty 'struct RtpCtrlThread::RtcpPacket::<unnamed union>::Bye'
|
||||
|
||||
Not reported upstream because pkgsrc is out of date; to be done if this is not resolved by updating.
|
||||
|
||||
--- src/zm_rtp_ctrl.h.orig 2015-02-05 02:52:37.000000000 +0000
|
||||
+++ src/zm_rtp_ctrl.h
|
||||
@@ -125,7 +125,7 @@ private:
|
||||
// BYE
|
||||
struct Bye
|
||||
{
|
||||
- uint32_t srcN[]; // list of sources
|
||||
+ uint32_t srcN[0]; // list of sources
|
||||
// can't express trailing text for reason (what does this mean? it's not even english!)
|
||||
} bye;
|
||||
} body;
|
Loading…
Reference in a new issue