Update to 3.11.1:

2014-5-26 meld 3.11.1
=====================

  Features:

   * New (alpha) infrastructure for stand-alone Windows builds (Kai Willadsen)
   * Display renames and metadata in Bazaar repositories (Louis des Landes)
   * Improved tab labels in version control comparisons (Kai Willadsen)
   * New merge-order preference to accompany comparison-order (Kai Willadsen)
   * Added a prompt to mark a conflict as resolved from file comparison (Kai
     Willadsen)

  Fixes:

   * Fix filtering for shallow folder comparisons (Casey)
   * Several install and distribution fixes (Kai Willadsen)
   * Sundry bug fixes (Dominique Leuenberger, Thomas Klausner, Louis des
     Landes, Kai Willadsen)

  Translations:

   * Andika Triwidada (id)
   * Benjamin Steinwender (de)
   * Daniel Mustieles (es)
   * Facundo Dario Illanes (es)
   * Inaki Larranaga Murgoitio (eu)
   * Jiri Grönroos (fi)
   * Marek Černocký (cs)
   * Milo Casagrande (it)
   * Piotr Drąg (pl)
   * Rafael Ferreira (pt_BR)
   * Tom Tryfonidis (el)
   * Ville-Pekka Vainio (fi)
   * Мирослав Николић (sr, sr@latin)
This commit is contained in:
wiz 2014-05-27 18:10:52 +00:00
parent 84bedc5e28
commit 4892142e3a
4 changed files with 27 additions and 25 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.4 2014/05/09 07:37:00 wiz Exp $
# $NetBSD: Makefile,v 1.5 2014/05/27 18:10:52 wiz Exp $
DISTNAME= meld-3.11.0
PKGREVISION= 2
DISTNAME= meld-3.11.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/meld/3.11/}
EXTRACT_SUFX= .tar.xz

View file

@ -1,6 +1,5 @@
@comment $NetBSD: PLIST,v 1.1 2014/02/24 12:24:11 wiz Exp $
@comment $NetBSD: PLIST,v 1.2 2014/05/27 18:10:52 wiz Exp $
bin/meld
man/man1/meld.1
${PYSITELIB}/${EGG_FILE}
${PYSITELIB}/meld/__init__.py
${PYSITELIB}/meld/__init__.pyc
@ -11,6 +10,9 @@ ${PYSITELIB}/meld/build_helpers.pyo
${PYSITELIB}/meld/conf.py
${PYSITELIB}/meld/conf.pyc
${PYSITELIB}/meld/conf.pyo
${PYSITELIB}/meld/const.py
${PYSITELIB}/meld/const.pyc
${PYSITELIB}/meld/const.pyo
${PYSITELIB}/meld/diffmap.py
${PYSITELIB}/meld/diffmap.pyc
${PYSITELIB}/meld/diffmap.pyo
@ -172,6 +174,7 @@ ${PYSITELIB}/meld/vc/svn_17.pyo
${PYSITELIB}/meld/vcview.py
${PYSITELIB}/meld/vcview.pyc
${PYSITELIB}/meld/vcview.pyo
man/man1/meld.1
share/appdata/meld.appdata.xml
share/applications/meld.desktop
share/doc/${PKGNAME}/COPYING
@ -193,6 +196,22 @@ share/help/C/meld/resolving-conflicts.page
share/help/C/meld/text-filters.page
share/help/C/meld/vc-mode.page
share/help/C/meld/vc-supported.page
share/help/el/meld/command-line.page
share/help/el/meld/file-changes.page
share/help/el/meld/file-filters.page
share/help/el/meld/file-mode.page
share/help/el/meld/flattened-view.page
share/help/el/meld/folder-mode.page
share/help/el/meld/index.page
share/help/el/meld/introduction.page
share/help/el/meld/keyboard-shortcuts.page
share/help/el/meld/legal.xml
share/help/el/meld/missing-functionality.page
share/help/el/meld/preferences.page
share/help/el/meld/resolving-conflicts.page
share/help/el/meld/text-filters.page
share/help/el/meld/vc-mode.page
share/help/el/meld/vc-supported.page
share/help/es/meld/command-line.page
share/help/es/meld/file-changes.page
share/help/es/meld/file-filters.page
@ -293,5 +312,3 @@ share/meld/ui/tab-placeholder.ui
share/meld/ui/vcview-ui.xml
share/meld/ui/vcview.ui
share/mime/packages/meld.xml
@pkgdir share/help/es/meld/figures
@pkgdir share/help/C/meld/figures

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.1 2014/02/24 12:24:11 wiz Exp $
$NetBSD: distinfo,v 1.2 2014/05/27 18:10:53 wiz Exp $
SHA1 (meld-3.11.0.tar.xz) = 3a23ef1b813bdcb3f8fd0308d46ba83f8536c90b
RMD160 (meld-3.11.0.tar.xz) = 1406fc6cb01526f1cdc6291ccd4f579d4bf9e599
Size (meld-3.11.0.tar.xz) = 408668 bytes
SHA1 (patch-meld_build__helpers.py) = 709f0ebdf247632c938e9ec7144b688750a1af25
SHA1 (meld-3.11.1.tar.xz) = d7a641bcb67dbae5087708bfe256a8385f015e13
RMD160 (meld-3.11.1.tar.xz) = 3063f24c59411a572abaefd4af44493f5a05f758
Size (meld-3.11.1.tar.xz) = 437704 bytes

View file

@ -1,13 +0,0 @@
$NetBSD: patch-meld_build__helpers.py,v 1.1 2014/02/24 12:24:11 wiz Exp $
--- meld/build_helpers.py.orig 2014-02-22 20:41:47.000000000 +0000
+++ meld/build_helpers.py
@@ -135,7 +135,7 @@ class build_help(distutils.cmd.Command):
for page in pages:
page_path = os.path.join(build_path, page)
if not os.path.exists(page_path):
- print "Skipping missing file", page_path
+ print ("Skipping missing file", page_path)
continue
lint = ['xmllint', '--noout', '--noent', '--path', build_path,
'--xinclude', page_path]