Update to 1.9.2.

Release 1.9.2 (2012-07-03)
----------------------------

Notable Bugfixes
''''''''''''''''

- Several regressions in support for reading (`#1636`_), writing/modifying
  (`#1670`_, `#1749`_), verifying (`#1628`_) and repairing (`#1655`_, `#1669`_,
  `#1676`_, `#1689`_) mutable files have been fixed.
- FTP can now list directories containing mutable files, although it
  still does not support reading or writing mutable files. (`#680`_)
- The FTP frontend would previously show Jan 1 1970 for all timestamps;
  now it shows the correct modification time of the directory entry.
  (`#1688`_)
- If a node is configured to report incidents to a log gatherer, but the
  gatherer is offline when some incidents occur, it would previously not
  "catch up" with those incidents as intended. (`#1725`_)
- OpenBSD 5 is now supported. (`#1584`_)
- The ``count-good-share-hosts`` field of file check results is now
  computed correctly. (`#1115`_)

Configuration/Behavior Changes
''''''''''''''''''''''''''''''

- The capability of the upload directory for the drop-upload frontend
  is now specified in the file ``private/drop_upload_dircap`` under
  the gateway's node directory, rather than in its ``tahoe.cfg``.
  (`#1593`_)
This commit is contained in:
gdt 2012-07-07 00:34:18 +00:00
parent 8abf6fae46
commit 48a24c7c50
4 changed files with 22 additions and 20 deletions

View file

@ -1,11 +1,10 @@
# $NetBSD: Makefile,v 1.12 2012/05/25 11:25:56 gdt Exp $
# $NetBSD: Makefile,v 1.13 2012/07/07 00:34:18 gdt Exp $
#
VERSION= 1.9.1
VERSION= 1.9.2
DISTNAME= allmydata-tahoe-${VERSION}
EGG_NAME= allmydata_tahoe-${VERSION}
PKGNAME= tahoe-lafs-${VERSION}
PKGREVISION= 2
CATEGORIES= filesystems
MASTER_SITES= https://tahoe-lafs.org/source/tahoe-lafs/releases/
#for beta, add
@ -22,6 +21,7 @@ USE_TOOLS= gmake
PKG_DESTDIR_SUPPORT= user-destdir
# $WRKDIR/Makefile has 'python' hardcoded; this works after hand-patching
TEST_TARGET= test
# TODO

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.4 2011/11/09 00:30:12 gdt Exp $
@comment $NetBSD: PLIST,v 1.5 2012/07/07 00:34:18 gdt Exp $
bin/tahoe
${PYSITELIB}/allmydata/__init__.py
${PYSITELIB}/allmydata/__init__.pyc
@ -345,6 +345,9 @@ ${PYSITELIB}/allmydata/test/test_encodingutil.pyo
${PYSITELIB}/allmydata/test/test_filenode.py
${PYSITELIB}/allmydata/test/test_filenode.pyc
${PYSITELIB}/allmydata/test/test_filenode.pyo
${PYSITELIB}/allmydata/test/test_ftp.py
${PYSITELIB}/allmydata/test/test_ftp.pyc
${PYSITELIB}/allmydata/test/test_ftp.pyo
${PYSITELIB}/allmydata/test/test_hashtree.py
${PYSITELIB}/allmydata/test/test_hashtree.pyc
${PYSITELIB}/allmydata/test/test_hashtree.pyo
@ -375,9 +378,6 @@ ${PYSITELIB}/allmydata/test/test_mutable.pyo
${PYSITELIB}/allmydata/test/test_netstring.py
${PYSITELIB}/allmydata/test/test_netstring.pyc
${PYSITELIB}/allmydata/test/test_netstring.pyo
${PYSITELIB}/allmydata/test/test_nevow.py
${PYSITELIB}/allmydata/test/test_nevow.pyc
${PYSITELIB}/allmydata/test/test_nevow.pyo
${PYSITELIB}/allmydata/test/test_no_network.py
${PYSITELIB}/allmydata/test/test_no_network.pyc
${PYSITELIB}/allmydata/test/test_no_network.pyo
@ -553,7 +553,6 @@ ${PYSITELIB}/allmydata/web/directory.pyo
${PYSITELIB}/allmydata/web/directory.xhtml
${PYSITELIB}/allmydata/web/download-status-timeline.xhtml
${PYSITELIB}/allmydata/web/download-status.xhtml
${PYSITELIB}/allmydata/web/download_status_timeline.js
${PYSITELIB}/allmydata/web/filenode.py
${PYSITELIB}/allmydata/web/filenode.pyc
${PYSITELIB}/allmydata/web/filenode.pyo
@ -566,14 +565,12 @@ ${PYSITELIB}/allmydata/web/introducer.xhtml
${PYSITELIB}/allmydata/web/introweb.py
${PYSITELIB}/allmydata/web/introweb.pyc
${PYSITELIB}/allmydata/web/introweb.pyo
${PYSITELIB}/allmydata/web/jquery-1.6.1.min.js
${PYSITELIB}/allmydata/web/literal-check-results.xhtml
${PYSITELIB}/allmydata/web/manifest.xhtml
${PYSITELIB}/allmydata/web/map-update-status.xhtml
${PYSITELIB}/allmydata/web/operations.py
${PYSITELIB}/allmydata/web/operations.pyc
${PYSITELIB}/allmydata/web/operations.pyo
${PYSITELIB}/allmydata/web/protovis-3.3.1.min.js
${PYSITELIB}/allmydata/web/provisioning.xhtml
${PYSITELIB}/allmydata/web/publish-status.xhtml
${PYSITELIB}/allmydata/web/reliability.py
@ -585,6 +582,12 @@ ${PYSITELIB}/allmydata/web/retrieve-status.xhtml
${PYSITELIB}/allmydata/web/root.py
${PYSITELIB}/allmydata/web/root.pyc
${PYSITELIB}/allmydata/web/root.pyo
${PYSITELIB}/allmydata/web/static/d3-2.4.6.min.js
${PYSITELIB}/allmydata/web/static/d3-2.4.6.time.min.js
${PYSITELIB}/allmydata/web/static/download_status_timeline.js
${PYSITELIB}/allmydata/web/static/icon.png
${PYSITELIB}/allmydata/web/static/jquery-1.6.1.min.js
${PYSITELIB}/allmydata/web/static/tahoe.css
${PYSITELIB}/allmydata/web/statistics.xhtml
${PYSITELIB}/allmydata/web/status.py
${PYSITELIB}/allmydata/web/status.pyc
@ -594,7 +597,6 @@ ${PYSITELIB}/allmydata/web/storage.py
${PYSITELIB}/allmydata/web/storage.pyc
${PYSITELIB}/allmydata/web/storage.pyo
${PYSITELIB}/allmydata/web/storage_status.xhtml
${PYSITELIB}/allmydata/web/tahoe.css
${PYSITELIB}/allmydata/web/unlinked.py
${PYSITELIB}/allmydata/web/unlinked.pyc
${PYSITELIB}/allmydata/web/unlinked.pyo

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.7 2012/01/13 01:14:56 gdt Exp $
$NetBSD: distinfo,v 1.8 2012/07/07 00:34:18 gdt Exp $
SHA1 (allmydata-tahoe-1.9.1.tar.bz2) = c1e3802f893438e4fcc83f1c178d498027000bec
RMD160 (allmydata-tahoe-1.9.1.tar.bz2) = 3b934fe834c14a550b8df42e2a0856bcee214fcf
Size (allmydata-tahoe-1.9.1.tar.bz2) = 1126286 bytes
SHA1 (patch-aa) = 68f09259cd8e4aab5dd6c8a4fbac1aac6c159e23
SHA1 (allmydata-tahoe-1.9.2.tar.bz2) = 5101f527042fbcb4d27712ac1f4480d675e3c8a6
RMD160 (allmydata-tahoe-1.9.2.tar.bz2) = 78d3cc85072a98b09a87bd6918972aedfe3e5b00
Size (allmydata-tahoe-1.9.2.tar.bz2) = 1139559 bytes
SHA1 (patch-aa) = 38b8a3e75ea9f948ae6da27abd227233d9a45697

View file

@ -1,14 +1,14 @@
$NetBSD: patch-aa,v 1.2 2012/01/13 01:14:56 gdt Exp $
$NetBSD: patch-aa,v 1.3 2012/07/07 00:34:18 gdt Exp $
Upstream incorrectly installs test code. Patch from David-Sarah
Hopwood (of upstream) in private mail.
--- setup.py.orig 2012-01-11 22:40:51.000000000 +0000
--- setup.py.orig 2012-05-31 22:25:33.000000000 +0000
+++ setup.py
@@ -453,8 +453,7 @@ setup(name=APPNAME,
'allmydata.test',
@@ -467,8 +467,7 @@ setup(name=APPNAME,
'allmydata.util',
'allmydata.web',
'allmydata.web.static',
- 'allmydata.windows',
- 'buildtest'],
+ 'allmydata.windows'],