Update to 2.4.58:

2.4.58:

    Rob Clark (3):
      fix compile error on 32bit systems
      more compile fix
      configure.ac: bump version to 2.4.58 for release

2.4.57:

    Alex Deucher (2):
      radeon: add new CIK pci ids
      radeon: add new SI pci ids

    Benjamin Gaignard (1):
      modetest: Add support of STI driver

    Damien Lespiau (1):
      intel: Don't leak the test page in an has_userptr() error path

    Emil Velikov (27):
      all: include config.h only when available and use its defines
      libkms: remove explicit define _FILE_OFFSET_BITS 64
      libdrm, freedreno, intel, nouveau, radeon: add Makefile.sources
      libdrm,intel: Add Android build
      libdrm,intel: rework android header handling
      radeon: add Android build support
      nouveau: add Android build support
      freedreno: add Android build support
      android: add CleanSpec.mk
      freedreno: fd_bo_from_handle() remove duplicate declaration
      automake: remove obsolete makefiles
      Remove i810_drm.h and i830_drm.h from the distribution tarball
      automake: fix 'make commit-headers'
      configure: unconditionally check for atomic ops/primitives
      libkms: build the intel backend only when needed
      libkms: move sources lists to makefile.sources
      libkms: add Android build
      modetest: move sources lists to makefiles.sources
      modetest: add Android build
      automake: pick up all files for distribution.
      Add private mmap/munmap wrappers
      drm: use drm_mmap/drm_munmap wrappers
      libkms: use drm_mmap/drm_munmap wrappers
      nouveau: use drm_mmap/drm_munmap wrappers
      radeon: use drm_mmap/drm_munmap wrappers
      freedreno: use drm_mmap/drm_munmap wrappers
      intel: use drm_mmap/drm_munmap wrappers

    François Tigeot (1):
      drm: Implement drmCheckModesettingSupported() for DragonFly

    Lionel Landwerlin (4):
      atomic: add atomic_add_unless()
      intel: make bufmgr_gem shareable from different API
      intel: make bo_unreference() thread safe
      intel: make drm_intel_gem_bo_get_reloc_count() thread safe

    Maarten Lankhorst (6):
      nouveau: Only export public functions.
      radeon: Use symbol visibility.
      intel: Use symbol visibility.
      omap: Use symbol visibility.
      freedreno: Use symbol visibility.
      exynos: Use symbol visibility.

    Maks Naumov (1):
      radeon: Fix surf->bankh init by default value when surf->tile_split == 0

    Rafal Sapala (1):
      intel: Adding locks for drm objects synchronization.

    Rob Clark (2):
      freedreno: add dmabuf import/export helpers
      configure.ac: bump version to 2.4.57 for release

    Thierry Reding (1):
      configure: Support symbol visibility when available

    Tvrtko Ursulin (1):
      intel: Add support for userptr objects
This commit is contained in:
wiz 2014-10-01 09:39:30 +00:00
parent d713bf519a
commit 48a84aa28e
3 changed files with 11 additions and 11 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.47 2014/07/29 21:30:44 wiz Exp $
# $NetBSD: Makefile,v 1.48 2014/10/01 09:39:30 wiz Exp $
DISTNAME= libdrm-2.4.56
DISTNAME= libdrm-2.4.58
CATEGORIES= x11 graphics
MASTER_SITES= http://dri.freedesktop.org/libdrm/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,11 +1,11 @@
$NetBSD: distinfo,v 1.45 2014/07/29 21:30:44 wiz Exp $
$NetBSD: distinfo,v 1.46 2014/10/01 09:39:30 wiz Exp $
SHA1 (libdrm-2.4.56.tar.bz2) = c61feed76db0ca729febbc45794d13d04a3eeb53
RMD160 (libdrm-2.4.56.tar.bz2) = 10ef0d7af7f0cbe0cc05fadace0678c60e1bc8ba
Size (libdrm-2.4.56.tar.bz2) = 590856 bytes
SHA1 (libdrm-2.4.58.tar.bz2) = ef9a647796fa326e99ca9026a6d847172f39c66c
RMD160 (libdrm-2.4.58.tar.bz2) = d765d1d5860014e7295c12edc28a4d696ce8b0f1
Size (libdrm-2.4.58.tar.bz2) = 573202 bytes
SHA1 (patch-ab) = 66dadd3244bfa9c69be0982fd2108deb94483de2
SHA1 (patch-ac) = 67c998df7dfc0dabc86320ea6d015cede3e464ea
SHA1 (patch-ad) = b9c8d708830c8b182c8e491fe5a9e5d0f2d44a5f
SHA1 (patch-include_drm_drm.h) = d370e83da5c39f0e49094787c5f4580758c911b0
SHA1 (patch-libkms_linux.c) = 737d0a8e7b742ee9d24fec94c72de6b4915dd675
SHA1 (patch-libkms_vmwgfx.c) = 373390c7c33df27227607ee1b8110bc65ca37af6
SHA1 (patch-libkms_vmwgfx.c) = d49c046a70e5c0edbdb0a424473324cc2a3b6243

View file

@ -1,11 +1,11 @@
$NetBSD: patch-libkms_vmwgfx.c,v 1.1 2014/04/12 09:28:42 wiz Exp $
$NetBSD: patch-libkms_vmwgfx.c,v 1.2 2014/10/01 09:39:30 wiz Exp $
Provide compatibility errno number for non-Linux.
--- libkms/vmwgfx.c.orig 2013-08-12 18:01:22.000000000 +0000
--- libkms/vmwgfx.c.orig 2014-09-28 16:19:54.000000000 +0000
+++ libkms/vmwgfx.c
@@ -38,6 +38,10 @@
#include "xf86drm.h"
@@ -39,6 +39,10 @@
#include "libdrm.h"
#include "vmwgfx_drm.h"
+#ifndef ERESTART