Add missing prototypes for functions that should really be void.
This commit is contained in:
parent
ea2712439c
commit
48b297afca
4 changed files with 47 additions and 1 deletions
|
@ -1,6 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.4 2010/02/14 21:03:19 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.5 2012/12/20 22:04:14 joerg Exp $
|
||||
|
||||
SHA1 (spellcast.tar.Z) = 3c51aa1746d4b8385a87ab5af5ed78b48cc4ac19
|
||||
RMD160 (spellcast.tar.Z) = ed4751d902a58abdc2a79333541fc866170a642d
|
||||
Size (spellcast.tar.Z) = 129173 bytes
|
||||
SHA1 (patch-aa) = 0b407bfe80ca4170d54da83deebf5ea57952cf90
|
||||
SHA1 (patch-xgest.c) = 61e4fc03709995813d8a2ced3d4c8e651aa6072d
|
||||
SHA1 (patch-xquery.c) = fdf45bfbc4c8b9e530a966439e4dd0575351b7df
|
||||
SHA1 (patch-xspell.h) = aa77dc029e80f6926024a46d90ae927bee111ce3
|
||||
|
|
16
games/spellcast/patches/patch-xgest.c
Normal file
16
games/spellcast/patches/patch-xgest.c
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-xgest.c,v 1.1 2012/12/20 22:04:14 joerg Exp $
|
||||
|
||||
--- xgest.c.orig 2012-12-20 17:55:28.000000000 +0000
|
||||
+++ xgest.c
|
||||
@@ -272,10 +272,7 @@ int button;
|
||||
return ms_None;
|
||||
}
|
||||
|
||||
-int gesture_motion(py, xpos, ypos, button)
|
||||
-struct player *py;
|
||||
-int xpos, ypos;
|
||||
-int button;
|
||||
+void gesture_motion(struct player *py, int xpos, int ypos, int button)
|
||||
{
|
||||
int hitx, hity, hit;
|
||||
int posx, posy;
|
16
games/spellcast/patches/patch-xquery.c
Normal file
16
games/spellcast/patches/patch-xquery.c
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-xquery.c,v 1.1 2012/12/20 22:04:14 joerg Exp $
|
||||
|
||||
--- xquery.c.orig 2012-12-20 17:54:14.000000000 +0000
|
||||
+++ xquery.c
|
||||
@@ -670,10 +670,7 @@ int button;
|
||||
return ms_Query;
|
||||
}
|
||||
|
||||
-int query_motion(py, xpos, ypos, button)
|
||||
-struct player *py;
|
||||
-int xpos, ypos;
|
||||
-int button;
|
||||
+void query_motion(struct player *py, int xpos, int ypos, int button)
|
||||
{
|
||||
int hitrow;
|
||||
int qtype = py->answers[py->query_hit].query->qtype;
|
11
games/spellcast/patches/patch-xspell.h
Normal file
11
games/spellcast/patches/patch-xspell.h
Normal file
|
@ -0,0 +1,11 @@
|
|||
$NetBSD: patch-xspell.h,v 1.1 2012/12/20 22:04:14 joerg Exp $
|
||||
|
||||
--- xspell.h.orig 2012-12-20 17:55:01.000000000 +0000
|
||||
+++ xspell.h
|
||||
@@ -138,3 +138,6 @@ extern game *gameval;
|
||||
extern int turnstate;
|
||||
extern int movelist[];
|
||||
extern int blinklevel;
|
||||
+
|
||||
+void query_motion(struct player *py, int xpos, int ypos, int button);
|
||||
+void gesture_motion(struct player *py, int xpos, int ypos, int button);
|
Loading…
Reference in a new issue