Upgrade lang/newlisp from 10.6 to 10.7.1
Changes too numerous to include, see <http://www.newlisp.org/downloads/newLISP-10.7.1-Release.html> <http://www.newlisp.org/downloads/previous-release-notes/>
This commit is contained in:
parent
eef56f5cc0
commit
48ba735758
4 changed files with 22 additions and 35 deletions
|
@ -1,9 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.11 2016/04/01 16:22:15 jperkin Exp $
|
||||
# $NetBSD: Makefile,v 1.12 2019/04/24 13:09:45 hauke Exp $
|
||||
#
|
||||
|
||||
DISTNAME= newlisp-10.6.0
|
||||
DISTNAME= newlisp-10.7.1
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=newlisp/}
|
||||
MASTER_SITES= http://www.newlisp.org/downloads/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= ryoon@NetBSD.org
|
||||
|
@ -17,8 +17,6 @@ CONFIGURE_ARGS+= --prefix=${PREFIX}
|
|||
CONFIGURE_ARGS+= --mandir=${PREFIX}/${PKGMANDIR}
|
||||
CONFIGURE_ARGS+= --enable-readline
|
||||
|
||||
USE_GNU_READLINE= yes
|
||||
|
||||
USE_JAVA= run
|
||||
USE_JAVA2= yes
|
||||
|
||||
|
@ -32,6 +30,7 @@ SUBST_STAGE.interpreter= pre-configure
|
|||
SUBST_MESSAGE.interpreter= Fix shebang
|
||||
SUBST_FILES.interpreter= guiserver/*lsp util/syntax.cgi util/newlispdoc
|
||||
SUBST_SED.interpreter= -e 's,/usr/bin/newlisp,${PREFIX}/bin/newlisp,'
|
||||
SUBST_SED.interpreter+= -e 's,/usr/local/bin/newlisp,${PREFIX}/bin/newlisp,'
|
||||
SUBST_SED.interpreter+= -e 's,/usr/bin/env newlisp,${PREFIX}/bin/newlisp,'
|
||||
|
||||
.include "../../mk/readline.buildlink3.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.7 2014/07/07 14:25:31 ryoon Exp $
|
||||
@comment $NetBSD: PLIST,v 1.8 2019/04/24 13:09:45 hauke Exp $
|
||||
bin/newlisp
|
||||
bin/${PKGNAME}
|
||||
bin/newlisp-edit
|
||||
|
@ -51,7 +51,6 @@ share/${PKGNAME}/modules/cgi.lsp
|
|||
share/${PKGNAME}/modules/crypto.lsp
|
||||
share/${PKGNAME}/modules/ftp.lsp
|
||||
share/${PKGNAME}/modules/getopts.lsp
|
||||
share/${PKGNAME}/modules/gmp.lsp
|
||||
share/${PKGNAME}/modules/gsl.lsp
|
||||
share/${PKGNAME}/modules/infix.lsp
|
||||
share/${PKGNAME}/modules/mysql.lsp
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.12 2015/12/29 23:34:52 dholland Exp $
|
||||
$NetBSD: distinfo,v 1.13 2019/04/24 13:09:45 hauke Exp $
|
||||
|
||||
SHA1 (newlisp-10.6.0.tgz) = 8a3b23a72acfdbb00306f8c7419892b553b8026e
|
||||
RMD160 (newlisp-10.6.0.tgz) = 3f710834a68f1a43fe2e22b21a273dc8a77c35fe
|
||||
SHA512 (newlisp-10.6.0.tgz) = 2356d9ba7b4a01a58705be554e01660c3706e79aa725ff97e1e85c60cd103fd2ad9dac27f45cc60feaeffdfa4d6a98f752013cbbcfb568de88df18eab4b637b0
|
||||
Size (newlisp-10.6.0.tgz) = 1670428 bytes
|
||||
SHA1 (newlisp-10.7.1.tgz) = 724e7fd1c0512a4236fde022825dfd7ef859ca96
|
||||
RMD160 (newlisp-10.7.1.tgz) = e0981aafef32790cc66cdb570b628930a6e45c22
|
||||
SHA512 (newlisp-10.7.1.tgz) = dff9ea671581e9421028abec786ec4f4557b150ffff8357c42c03af414d6d78a277b7c13cf08cd9950427eff32570a15b85072009e7596e66592c8a4186c6560
|
||||
Size (newlisp-10.7.1.tgz) = 1721645 bytes
|
||||
SHA1 (patch-configure-alt) = 6ac73164de672a048f7cde791e8958633fdae47e
|
||||
SHA1 (patch-guiserver_guiserver.lsp) = 47e29e73e9ecb6d96f42287a17398dd13071c572
|
||||
SHA1 (patch-newlisp.c) = 8f21fdd3ae791e1ef51bb52365fb63faa30af633
|
||||
SHA1 (patch-newlisp.c) = 2ae925e56be9ed4197876493c077976a1690726b
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-newlisp.c,v 1.3 2015/12/29 23:34:52 dholland Exp $
|
||||
$NetBSD: patch-newlisp.c,v 1.4 2019/04/24 13:09:45 hauke Exp $
|
||||
|
||||
Fix build with recent readline.
|
||||
|
||||
--- newlisp.c.orig 2014-04-08 14:02:27.000000000 +0000
|
||||
--- newlisp.c.orig 2017-01-25 16:42:21.000000000 +0000
|
||||
+++ newlisp.c
|
||||
@@ -138,7 +138,7 @@ char preLoad[] =
|
||||
"(define (Class:Class) (cons (context) (args)))";
|
||||
|
@ -13,18 +13,16 @@ Fix build with recent readline.
|
|||
#endif
|
||||
/* --------------------- globals -------------------------------------- */
|
||||
|
||||
@@ -904,8 +904,8 @@ if(errorReg && !isNil((CELL*)errorEvent-
|
||||
|
||||
@@ -931,7 +931,7 @@ if(errorReg && !isNil((CELL*)errorEvent-
|
||||
#ifdef READLINE
|
||||
rl_readline_name = "newlisp";
|
||||
-rl_attempted_completion_function = (CPPFunction *)newlisp_completion;
|
||||
-#if defined(LINUX) || defined(_BSD)
|
||||
+rl_attempted_completion_function = newlisp_completion;
|
||||
+#if defined(LINUX)
|
||||
rl_attempted_completion_function = (char ** (*) (const char *, int, int))newlisp_completion;
|
||||
-#if defined(LINUX) || defined(_BSD) || defined(KFREEBSD)
|
||||
+#if defined(LINUX) || defined(KFREEBSD)
|
||||
/* in Bash .inputrc put 'set blink-matching-paren on' */
|
||||
rl_set_paren_blink_timeout(300000); /* 300 ms */
|
||||
#endif
|
||||
@@ -959,7 +959,7 @@ return 0;
|
||||
@@ -985,7 +985,7 @@ return 0;
|
||||
#endif /* not LIBRARY */
|
||||
|
||||
#ifdef READLINE
|
||||
|
@ -33,21 +31,12 @@ Fix build with recent readline.
|
|||
{
|
||||
static int list_index, len, clen;
|
||||
char * name;
|
||||
@@ -984,15 +984,9 @@ while((name = primitive[list_index].name
|
||||
return ((char *)NULL);
|
||||
}
|
||||
@@ -1012,7 +1012,7 @@ return ((char *)NULL);
|
||||
|
||||
char ** completion_matches(const char * text, char * (*commands)(const char *, int));
|
||||
|
||||
-#ifdef _BSD
|
||||
-extern char **completion_matches PARAMS((char *, rl_compentry_func_t *));
|
||||
-#else
|
||||
-char ** completion_matches(const char * text, CPFunction commands);
|
||||
-#endif
|
||||
-
|
||||
-char ** newlisp_completion (char * text, int start, int end)
|
||||
+char ** newlisp_completion (const char * text, int start, int end)
|
||||
{
|
||||
-return(completion_matches(text, (CPFunction *)command_generator));
|
||||
+return(completion_matches(text, command_generator));
|
||||
return(completion_matches(text, (char * (*) (const char *, int) )command_generator));
|
||||
}
|
||||
#endif /* READLINE */
|
||||
|
||||
|
|
Loading…
Reference in a new issue