Importing graphics/ruby-color-tools 1.0.0.

color-tools is a Ruby library to provide RGB, CMYK, and other
colourspace support to applications that require it. It also provides
152 named RGB colours. It offers 152 named RGB colours (184 with
spelling variations) that are commonly supported and used in HTML,
SVG, and X11 applications. A technique for generating a monochromatic
contrasting palette is also included.
This commit is contained in:
taca 2010-09-12 01:43:31 +00:00
parent 40450b69cc
commit 48e49097c4
14 changed files with 199 additions and 0 deletions

View file

@ -0,0 +1,6 @@
color-japanese defines RGB value for Japanese color names.
Supported color names are:
* Japanese traditional colors
* JIS Z 8102 (Names of non-luminous object colours)

View file

@ -0,0 +1,17 @@
# $NetBSD: Makefile,v 1.1.1.1 2010/09/12 01:43:31 taca Exp $
DISTNAME= color-japanese-1.0.0
CATEGORIES= graphics
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://color-japanese.rubyforge.org/
COMMENT= Defines RGB value for Japanese color names
LICENSE= mit
DEPENDS+= ${RUBY_PKGPREFIX}-color-tools>0:../../graphics/ruby-color-tools
DEPENDS+= ${RUBY_PKGPREFIX}-hoe>=1.2.0:../../devel/hoe
CONFLICTS+= ruby[1-9][0-9]-color-japanese-[0-9]*
.include "../../lang/ruby/gem.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,41 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2010/09/12 01:43:31 taca Exp $
bin/jcolorc
${GEM_HOME}/cache/${GEM_NAME}.gem
${GEM_LIBDIR}/CHANGELOG.txt
${GEM_LIBDIR}/History.txt
${GEM_LIBDIR}/Manifest.txt
${GEM_LIBDIR}/README.txt
${GEM_LIBDIR}/Rakefile
${GEM_LIBDIR}/bin/jcolorc
${GEM_LIBDIR}/examples/Rakefile
${GEM_LIBDIR}/examples/color-test.html.in
${GEM_LIBDIR}/examples/color2html.rb
${GEM_LIBDIR}/examples/default.css.in
${GEM_LIBDIR}/examples/default.html
${GEM_LIBDIR}/examples/palletize.rb
${GEM_LIBDIR}/helper/helper.rb
${GEM_LIBDIR}/helper/rake.rb
${GEM_LIBDIR}/helper/rake_sh_filter.rb
${GEM_LIBDIR}/helper/util.rb
${GEM_LIBDIR}/lib/color/rgb/jp.rb
${GEM_LIBDIR}/lib/color/rgb/jp/base.rb
${GEM_LIBDIR}/lib/color/rgb/jp/base/color_name.rb
${GEM_LIBDIR}/lib/color/rgb/jp/base/encode.rb
${GEM_LIBDIR}/lib/color/rgb/jp/base/named_rgb.rb
${GEM_LIBDIR}/lib/color/rgb/jp/base/pallet.rb
${GEM_LIBDIR}/lib/color/rgb/jp/compiler/command.rb
${GEM_LIBDIR}/lib/color/rgb/jp/compiler/compiler.rb
${GEM_LIBDIR}/lib/color/rgb/jp/jisz8102.rb
${GEM_LIBDIR}/lib/color/rgb/jp/traditional.rb
${GEM_LIBDIR}/lib/color/rgb/jp/version.rb
${GEM_LIBDIR}/setup.rb
${GEM_LIBDIR}/test/helper.rb
${GEM_LIBDIR}/test/test_color_name.rb
${GEM_LIBDIR}/test/test_compiler.rb
${GEM_LIBDIR}/test/test_encode.rb
${GEM_LIBDIR}/test/test_jisz8102.rb
${GEM_LIBDIR}/test/test_named_rgb.rb
${GEM_LIBDIR}/test/test_pallet.rb
${GEM_LIBDIR}/test/test_traditional.rb
${GEM_LIBDIR}/test/test_version.rb
${GEM_HOME}/specifications/${GEM_NAME}.gemspec

View file

@ -0,0 +1,15 @@
$NetBSD: distinfo,v 1.1.1.1 2010/09/12 01:43:31 taca Exp $
SHA1 (color-japanese-1.0.0.gem) = 7256f40953e0165fdebccd02104f089c2a4fbe9a
RMD160 (color-japanese-1.0.0.gem) = 7f2b4dd64e3509b2c1717a9664579079c4e689a3
Size (color-japanese-1.0.0.gem) = 52224 bytes
SHA1 (patch-aa) = 79e95ade6884992331b40f2a3fe33757d66d8d1e
SHA1 (patch-ab) = c0065f239829ddd7c3e86d398a4f3fe97b2b0828
SHA1 (patch-ac) = 95e6740114cdf9793bac9576c35fa65b60d270ab
SHA1 (patch-ad) = 5f3cbd4c2aaaace57830f3cfc16f2d8c568166b1
SHA1 (patch-ae) = 9f12f8c9d30ee2694d259ad3af2f591719fc5fc2
SHA1 (patch-af) = fa93a807efa58dc5197c3483d9a8ff5c42cc5e99
SHA1 (patch-ag) = d03e9a2c3d5d7e7575d995b9845e28547498daa8
SHA1 (patch-ah) = db26d3b28fdd393a5e3a0e036d0af5c38a68c3ab
SHA1 (patch-ai) = d246acf52f9c50db32557248f0eb5a3b4ed1975b
SHA1 (patch-aj) = 9f755fcb6c041b1c5f7bf0036fb66c832ccfd6c7

View file

@ -0,0 +1,12 @@
$NetBSD: patch-aa,v 1.1.1.1 2010/09/12 01:43:31 taca Exp $
Add macig comment to specify script encoding.
--- bin/jcolorc.orig 2010-09-03 08:05:33.000000000 +0000
+++ bin/jcolorc
@@ -1,4 +1,5 @@
#!/usr/bin/ruby
+# coding: utf-8
#
# == NAME

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ab,v 1.1.1.1 2010/09/12 01:43:31 taca Exp $
Fix script encoding.
--- examples/color2html.rb.orig 2010-09-03 08:05:33.000000000 +0000
+++ examples/color2html.rb
@@ -1,4 +1,4 @@
-# -*- encoding: utf8 -*-
+# -*- encoding: utf-8 -*-
require "erb"
require "optparse"

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ac,v 1.1.1.1 2010/09/12 01:43:31 taca Exp $
Fix script encoding.
--- lib/color/rgb/jp/jisz8102.rb.orig 2010-09-03 08:05:33.000000000 +0000
+++ lib/color/rgb/jp/jisz8102.rb
@@ -1,4 +1,4 @@
-# -*- encoding: utf8 -*-
+# -*- encoding: utf-8 -*-
require "color"
require "color/rgb/jp/base"

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ad,v 1.1.1.1 2010/09/12 01:43:31 taca Exp $
Fix script encoding.
--- lib/color/rgb/jp/traditional.rb.orig 2010-09-03 08:05:33.000000000 +0000
+++ lib/color/rgb/jp/traditional.rb
@@ -1,4 +1,4 @@
-# -*- encoding: utf8 -*-
+# -*- encoding: utf-8 -*-
require "color"
require "color/rgb/jp/base"

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ae,v 1.1.1.1 2010/09/12 01:43:31 taca Exp $
Fix script encoding.
--- test/test_color_name.rb.orig 2010-09-03 08:05:33.000000000 +0000
+++ test/test_color_name.rb
@@ -1,4 +1,4 @@
-# -*- encoding: utf8 -*-
+# -*- encoding: utf-8 -*-
require File.dirname(__FILE__) + '/helper.rb'

View file

@ -0,0 +1,12 @@
$NetBSD: patch-af,v 1.1.1.1 2010/09/12 01:43:31 taca Exp $
Fix script encoding.
--- test/test_compiler.rb.orig 2010-09-03 08:05:33.000000000 +0000
+++ test/test_compiler.rb
@@ -1,4 +1,4 @@
-# -*- encoding: utf8 -*-
+# -*- encoding: utf-8 -*-
require File.dirname(__FILE__) + '/helper.rb'
require "color/rgb/jp/compiler/compiler"

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ag,v 1.1.1.1 2010/09/12 01:43:31 taca Exp $
Fix script encoding.
--- test/test_encode.rb.orig 2010-09-03 08:05:33.000000000 +0000
+++ test/test_encode.rb
@@ -1,4 +1,4 @@
-# -*- encoding: utf8 -*-
+# -*- encoding: utf-8 -*-
require File.dirname(__FILE__) + '/helper.rb'

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ah,v 1.1.1.1 2010/09/12 01:43:31 taca Exp $
Fix script encoding.
--- test/test_jisz8102.rb.orig 2010-09-03 08:05:33.000000000 +0000
+++ test/test_jisz8102.rb
@@ -1,4 +1,4 @@
-# -*- encoding: utf8 -*-
+# -*- encoding: utf-8 -*-
require File.dirname(__FILE__) + '/helper.rb'

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ai,v 1.1.1.1 2010/09/12 01:43:31 taca Exp $
Fix script encoding.
--- test/test_pallet.rb.orig 2010-09-03 08:05:33.000000000 +0000
+++ test/test_pallet.rb
@@ -1,4 +1,4 @@
-# -*- encoding: utf8 -*-
+# -*- encoding: utf-8 -*-
require File.dirname(__FILE__) + '/helper.rb'

View file

@ -0,0 +1,12 @@
$NetBSD: patch-aj,v 1.1.1.1 2010/09/12 01:43:31 taca Exp $
Fix script encoding.
--- test/test_traditional.rb.orig 2010-09-03 08:05:33.000000000 +0000
+++ test/test_traditional.rb
@@ -1,4 +1,4 @@
-# -*- encoding: utf8 -*-
+# -*- encoding: utf-8 -*-
require File.dirname(__FILE__) + '/helper.rb'