Update to 1.4.0.

Change default backend to hunspell.
aspell support is now a (disabled by default) option.
Add some other options.

Remove aspell from includes in buildlink3.mk. The backends
are abstracted into dynamically loaded modules and don't need
to be pulled in by buildlink3.mk.

Release notes:
Voikko (Finnish) language support. Zemberek (Turkish) language support.
Better support for Unicode in the personal dictionaries. Personal
dictionaries offer better suggestions. OpenOffice's dictionaries are used
on Windows. Aspell works on Windows. This release can use a system-wide
Hunspell/Myspell installation on Unix-like platforms. Hunspell 1.2.1 and
NET bindings are required. This release has more lax language matching
rules. It uses XDG's data-dirs spec for locating dictionaries. There are
many unit tests and bugfixes.
This commit is contained in:
wiz 2008-04-14 11:35:49 +00:00
parent f3dab88213
commit 48ed320b56
8 changed files with 69 additions and 56 deletions

View file

@ -3,10 +3,15 @@ for dealing with different spell checking libraries.
Enchant is meant to provide a generic interface into various existing
spell checking libaries. These include, but are not limited to:
* Aspell/Pspell
* Ispell
* Hspell
* Uspell
* Aspell/Pspell (intends to replace Ispell)
* Ispell (old as sin, could be interpreted as a defacto standard)
* MySpell/Hunspell (an OOo project, also used by Mozilla)
* Uspell (primarily Yiddish, Hebrew, and Eastern European
languages - hosted in AbiWord's CVS under the module "uspell")
* Hspell (Hebrew)
* Zemberek (Turkish)
* Voikko (Finnish)
* AppleSpell (Mac OSX)
Enchant is also meant to be used in a cross-platform (XP) environment.
Part of this means that Enchant wants to limit its number of external
@ -15,9 +20,3 @@ enchant consumer (i.e. a Word Processor) should not need to know
about what backend providers Enchant knows about. In fact, Enchant
shouldn't even need to know this information itself. To accomplish
this, all of Enchant's providers are DLLs.
Enchant is also meant to be used in a multi-user environment, such
as Unix. It is preferable to have both a $USER and a $GLOBAL
location for both provider DLLs and for dictionaries themselves,
when possible. Enchant's DLL location algorithm takes this into
account, and gives preference to the $USER DLLs, when found.

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.22 2006/12/05 10:28:27 wiz Exp $
# $NetBSD: Makefile,v 1.23 2008/04/14 11:35:50 wiz Exp $
#
DISTNAME= enchant-1.3.0
DISTNAME= enchant-1.4.0
CATEGORIES= textproc
MASTER_SITES= http://www.abisource.com/downloads/enchant/1.3.0/
MASTER_SITES= http://www.abisource.com/downloads/enchant/1.4.0/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.abisource.com/projects/enchant/
@ -19,6 +19,7 @@ PKGCONFIG_OVERRIDE+= enchant.pc.in
GNU_CONFIGURE= yes
CFLAGS.SunOS+= -D__EXTENSIONS__
.include "options.mk"
.include "../../devel/glib2/buildlink3.mk"
.include "../../textproc/aspell/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,12 +1,12 @@
@comment $NetBSD: PLIST,v 1.4 2006/07/12 17:52:16 wiz Exp $
@comment $NetBSD: PLIST,v 1.5 2008/04/14 11:35:50 wiz Exp $
bin/enchant
bin/enchant-lsmod
include/enchant/enchant++.h
include/enchant/enchant-provider.h
include/enchant/enchant.h
lib/enchant/libenchant_aspell.la
lib/enchant/libenchant_ispell.la
lib/enchant/libenchant_myspell.la
${PLIST.aspell}lib/enchant/libenchant_aspell.la
${PLIST.ispell}lib/enchant/libenchant_ispell.la
${PLIST.hunspell}lib/enchant/libenchant_myspell.la
lib/libenchant.la
lib/pkgconfig/enchant.pc
man/man1/enchant.1

View file

@ -1,4 +1,4 @@
# $NetBSD: buildlink3.mk,v 1.10 2006/07/08 23:11:10 jlam Exp $
# $NetBSD: buildlink3.mk,v 1.11 2008/04/14 11:35:50 wiz Exp $
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
ENCHANT_BUILDLINK3_MK:= ${ENCHANT_BUILDLINK3_MK}+
@ -17,7 +17,8 @@ BUILDLINK_ABI_DEPENDS.enchant+= enchant>=1.1.6nb1
BUILDLINK_PKGSRCDIR.enchant?= ../../textproc/enchant
.endif # ENCHANT_BUILDLINK3_MK
# spelling libraries are loaded dynamically and do not need
# to be included here
.include "../../devel/glib2/buildlink3.mk"
.include "../../textproc/aspell/buildlink3.mk"
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}

View file

@ -1,7 +1,5 @@
$NetBSD: distinfo,v 1.8 2007/11/13 21:19:45 rillig Exp $
$NetBSD: distinfo,v 1.9 2008/04/14 11:35:50 wiz Exp $
SHA1 (enchant-1.3.0.tar.gz) = 140ffd2798d94e5f77cc28a37086c75b830f07d8
RMD160 (enchant-1.3.0.tar.gz) = c2025152d0e6ff4441abeb9606e01cfe99e84bad
Size (enchant-1.3.0.tar.gz) = 539040 bytes
SHA1 (patch-aa) = 65bc94dfeef4fefdf7a16d33e02c0950fe2a7881
SHA1 (patch-ab) = 80ef782fe11bd7ad04b71bd224d9a87fc4fc8bd8
SHA1 (enchant-1.4.0.tar.gz) = 1a3c140c96769d3268a7f1faf7d9400016985537
RMD160 (enchant-1.4.0.tar.gz) = 84a253e665f71ba5b3277ad95a403ea386d42ba4
Size (enchant-1.4.0.tar.gz) = 601930 bytes

View file

@ -0,0 +1,44 @@
# $NetBSD: options.mk,v 1.1 2008/04/14 11:35:50 wiz Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.enchant
PKG_SUPPORTED_OPTIONS= aspell enchant-zemberek hunspell ispell
# Package also supports the following:
# hspell - Hebrew spelling
# uspell - Yiddish spelling
# voikko - Finnish spelling
PKG_SUGGESTED_OPTIONS= hunspell ispell
.include "../../mk/bsd.options.mk"
PLIST_VARS+= aspell
.if !empty(PKG_OPTIONS:Maspell)
CONFIGURE_ARGS+= --enable-aspell
.include "../../textproc/aspell/buildlink3.mk"
PLIST.aspell= yes
.else
CONFIGURE_ARGS+= --disable-aspell
.endif
.if !empty(PKG_OPTIONS:Menchant-zemberek)
CONFIGURE_ARGS+= --enable-zemberek
.include "../../sysutils/dbus-glib/buildlink3.mk"
.else
CONFIGURE_ARGS+= --disable-zemberek
.endif
PLIST_VARS+= hunspell
.if !empty(PKG_OPTIONS:Mhunspell)
CONFIGURE_ARGS+= --enable-myspell
.include "../../textproc/hunspell/buildlink3.mk"
PLIST.hunspell= yes
.else
CONFIGURE_ARGS+= --disable-myspell
.endif
PLIST_VARS+= ispell
.if !empty(PKG_OPTIONS:Mispell)
CONFIGURE_ARGS+= --enable-ispell
PLIST.ispell= yes
.else
CONFIGURE_ARGS+= --disable-ispell
.endif

View file

@ -1,15 +0,0 @@
$NetBSD: patch-aa,v 1.1 2007/11/13 21:19:45 rillig Exp $
<cstdio> does not declare FILE, it only declares std::FILE.
--- src/myspell/affixmgr.hxx.orig 2006-01-12 23:51:52.000000000 +0100
+++ src/myspell/affixmgr.hxx 2007-11-13 21:44:53.000000000 +0100
@@ -2,7 +2,7 @@
#define _AFFIXMGR_HXX_
#include <cstdlib>
#include <cstring>
-#include <cstdio>
+#include <stdio.h>
#include "atypes.hxx"
#include "baseaffix.hxx"

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ab,v 1.1 2007/11/13 21:19:45 rillig Exp $
<cstdio> does not declare FILE, it only declares std::FILE.
--- src/myspell/hashmgr.hxx.orig 2006-01-06 11:04:02.000000000 +0100
+++ src/myspell/hashmgr.hxx 2007-11-13 21:45:15.000000000 +0100
@@ -1,7 +1,7 @@
#ifndef _HASHMGR_HXX_
#define _HASHMGR_HXX_
-#include <cstdio>
+#include <stdio.h>
#include "htypes.hxx"
enum flag { FLAG_CHAR, FLAG_LONG, FLAG_NUM, FLAG_UNI };