perl defined(%hash) was deprecated.

patch package so it can run with this change to perl.

bump PKGREVISION
This commit is contained in:
maya 2016-08-16 00:11:35 +00:00
parent 81b8718dfc
commit 490787aa10
3 changed files with 28 additions and 3 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.34 2016/07/09 06:39:12 wiz Exp $
# $NetBSD: Makefile,v 1.35 2016/08/16 00:11:35 maya Exp $
#
DISTNAME= htmllint
PKGNAME= htmllint-20051019
PKGREVISION= 6
PKGREVISION= 7
CATEGORIES= www japanese
MASTER_SITES= http://openlab.ring.gr.jp/k16/htmllint/archives/
EXTRACT_SUFX= .zip

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.15 2015/11/04 02:46:55 agc Exp $
$NetBSD: distinfo,v 1.16 2016/08/16 00:11:35 maya Exp $
SHA1 (htmllint-20051019/htmllint.zip) = 9906763f2b59830d3199cacd9992c67ea74a11ab
RMD160 (htmllint-20051019/htmllint.zip) = c0ab6f063435d4f0f420bad66ae48df90aef2943
@ -12,3 +12,4 @@ SHA1 (patch-ah) = 26ba26f155a05d8bd0e7bfa1d494a246e1bf2ab8
SHA1 (patch-ai) = 27068dafb150f20e30898ec546d07af54e487fce
SHA1 (patch-aj) = cb95bd5bbce00979ea29574f55e001c8df32436f
SHA1 (patch-ak) = af542b90c1992e9fbf57d1b09a0fc1c0fafbcc25
SHA1 (patch-htmllint.pm) = 13edfb6deb7a5e2f6b09c4205489bc37676d61b1

View file

@ -0,0 +1,24 @@
$NetBSD: patch-htmllint.pm,v 1.1 2016/08/16 00:11:35 maya Exp $
defined(%hash) was deprecated in perl and errors out
--- htmllint.pm.orig 2005-10-19 08:02:26.000000000 +0000
+++ htmllint.pm
@@ -4695,7 +4695,7 @@ sub WhineOmitEndTag
sub Whine
{
- unless (defined(%messages)) { # ¥Ç¥Ð¥°ÍÑ
+ unless (%messages) { # ¥Ç¥Ð¥°ÍÑ
print @_, "\n";
return;
}
@@ -5094,7 +5094,7 @@ sub ReadOptions
sub ListWarnings(;\@)
{
- &ReadWarnings unless defined(%messages);
+ &ReadWarnings unless %messages;
my $aref = shift;
my %msgshort;
foreach my $id (keys %shortid) { $msgshort{$shortid{$id}} = $id; }