Add support for LDFLAGS when building gdbsx in xentools{42,45,46,48}
This helps pass the RELRO check for these packages.
This commit is contained in:
parent
97d6a38dd2
commit
491ba5ffff
8 changed files with 68 additions and 4 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.34 2017/08/23 02:57:09 maya Exp $
|
||||
$NetBSD: distinfo,v 1.35 2017/10/28 03:14:16 khorben Exp $
|
||||
|
||||
SHA1 (ipxe-git-v1.0.0.tar.gz) = da052c8de5f3485fe0253c19cf52ed6d72528485
|
||||
RMD160 (ipxe-git-v1.0.0.tar.gz) = dcd9b6eaafa1ce05c1ebf2a15f2f73ad7a8c5547
|
||||
|
@ -47,6 +47,7 @@ SHA1 (patch-blktap_drivers_Makefile) = c6be57154a403a64e3d6bc22d6bd833fe33fc9af
|
|||
SHA1 (patch-blktap_lib_blktaplib.h) = 571e35081df24785ae67133b04d2b0ff016a0ded
|
||||
SHA1 (patch-configure) = 11df58a8e1cd6bcc319db0aff508367e59592cba
|
||||
SHA1 (patch-console_daemon_utils.c) = 362966402e4925a37b400e324e59af738b65cafc
|
||||
SHA1 (patch-debugger_gdbsx_Makefile) = 1e16761b20604bb5a9ee22174f0bb46005fb19c7
|
||||
SHA1 (patch-examples_Makefile) = ee02f973416ca4ffda5381cd7a4ddb3b43579621
|
||||
SHA1 (patch-examples_xend-config.sxp) = 1c3423b6eead47f09768d571a65891caed12aa99
|
||||
SHA1 (patch-firmware_etherboot_Makefile) = 9928566768b20d9400d8df379c09b30ba60b2575
|
||||
|
|
15
sysutils/xentools42/patches/patch-debugger_gdbsx_Makefile
Normal file
15
sysutils/xentools42/patches/patch-debugger_gdbsx_Makefile
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-debugger_gdbsx_Makefile,v 1.1 2017/10/28 03:14:16 khorben Exp $
|
||||
|
||||
Add support for LDFLAGS when building gdbsx
|
||||
|
||||
--- debugger/gdbsx/Makefile.orig 2016-09-20 05:59:24.000000000 +0000
|
||||
+++ debugger/gdbsx/Makefile
|
||||
@@ -18,7 +18,7 @@ install: all
|
||||
$(INSTALL_PROG) gdbsx $(DESTDIR)$(SBINDIR)/gdbsx
|
||||
|
||||
gdbsx: gx/gx_all.a xg/xg_all.a
|
||||
- $(CC) -o $@ $^
|
||||
+ $(CC) $(LDFLAGS) -o $@ $^
|
||||
|
||||
xg/xg_all.a:
|
||||
$(MAKE) -C xg
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.31 2017/08/23 02:49:48 maya Exp $
|
||||
$NetBSD: distinfo,v 1.32 2017/10/28 03:14:17 khorben Exp $
|
||||
|
||||
SHA1 (ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz) = fecadf952821e830ce1a1d19655288eef8488f88
|
||||
RMD160 (ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz) = 539bfa12db7054228250d6dd380bbf96c1a040f8
|
||||
|
@ -34,6 +34,7 @@ SHA1 (patch-XSA-211-2) = a92663c2c18290f5927780d3ed55aec497c58a8c
|
|||
SHA1 (patch-blktap_drivers_Makefile) = 7cc53b2a0dea1694a969046ab8542271ca63f9e7
|
||||
SHA1 (patch-configure) = 97fa4274e425984d593cd93aea36edc681462b88
|
||||
SHA1 (patch-console_daemon_utils.c) = 915078ce6155a367e3e597fa7ab551f6afac083f
|
||||
SHA1 (patch-debugger_gdbsx_Makefile) = 1e16761b20604bb5a9ee22174f0bb46005fb19c7
|
||||
SHA1 (patch-examples_Makefile) = 5fe7bb876d254cf0c4f774ed0f08dcaea5b355ff
|
||||
SHA1 (patch-firmware_etherboot_Makefile) = f55e14948b7191e533a82b8fc3575f1052f23c45
|
||||
SHA1 (patch-firmware_etherboot_patches_series) = 2fa1342c78094c6dd5d60a07c236c4a1c0599fc4
|
||||
|
|
15
sysutils/xentools45/patches/patch-debugger_gdbsx_Makefile
Normal file
15
sysutils/xentools45/patches/patch-debugger_gdbsx_Makefile
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-debugger_gdbsx_Makefile,v 1.1 2017/10/28 03:14:17 khorben Exp $
|
||||
|
||||
Add support for LDFLAGS when building gdbsx
|
||||
|
||||
--- debugger/gdbsx/Makefile.orig 2016-09-20 05:59:24.000000000 +0000
|
||||
+++ debugger/gdbsx/Makefile
|
||||
@@ -18,7 +18,7 @@ install: all
|
||||
$(INSTALL_PROG) gdbsx $(DESTDIR)$(SBINDIR)/gdbsx
|
||||
|
||||
gdbsx: gx/gx_all.a xg/xg_all.a
|
||||
- $(CC) -o $@ $^
|
||||
+ $(CC) $(LDFLAGS) -o $@ $^
|
||||
|
||||
xg/xg_all.a:
|
||||
$(MAKE) -C xg
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.9 2017/10/17 10:57:34 bouyer Exp $
|
||||
$NetBSD: distinfo,v 1.10 2017/10/28 03:14:17 khorben Exp $
|
||||
|
||||
SHA1 (ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz) = fecadf952821e830ce1a1d19655288eef8488f88
|
||||
RMD160 (ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz) = 539bfa12db7054228250d6dd380bbf96c1a040f8
|
||||
|
@ -25,6 +25,7 @@ SHA1 (patch-XSA233) = dc01c99933f7a5c67394531618cdea810fbd7c26
|
|||
SHA1 (patch-XSA240) = 26c0fc28f5f74f907e0082ec9f8bbe8ec6e22c5a
|
||||
SHA1 (patch-configure) = a58d149de07613fb03444234278778a6a24b9b26
|
||||
SHA1 (patch-console_daemon_utils.c) = 915078ce6155a367e3e597fa7ab551f6afac083f
|
||||
SHA1 (patch-debugger_gdbsx_Makefile) = 3fb99d38121a5831834cc86aa0415b2d6fe3df27
|
||||
SHA1 (patch-examples_Makefile) = 5fe7bb876d254cf0c4f774ed0f08dcaea5b355ff
|
||||
SHA1 (patch-firmware_etherboot_Makefile) = f55e14948b7191e533a82b8fc3575f1052f23c45
|
||||
SHA1 (patch-firmware_etherboot_patches_series) = 2fa1342c78094c6dd5d60a07c236c4a1c0599fc4
|
||||
|
|
15
sysutils/xentools46/patches/patch-debugger_gdbsx_Makefile
Normal file
15
sysutils/xentools46/patches/patch-debugger_gdbsx_Makefile
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-debugger_gdbsx_Makefile,v 1.1 2017/10/28 03:14:17 khorben Exp $
|
||||
|
||||
Add support for LDFLAGS when building gdbsx
|
||||
|
||||
--- debugger/gdbsx/Makefile.orig 2017-07-06 07:04:28.000000000 +0000
|
||||
+++ debugger/gdbsx/Makefile
|
||||
@@ -22,7 +22,7 @@ install: all
|
||||
$(INSTALL_PROG) gdbsx $(DESTDIR)$(sbindir)/gdbsx
|
||||
|
||||
gdbsx: gx/gx_all.a xg/xg_all.a
|
||||
- $(CC) -o $@ $^
|
||||
+ $(CC) $(LDFLAGS) -o $@ $^
|
||||
|
||||
xg/xg_all.a:
|
||||
$(MAKE) -C xg
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.4 2017/10/17 08:42:30 bouyer Exp $
|
||||
$NetBSD: distinfo,v 1.5 2017/10/28 03:14:17 khorben Exp $
|
||||
|
||||
SHA1 (xen48/gmp-4.3.2.tar.bz2) = c011e8feaf1bb89158bd55eaabd7ef8fdd101a2c
|
||||
RMD160 (xen48/gmp-4.3.2.tar.bz2) = a8f3f41501ece290c348aeb4444bbea40bc53e71
|
||||
|
@ -52,6 +52,7 @@ SHA1 (patch-Config.mk) = 7976ce94c553c2fc6badc6d41e9cb8334fea40c8
|
|||
SHA1 (patch-Makefile) = fdcd5fbb22613e55ac1b000a46b1ecbbd99eef59
|
||||
SHA1 (patch-XSA233) = e6a7230035966d7d292ef3ca477f2eb3458ae12f
|
||||
SHA1 (patch-XSA240) = 754bbe5080a81e1526b7938fed01ba435e65e50b
|
||||
SHA1 (patch-debugger_gdbsx_Makefile) = 1e16761b20604bb5a9ee22174f0bb46005fb19c7
|
||||
SHA1 (patch-docs_man_xl.cfg.pod.5.in) = e1ee6f2d48f6ce001c44c7ac688ea179b625b584
|
||||
SHA1 (patch-docs_man_xl.conf.pod.5) = d77e3313750db315d540d7713c95cd54d6f02938
|
||||
SHA1 (patch-docs_man_xl.pod.1.in) = 9b37ef724f2827bc05110e5456a8668257509cab
|
||||
|
|
15
sysutils/xentools48/patches/patch-debugger_gdbsx_Makefile
Normal file
15
sysutils/xentools48/patches/patch-debugger_gdbsx_Makefile
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-debugger_gdbsx_Makefile,v 1.1 2017/10/28 03:14:17 khorben Exp $
|
||||
|
||||
Add support for LDFLAGS when building gdbsx
|
||||
|
||||
--- debugger/gdbsx/Makefile.orig 2016-09-20 05:59:24.000000000 +0000
|
||||
+++ debugger/gdbsx/Makefile
|
||||
@@ -18,7 +18,7 @@ install: all
|
||||
$(INSTALL_PROG) gdbsx $(DESTDIR)$(SBINDIR)/gdbsx
|
||||
|
||||
gdbsx: gx/gx_all.a xg/xg_all.a
|
||||
- $(CC) -o $@ $^
|
||||
+ $(CC) $(LDFLAGS) -o $@ $^
|
||||
|
||||
xg/xg_all.a:
|
||||
$(MAKE) -C xg
|
Loading…
Reference in a new issue