The sample scripts in ${PREFIX}/share/festival/examples did not work
because their #! lines contained an incorrect path. Also, even if they had actually pointed to the installed "festival", it would still not have worked because a script cannot be used as a script interpreter. Even if it could, it still wouldn't have worked because the festival script did not pass --script as the first command line argument as festival.naked requires when running a script. Fixed by pointing the #! lines directly at the festival.naked binary.
This commit is contained in:
parent
42acb23f0e
commit
49396d619e
4 changed files with 19 additions and 3 deletions
|
@ -1,6 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.20 2002/12/02 11:34:14 markd Exp $
|
||||
# $NetBSD: Makefile,v 1.21 2002/12/10 05:21:50 gson Exp $
|
||||
|
||||
DISTNAME= festival-1.4.1
|
||||
PKGREVISION= 1
|
||||
WRKSRC= ${WRKDIR}
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ftp://ftp.cstr.ed.ac.uk/pub/festival/1.4.1/ \
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2002/02/15 10:12:29 skrll Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2002/12/10 05:21:51 gson Exp $
|
||||
bin/festival
|
||||
bin/festival_client
|
||||
libexec/audsp
|
||||
|
@ -7,6 +7,7 @@ libexec/festival_client.naked
|
|||
man/man1/festival.1
|
||||
man/man1/festival_client.1
|
||||
share/festival/examples/Makefile
|
||||
share/festival/examples/Makefile.orig
|
||||
share/festival/examples/addr-mode.scm
|
||||
share/festival/examples/benchmark
|
||||
share/festival/examples/benchmark.orig
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.4 2001/11/17 16:29:07 martin Exp $
|
||||
$NetBSD: distinfo,v 1.5 2002/12/10 05:21:51 gson Exp $
|
||||
|
||||
SHA1 (festival-1.4.1.tar.gz) = d3be7d58b986c37c39444a2dcc044cdc3ee1e774
|
||||
Size (festival-1.4.1.tar.gz) = 543335 bytes
|
||||
|
@ -21,3 +21,4 @@ SHA1 (patch-aj) = a50a9e762096faf7dc1272325a925e54d2c882a0
|
|||
SHA1 (patch-ak) = 705016ef010989c1b9ffe2d23b78ee9615a4c6f7
|
||||
SHA1 (patch-al) = d8a22c5f509a6d75aa3295037654b594e8db4a4a
|
||||
SHA1 (patch-am) = cd6e07df1729fecca5cd9869229701b63ba71d14
|
||||
SHA1 (patch-an) = bdd701017c72db315de8fcfb4ac6ce3bf97d4d47
|
||||
|
|
13
audio/festival/patches/patch-an
Normal file
13
audio/festival/patches/patch-an
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-an,v 1.1 2002/12/10 05:21:52 gson Exp $
|
||||
|
||||
--- festival/examples/Makefile.orig Thu Nov 18 11:19:50 1999
|
||||
+++ festival/examples/Makefile
|
||||
@@ -51,7 +51,7 @@
|
||||
|
||||
$(ALL) : % : %.sh
|
||||
rm -f $@
|
||||
- echo "#!"$(FESTIVAL_HOME)/bin/festival --script >$@
|
||||
+ echo "#!"$(PREFIX)/libexec/festival.naked --script >$@
|
||||
cat $< >>$@
|
||||
chmod +x $@
|
||||
|
Loading…
Reference in a new issue