Change the patch to only do this #ifdef __NetBSD__.

This commit is contained in:
bad 2001-07-08 15:23:16 +00:00
parent 7bb464e019
commit 496b5b32ed
2 changed files with 13 additions and 9 deletions

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.5 2001/07/08 13:59:16 bad Exp $
$NetBSD: distinfo,v 1.6 2001/07/08 15:23:16 bad Exp $
SHA1 (mysql-3.23.39.tar.gz) = bca088128d17f2274cff16bc0c4aaf383d5c27f1
Size (mysql-3.23.39.tar.gz) = 11211077 bytes
SHA1 (patch-aa) = 05c56d81e17893dd267fcd5f68d8c378f024a06f
SHA1 (patch-ab) = 4f10917780d73cb4a58127b27a5d8c1c9f63e0d3
SHA1 (patch-ac) = 9ac4beb4f53cc4d4fc4ec52cf30716c8269face8
SHA1 (patch-ac) = 5056bd313f73eb0b2ebf805096f58d855478a6b1
SHA1 (patch-ad) = 1aecfee152d303b3d65f3866032d2a6d49538f46
SHA1 (patch-ae) = 91e0c47e1e722cf84463af2c298a17beac56e2e9
SHA1 (patch-af) = e21b8898e24a1d576f8301b0bf9363f648d81b61

View file

@ -1,23 +1,27 @@
$NetBSD: patch-ac,v 1.3 2000/08/23 14:46:52 wiz Exp $
$NetBSD: patch-ac,v 1.4 2001/07/08 15:23:17 bad Exp $
--- mit-pthreads/stdio/strerror.c.orig Mon Aug 8 05:48:21 1994
+++ mit-pthreads/stdio/strerror.c
@@ -36,13 +36,12 @@
--- mit-pthreads/stdio/strerror.c.orig Tue Jun 12 21:07:25 2001
+++ mit-pthreads/stdio/strerror.c Sun Jul 8 16:51:52 2001
@@ -36,13 +36,18 @@
#endif /* LIBC_SCCS and not lint */
#include <string.h>
+#if defined(__NetBSD__)
+#include <errno.h>
+#endif
char *
strerror(num)
int num;
{
- extern int sys_nerr;
- extern char *sys_errlist[];
+#if !defined(__NetBSD__)
extern int sys_nerr;
extern char *sys_errlist[];
+#endif
#define UPREFIX "Unknown error: "
static char ebuf[40] = UPREFIX; /* 64-bit number + slop */
register unsigned int errnum;
@@ -51,7 +50,7 @@
@@ -51,7 +56,7 @@
errnum = num; /* convert to unsigned */
if (errnum < sys_nerr)