Added two patches for building on NetBSD-1.6.2 using gcc-2.95.3.
Approved by wiz.
This commit is contained in:
parent
70020be9dc
commit
497511111f
3 changed files with 40 additions and 1 deletions
|
@ -1,5 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.6 2005/02/24 12:13:42 agc Exp $
|
||||
$NetBSD: distinfo,v 1.7 2005/03/16 19:06:10 rillig Exp $
|
||||
|
||||
SHA1 (aMule-1.2.8.tar.bz2) = fac6f73f5068b326f45e08cded3b81af329c4226
|
||||
RMD160 (aMule-1.2.8.tar.bz2) = 2cc882013f88f35f8f925fa8423ea9e2d8b33ac1
|
||||
Size (aMule-1.2.8.tar.bz2) = 2039251 bytes
|
||||
SHA1 (patch-aa) = eba9455414a26dcd3cc81c6d7847d86e02dc9eb3
|
||||
SHA1 (patch-ab) = c38a9a4e7f927b7395ff8a40786c6eca3f248300
|
||||
|
|
16
net/amule/patches/patch-aa
Normal file
16
net/amule/patches/patch-aa
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-aa,v 1.3 2005/03/16 19:06:10 rillig Exp $
|
||||
|
||||
<net/if.h> requires <sys/socket.h>
|
||||
|
||||
--- src/SysTray.cpp.orig Tue Mar 15 19:02:17 2005
|
||||
+++ src/SysTray.cpp Tue Mar 15 19:01:55 2005
|
||||
@@ -23,6 +23,9 @@
|
||||
#include "sys.h"
|
||||
#include <libintl.h>
|
||||
#include <clocale> // Needed for setlocale(3)
|
||||
+#ifdef __NetBSD__
|
||||
+# include <sys/socket.h>
|
||||
+#endif
|
||||
#include <net/if.h> // Needed for struct ifreq
|
||||
#include <sys/socket.h> //
|
||||
#include <netinet/in.h> // Needed for inet_ntoa
|
21
net/amule/patches/patch-ab
Normal file
21
net/amule/patches/patch-ab
Normal file
|
@ -0,0 +1,21 @@
|
|||
$NetBSD: patch-ab,v 1.3 2005/03/16 19:06:10 rillig Exp $
|
||||
|
||||
The C++ standard library headers sometimes include <_G_config.h>, which
|
||||
undefines the NULL macro and includes <stddef.h> afterwards. But if the
|
||||
<stddef.h> header had been included once before, the GNU C preprocessor
|
||||
doesn't include it a second time.
|
||||
|
||||
--- src/sys.h.orig Sun Jun 13 17:37:06 2004
|
||||
+++ src/sys.h Wed Mar 16 19:40:44 2005
|
||||
@@ -23,6 +23,11 @@
|
||||
#ifndef SYS_H
|
||||
#define SYS_H
|
||||
|
||||
+/* This is needed to have a NULL macro */
|
||||
+#if defined(__NetBSD__) && defined(__GNUC__) && ((__GNUC__) < 3)
|
||||
+# include <stl_config.h>
|
||||
+#endif
|
||||
+
|
||||
//
|
||||
// The build system forgets to add the correct CXXFLAGS (like for
|
||||
// example -pthread for g++). Therefore define this here instead.
|
Loading…
Reference in a new issue