Update to 3.03

Upstream changes:
3.03 2022-02-24
    - Tests: Generate unicode file names on the fly (GH#30).

3.02 2022-02-23
    - Fix copy-paste error in MultiPointM handling (GH#28).
    - CI changes (GH#27, GH#29)
    - Thanks to @voegelas for all three PRs.
This commit is contained in:
wen 2023-06-30 09:39:26 +00:00
parent a2d297a088
commit 49771f877a
3 changed files with 6 additions and 26 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.22 2022/06/28 11:33:58 wiz Exp $
# $NetBSD: Makefile,v 1.23 2023/06/30 09:39:26 wen Exp $
DISTNAME= Geo-ShapeFile-3.01
DISTNAME= Geo-ShapeFile-3.03
PKGNAME= p5-${DISTNAME}
PKGREVISION= 2
CATEGORIES= geography perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Geo/}

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.10 2021/10/26 10:45:14 nia Exp $
$NetBSD: distinfo,v 1.11 2023/06/30 09:39:26 wen Exp $
BLAKE2s (Geo-ShapeFile-3.01.tar.gz) = 5166219b16d71300e81f87d5eb078a530e80f8a6c3e982f2600de6a720f05135
SHA512 (Geo-ShapeFile-3.01.tar.gz) = 5e1799cb211beddead3f194af68ba15b00e0cc688ee7ed04a4de35e2084fe3a1b1d832aa765ee02919a157f2f89f7c73e248f1360594d70946bd578d697fe93c
Size (Geo-ShapeFile-3.01.tar.gz) = 358669 bytes
BLAKE2s (Geo-ShapeFile-3.03.tar.gz) = f05379b2077033f3670556833ade136f5a7de108df39a2cd11d99d915db96bc4
SHA512 (Geo-ShapeFile-3.03.tar.gz) = a55e0819014904fe44ebc823a60e1dfc877013b15d18f84e412e66707ab0a09c2e20665bfb55a09c65dbeea86d1d6d55037f4a42b140cb4ac77a6536b5be7dee
Size (Geo-ShapeFile-3.03.tar.gz) = 351571 bytes
SHA1 (patch-t_main__tests.t) = eab0bb1ff1eb506a0f2d93aa2a5fb36dacfe891f

View file

@ -1,19 +0,0 @@
$NetBSD: patch-t_main__tests.t,v 1.2 2020/09/07 11:20:47 wiz Exp $
Add patch to be able to run tests without the need to install rlib,
which is not in ports and which can easily be replaced by the FindBin
The patch come from FreeBSD ports.
--- t/main_tests.t.orig 2016-07-25 08:39:51.000000000 +0000
+++ t/main_tests.t
@@ -3,7 +3,9 @@
use Test::More;
use strict;
use warnings;
-use rlib '../lib', './lib';
+use FindBin;
+use lib "$FindBin::Bin/lib";
+use lib "$FindBin::Bin/../lib";
use Geo::ShapeFile;
use Geo::ShapeFile::Shape;