Fix missing return value. Add a missing include.

This commit is contained in:
joerg 2012-11-01 19:43:42 +00:00
parent 593cedec04
commit 498af038c4
3 changed files with 28 additions and 1 deletions

View file

@ -1,5 +1,7 @@
$NetBSD: distinfo,v 1.5 2010/12/07 13:14:57 mef Exp $
$NetBSD: distinfo,v 1.6 2012/11/01 19:43:42 joerg Exp $
SHA1 (cwtext-0.96.tar.gz) = 5e6d7d57b5329de80fce84eb65d47c0b776f2d4f
RMD160 (cwtext-0.96.tar.gz) = 1d47de9a6441846484e993708b9c0fdd9042e8ba
Size (cwtext-0.96.tar.gz) = 16596 bytes
SHA1 (patch-morse.c) = 19f95a2d66d54708cd13d19468964cfac282b47a
SHA1 (patch-pcm.c) = 305d818ee9557a626673b2023b758bd19150ce44

View file

@ -0,0 +1,12 @@
$NetBSD: patch-morse.c,v 1.1 2012/11/01 19:43:42 joerg Exp $
--- morse.c.orig 2012-10-30 22:47:24.000000000 +0000
+++ morse.c
@@ -17,6 +17,7 @@ Foundation, Inc., 59 Temple Place - Suit
*/
+#include <ctype.h>
#include <stdio.h>
#include "cw.h"

View file

@ -0,0 +1,13 @@
$NetBSD: patch-pcm.c,v 1.1 2012/11/01 19:43:42 joerg Exp $
--- pcm.c.orig 2012-10-30 22:47:38.000000000 +0000
+++ pcm.c
@@ -60,7 +60,7 @@ int mStoSamples(int hVox, int time) {
float samples;
float fsr;
- if (!valid(hVox)) return;
+ if (!valid(hVox)) return -1;
timelen = (float) time;
fsr = (float) voxref(hVox).samplerate;