Fix getline breakage on current by renaming getline to get_line.
This commit is contained in:
parent
6845aa7a8b
commit
498af3f052
5 changed files with 114 additions and 1 deletions
|
@ -1,9 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.6 2008/03/08 16:28:23 tnn Exp $
|
||||
$NetBSD: distinfo,v 1.7 2009/08/15 17:15:32 wiz Exp $
|
||||
|
||||
SHA1 (noweb-2.11b.tgz) = 3b391c42f46dcb8a002b863fb2e483560a7da51d
|
||||
RMD160 (noweb-2.11b.tgz) = 01e4fbb636dfd0f6d117caa045cf105e49d25fca
|
||||
Size (noweb-2.11b.tgz) = 738870 bytes
|
||||
SHA1 (patch-aa) = a548bc947bc3846e623565e9d875205ed1b772fd
|
||||
SHA1 (patch-ab) = 8b07b126d9b49c410ad7338ebef1991f631dde29
|
||||
SHA1 (patch-ac) = b953b18dfcb70f959b3fef4fff365e793c298563
|
||||
SHA1 (patch-ad) = 3dbadb8b512da3aee92330f15f1d66d8dc757b53
|
||||
SHA1 (patch-ae) = 007f1943f60d1f5b3207bc6bd537b86e71c56a77
|
||||
|
@ -16,3 +17,6 @@ SHA1 (patch-ak) = 845d4eb472a803e8ad66dce524a8e10084b62b96
|
|||
SHA1 (patch-al) = 42e3d05a052b9b00f3da9a9e157035ccd670a73c
|
||||
SHA1 (patch-am) = 9ec2e25fe28be98908d3cf3e4b42fff937730f1d
|
||||
SHA1 (patch-an) = 3b3a5167920d49ca7b3432250357010eb781b880
|
||||
SHA1 (patch-ao) = b4a996f4c4c0fdc2168320e4f2c313ca35a19a18
|
||||
SHA1 (patch-ap) = efb4f16eba1ca49603e64ca2035c57cfb1fa93b5
|
||||
SHA1 (patch-aq) = 4186f2a159fbce550e65486387f96711cc2c5a07
|
||||
|
|
12
devel/noweb/patches/patch-ab
Normal file
12
devel/noweb/patches/patch-ab
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-ab,v 1.3 2009/08/15 17:15:32 wiz Exp $
|
||||
|
||||
--- src/c/getline.h.orig 2006-06-12 21:16:23.000000000 +0000
|
||||
+++ src/c/getline.h
|
||||
@@ -1,6 +1,6 @@
|
||||
char *getline_expand (FILE *fp);
|
||||
/* grab a line in buffer, return new buffer or NULL for eof
|
||||
tabs in line are expanded according to tabsize */
|
||||
-char *getline (FILE *fp);
|
||||
+char *get_line (FILE *fp);
|
||||
/* grab a line in the buffer, return a new buffer or NULL for eof
|
||||
no expansion of tabs */
|
22
devel/noweb/patches/patch-ao
Normal file
22
devel/noweb/patches/patch-ao
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ao,v 1.1 2009/08/15 17:15:32 wiz Exp $
|
||||
|
||||
--- src/c/getline.c.orig 2006-06-12 21:16:23.000000000 +0000
|
||||
+++ src/c/getline.c
|
||||
@@ -19,7 +19,7 @@ void new_buffers(void) {
|
||||
checkptr(buf2 = (char *) realloc(buf2, buf_size));
|
||||
}
|
||||
#line 47 "getline.nw"
|
||||
-char *getline (FILE *fp) {
|
||||
+char *get_line (FILE *fp) {
|
||||
|
||||
|
||||
#line 82 "getline.nw"
|
||||
@@ -44,7 +44,7 @@ char *getline_expand (FILE *fp) {
|
||||
char *s, *t;
|
||||
int width;
|
||||
|
||||
- if (getline(fp)==NULL) return NULL;
|
||||
+ if (get_line(fp)==NULL) return NULL;
|
||||
|
||||
#line 87 "getline.nw"
|
||||
if (columnwidth(buf1) > buf_size - 1) {
|
44
devel/noweb/patches/patch-ap
Normal file
44
devel/noweb/patches/patch-ap
Normal file
|
@ -0,0 +1,44 @@
|
|||
$NetBSD: patch-ap,v 1.1 2009/08/15 17:15:32 wiz Exp $
|
||||
|
||||
--- src/c/notangle.c.orig 2006-06-12 21:16:23.000000000 +0000
|
||||
+++ src/c/notangle.c
|
||||
@@ -44,7 +44,7 @@ void read_defs(FILE *in) {
|
||||
char *line = NULL; /* buffer for input */
|
||||
Location loc;
|
||||
|
||||
- while ((line = getline(in)) != NULL) {
|
||||
+ while ((line = get_line(in)) != NULL) {
|
||||
if (is_keyword(line, "fatal")) exit(1);
|
||||
|
||||
#line 101 "notangle.nw"
|
||||
@@ -90,7 +90,7 @@ if (!is_begin(line, "code"))
|
||||
#line 66 "notangle.nw"
|
||||
|
||||
#line 97 "notangle.nw"
|
||||
-do { line = getline(in);
|
||||
+do { line = get_line(in);
|
||||
} while (line != NULL && !is_keyword(line,"defn") && !is_keyword(line,"text"));
|
||||
#line 67 "notangle.nw"
|
||||
insist(line,"defn","code chunk had no definition line");
|
||||
@@ -102,10 +102,10 @@ modname[strlen(modname)-1]='\0';
|
||||
warn_dots(modname); /* names ending in ... aren't like web */
|
||||
modptr = insert(modname); /* find or add module in table */
|
||||
|
||||
- line = getline(in);
|
||||
+ line = get_line(in);
|
||||
insist(line,"nl","definition line not followed by newline");
|
||||
loc.lineno++;
|
||||
- line = getline(in);
|
||||
+ line = get_line(in);
|
||||
while (line != NULL && !is_end(line,"code")) {
|
||||
if (is_keyword(line,"nl")) {
|
||||
addnewline(modptr);
|
||||
@@ -157,7 +157,7 @@ modname[strlen(modname)-1]='\0';
|
||||
#line 182 "notangle.nw"
|
||||
errorat(loc.filename, loc.lineno, Error, "botched code chunk `%s'", line);
|
||||
#line 90 "notangle.nw"
|
||||
- line = getline(in);
|
||||
+ line = get_line(in);
|
||||
}
|
||||
|
||||
#line 176 "notangle.nw"
|
31
devel/noweb/patches/patch-aq
Normal file
31
devel/noweb/patches/patch-aq
Normal file
|
@ -0,0 +1,31 @@
|
|||
$NetBSD: patch-aq,v 1.1 2009/08/15 17:15:32 wiz Exp $
|
||||
|
||||
--- src/c/finduses.c.orig 2006-06-12 21:16:23.000000000 +0000
|
||||
+++ src/c/finduses.c
|
||||
@@ -49,7 +49,7 @@ main(int argc, char **argv) {
|
||||
#line 155 "finduses.nw"
|
||||
errormsg(Fatal, "%s: couldn't open temporary file\n", progname);
|
||||
#line 78 "finduses.nw"
|
||||
- while ((line = getline(stdin)) != NULL) {
|
||||
+ while ((line = get_line(stdin)) != NULL) {
|
||||
if (fputs(line, tmp) == EOF)
|
||||
#line 157 "finduses.nw"
|
||||
errormsg(Fatal, "%s: error writing temporary file\n", progname);
|
||||
@@ -89,7 +89,7 @@ for (; i < argc; i++)
|
||||
#line 66 "finduses.nw"
|
||||
static void read_ids(FILE *in) {
|
||||
char *line;
|
||||
- while ((line = getline(in)) != NULL) {
|
||||
+ while ((line = get_line(in)) != NULL) {
|
||||
if (line[strlen(line)-1] == '\n') line[strlen(line)-1] = 0;
|
||||
add_ident(nwindex, line);
|
||||
}
|
||||
@@ -100,7 +100,7 @@ static void add_use_markers(FILE *in, FI
|
||||
int incode = 0;
|
||||
LineOut info; info.line = (char *)0; info.out = out;
|
||||
|
||||
- while ((line = getline(in)) != NULL) {
|
||||
+ while ((line = get_line(in)) != NULL) {
|
||||
if (is_begin(line, "code") || showquotes && is_keyword(line, "quote"))
|
||||
incode = 1;
|
||||
else if (is_end(line, "code") || is_keyword(line, "endquote"))
|
Loading…
Reference in a new issue