Update converters/py-zfec to 1.4.22.
pkgsrc changes: - /usr/bin/env police - zfec and zunfec scripts require py-argparse and py-setuptools_trial dependencies. upstream changes: Unknown. Upstream NEWS file stopped at 1.4.5.
This commit is contained in:
parent
63468dfa8f
commit
49bf50c360
4 changed files with 29 additions and 21 deletions
|
@ -1,21 +1,27 @@
|
|||
# $NetBSD: Makefile,v 1.6 2011/01/23 22:19:09 tnn Exp $
|
||||
# $NetBSD: Makefile,v 1.7 2012/02/12 19:55:09 gls Exp $
|
||||
#
|
||||
|
||||
DISTNAME= zfec-1.4.7
|
||||
PKGREVISION= 1
|
||||
DISTNAME= zfec-1.4.22
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
CATEGORIES= converters
|
||||
MASTER_SITES= http://pypi.python.org/packages/source/z/zfec/
|
||||
|
||||
MAINTAINER= gdt@ir.bbn.com
|
||||
HOMEPAGE= http://pypi.python.org/packages/source/z/zfec/
|
||||
HOMEPAGE= http://pypi.python.org/pypi/zfec/
|
||||
COMMENT= Fast erasure codec
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
DEPENDS+= ${PYPKGPREFIX}-argparse-[0-9]*:../../devel/py-argparse
|
||||
DEPENDS+= ${PYPKGPREFIX}-darcsver-[0-9]*:../../devel/py-darcsver
|
||||
DEPENDS+= ${PYPKGPREFIX}-setuptools_trial-[0-9]*:../../devel/py-setuptools_trial
|
||||
DEPENDS+= ${PYPKGPREFIX}-expat-[0-9]*:../../textproc/py-expat
|
||||
|
||||
REPLACE_INTERPRETER+= python
|
||||
REPLACE.python.old= /usr/bin/env python
|
||||
REPLACE.python.new= ${PYTHONBIN}
|
||||
REPLACE_FILES.python= zfec/cmdline_zfec.py zfec/cmdline_zunfec.py zfec/test/test_zfec.py
|
||||
|
||||
.include "../../lang/python/egg.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2010/07/24 13:24:15 gdt Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2012/02/12 19:55:09 gls Exp $
|
||||
bin/zfec
|
||||
bin/zunfec
|
||||
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
|
||||
|
@ -39,6 +39,6 @@ ${PYSITELIB}/zfec/test/test_zfec.pyc
|
|||
${PYSITELIB}/zfec/test/test_zfec.pyo
|
||||
share/doc/zfec/COPYING.GPL
|
||||
share/doc/zfec/COPYING.TGPPL.html
|
||||
share/doc/zfec/README.txt
|
||||
share/doc/zfec/README.rst
|
||||
share/doc/zfec/TODO
|
||||
share/doc/zfec/changelog
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.2 2010/11/27 13:35:06 gdt Exp $
|
||||
$NetBSD: distinfo,v 1.3 2012/02/12 19:55:09 gls Exp $
|
||||
|
||||
SHA1 (zfec-1.4.7.tar.gz) = 7614e82757ad880cb8d0df44444822c5123af04b
|
||||
RMD160 (zfec-1.4.7.tar.gz) = 12dca2c4b50a79337fbef523eba681252006777a
|
||||
Size (zfec-1.4.7.tar.gz) = 155662 bytes
|
||||
SHA1 (patch-aa) = bd03f5a6ec9d83585b5adc24afe0981bd0407b9f
|
||||
SHA1 (zfec-1.4.22.tar.gz) = 5f6548a68d0c4b8a5dcfb190120d338d55179a81
|
||||
RMD160 (zfec-1.4.22.tar.gz) = 296a328db013c6e373ade1f34377502b1fed8c9c
|
||||
Size (zfec-1.4.22.tar.gz) = 162680 bytes
|
||||
SHA1 (patch-aa) = 0df981871a8fb22656a53a1934c1153d1a65c442
|
||||
|
|
|
@ -1,15 +1,17 @@
|
|||
$NetBSD: patch-aa,v 1.1 2010/11/27 13:35:07 gdt Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2012/02/12 19:55:09 gls Exp $
|
||||
|
||||
http://tahoe-lafs.org/trac/zfec/ticket/11
|
||||
|
||||
--- setup.py.orig 2010-05-24 06:20:43.000000000 +0000
|
||||
--- setup.py.orig 2011-03-03 12:07:50.000000000 +0000
|
||||
+++ setup.py
|
||||
@@ -115,7 +115,7 @@ setup_requires.append('darcsver >= 1.2.0
|
||||
# "sdist" or "bdist_egg"), unless there is a zfec.egg-info/SOURCE.txt file
|
||||
# present which contains a complete list of files that should be included.
|
||||
# http://pypi.python.org/pypi/setuptools_darcs
|
||||
-setup_requires.append('setuptools_darcs >= 1.1.0')
|
||||
+# setup_requires.append('setuptools_darcs >= 1.1.0')
|
||||
@@ -116,8 +116,8 @@ if 'darcsver' in sys.argv[1:]:
|
||||
# shipped in Ubuntu Lucid, so for now you have to manually install it
|
||||
# before building sdists or eggs:
|
||||
# http://bitbucket.org/tarek/distribute/issue/55/revision-control-plugin-automatically-installed-as-a-build-dependency-is-not-present-when-another-build-dependency-is-being
|
||||
-if False:
|
||||
- setup_requires.append('setuptools_darcs >= 1.1.0')
|
||||
+#if False:
|
||||
+# setup_requires.append('setuptools_darcs >= 1.1.0')
|
||||
|
||||
# stdeb is required to build Debian dsc files.
|
||||
if "sdist_dsc" in sys.argv:
|
||||
|
||||
# setuptools_trial is needed if you want "./setup.py trial" or
|
||||
|
|
Loading…
Reference in a new issue