fixes dbus-sharp dllmap for cross-architecture support,

taken from upstream.

Bump PKGREVISION.
This commit is contained in:
obache 2013-06-11 02:29:40 +00:00
parent 538ec41f58
commit 49da0b600a
4 changed files with 43 additions and 2 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.1 2013/06/10 11:59:38 obache Exp $
# $NetBSD: Makefile,v 1.2 2013/06/11 02:29:40 obache Exp $
#
DISTNAME= dbus-sharp-0.7.0
PKGREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://cloud.github.com/downloads/mono/dbus-sharp/

View file

@ -1,5 +1,7 @@
$NetBSD: distinfo,v 1.1 2013/06/10 11:59:38 obache Exp $
$NetBSD: distinfo,v 1.2 2013/06/11 02:29:40 obache Exp $
SHA1 (dbus-sharp-0.7.0.tar.gz) = 7e7b05aadb6a289cd862dc630a36d9b87b5b84cb
RMD160 (dbus-sharp-0.7.0.tar.gz) = 6f24068ea649d86282cabf11b633074165c2ed9f
Size (dbus-sharp-0.7.0.tar.gz) = 127651 bytes
SHA1 (patch-src_Unix.cs) = e7b6bf7f684066d12ad46cc9b1e9c59d7cec7548
SHA1 (patch-src_dbus-sharp.dll.config) = f8d14833fd8d2d37ce822b724279c4b396387b9e

View file

@ -0,0 +1,16 @@
$NetBSD: patch-src_Unix.cs,v 1.1 2013/06/11 02:29:40 obache Exp $
* Reverse the way the dllmap for libsocket is handled, by using libc
https://github.com/mono/dbus-sharp/commit/1561585d601058392d5864e3add2bac3c67e14a7
--- src/Unix.cs.orig 2010-09-14 09:17:50.000000000 +0000
+++ src/Unix.cs
@@ -197,7 +197,7 @@ namespace DBus.Unix
// Solaris provides socket functionality in libsocket rather than libc.
// We use a dllmap in the .config to deal with this.
- internal const string LIBSOCKET = "libsocket";
+ internal const string LIBSOCKET = "libc";
public const short AF_UNIX = 1;
// FIXME: SOCK_STREAM is 2 on Solaris

View file

@ -0,0 +1,22 @@
$NetBSD: patch-src_dbus-sharp.dll.config,v 1.1 2013/06/11 02:29:40 obache Exp $
* Reverse the way the dllmap for libsocket is handled, by using libc
https://github.com/mono/dbus-sharp/commit/1561585d601058392d5864e3add2bac3c67e14a7
--- src/dbus-sharp.dll.config.orig 2010-09-14 09:17:50.000000000 +0000
+++ src/dbus-sharp.dll.config
@@ -1,3 +1,13 @@
<configuration>
- <dllmap dll="libsocket" os="!solaris" target="libc.so.6"/>
+ <dllmap dll="libc">
+ <dllentry os="solaris" dll="libsocket.so.1" name="socket" target="socket"/>
+ <dllentry os="solaris" dll="libsocket.so.1" name="connect" target="connect"/>
+ <dllentry os="solaris" dll="libsocket.so.1" name="bind" target="bind"/>
+ <dllentry os="solaris" dll="libsocket.so.1" name="listen" target="listen"/>
+ <dllentry os="solaris" dll="libsocket.so.1" name="accept" target="accept"/>
+ <dllentry os="solaris" dll="libsocket.so.1" name="getsockopt" target="getsockopt"/>
+ <dllentry os="solaris" dll="libsocket.so.1" name="setsockopt" target="setsockopt"/>
+ <dllentry os="solaris" dll="libsocket.so.1" name="resvmsg" target="resvmsg"/>
+ <dllentry os="solaris" dll="libsocket.so.1" name="sendmsg" target="sendmsg"/>
+ </dllmap>
</configuration>