py-peewee: updated to 3.14.0
3.14.0 This release has been a bit overdue and there are numerous small improvements and bug-fixes. The bugfix that prompted this release is 2293, which is a regression in the Django-inspired .filter() APIs that could cause some filter expressions to be discarded from the generated SQL. Many thanks for the excellent bug report, Jakub. Add an experimental helper, shortcuts.resolve_multimodel_query(), for resolving multiple models used in a compound select query. Add a lateral() method to select query for use with lateral joins. Added support for nested transactions (savepoints) in cockroach-db (requires 20.1 or newer). Automatically escape wildcards passed to string-matching methods. Allow index-type to be specified on MySQL. Added a new API, converter() to be used for specifying a function to use to convert a row-value pulled off the cursor. Add set() and clear() method to the bitfield flag descriptor. Add support for range types with IN and other expressions. Support CTEs bound to compound select queries. Bug-fixes Fix to return related object id when accessing via the object-id descriptor, when the related object is not populated. Fix to ensure we do not insert a NULL value for a primary key. Fix to conditionally set the field/column on an added column in a migration. Apply field conversion logic to model-class values. Clone node before modifying it to be flat in an enclosed nodelist expr. Fix an invalid item assignment in nodelist. Fix an incorrect truthiness check used with save() and only=. Fix regression in filter() where using both *args and **kwargs caused the expressions passed as args to be discarded.
This commit is contained in:
parent
e1c91fe0c5
commit
49e85f5f7e
3 changed files with 10 additions and 11 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.69 2020/11/05 09:07:48 ryoon Exp $
|
||||
# $NetBSD: Makefile,v 1.70 2020/11/09 09:29:12 adam Exp $
|
||||
|
||||
DISTNAME= peewee-3.13.3
|
||||
DISTNAME= peewee-3.14.0
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= databases python
|
||||
MASTER_SITES= ${MASTER_SITE_PYPI:=p/peewee/}
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.57 2020/04/24 08:26:56 adam Exp $
|
||||
$NetBSD: distinfo,v 1.58 2020/11/09 09:29:12 adam Exp $
|
||||
|
||||
SHA1 (peewee-3.13.3.tar.gz) = acac756c95e312c30324df1434e3af5e3bbf64ba
|
||||
RMD160 (peewee-3.13.3.tar.gz) = 46f892773a5dcbad7390aabbe2bc64306c6edb45
|
||||
SHA512 (peewee-3.13.3.tar.gz) = 829bea39366d0ebeef19a8c169ac7ad724496770411549baddff33a82f2962c026a34bfce2ed7b6eb08527311504516467c49918a91de5fd670dd871b5ec4447
|
||||
Size (peewee-3.13.3.tar.gz) = 2293231 bytes
|
||||
SHA1 (patch-setup.py) = 2d4d9fde18df606b584dffe04aa9da22de3e4dcc
|
||||
SHA1 (peewee-3.14.0.tar.gz) = 4f217da044dd93fa1376b8df37bccb887765c38b
|
||||
RMD160 (peewee-3.14.0.tar.gz) = 2fbf3534cc6c343383a74962a76d4e697fcb657c
|
||||
SHA512 (peewee-3.14.0.tar.gz) = 864fe44f3e1e99a43bbb512113e7eb8136ce69abb7be0d844c2be5466873a9da0ef02b6ffca52caabae2718e5e714687e9504d64b99871fd2b530fa53b45aae5
|
||||
Size (peewee-3.14.0.tar.gz) = 873120 bytes
|
||||
SHA1 (patch-setup.py) = 59788f77a576274de46a2c090a9a0a6ede0e1166
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-setup.py,v 1.2 2019/01/08 08:37:59 adam Exp $
|
||||
$NetBSD: patch-setup.py,v 1.3 2020/11/09 09:29:12 adam Exp $
|
||||
|
||||
Find libsqlite3.
|
||||
|
||||
|
@ -7,7 +7,7 @@ Find libsqlite3.
|
|||
@@ -73,8 +73,9 @@ def _have_sqlite_extension_support():
|
||||
success = False
|
||||
try:
|
||||
compiler.link_executable(
|
||||
compiler.link_shared_object(
|
||||
- compiler.compile([src_file], output_dir=tmp_dir),
|
||||
+ compiler.compile([src_file], output_dir=tmp_dir, include_dirs=['@BUILDLINK_PREFIX.sqlite3@/include']),
|
||||
bin_file,
|
||||
|
|
Loading…
Reference in a new issue