Upgrade to ExaBGP version 3.4.19.
Pkgsrc changes: * Adapt PLIST * Adapt Makefile to new python scripts Upstream changes: 3.4.19 ExaBGP 'LINX 97/43' release ====== * Add: IPv6 nlri-mpls to list of enabled protocol (was missing) requested by: adrian62 * Fix: encoding of Flow Label requiring more than 2 bytes reported by: BLAKEMMM * Fix: decoding of capability (was potentially over reading) * Fix: trace when trying to access PID file and this is not allowed reported by: George Shuklin * Fix: Remove a peer's RIB cache when it is deleted from the config file patch by: Brian Johnson * Fix: do not crash the reactor when an invalid IP is passed via the API reported by: Yevgeniy Ovsyannikov * Fix: bad defintion of Flow for ICMPType, ICMPCode and Fragment reported by: Christoph Loibl * Feature: allow add-path for mpls-vpn reported by: adrian62 * Change: Backported setup.py from master * Feature: added SRPMS for exabgp patch by: Leonardo Amaral 3.4.18 ExaBGP 'No BETT' release ====== * Backport: backhole community (RFC 7999) original patch by: Job Snijders * Fix: Configuration parser does not accept configs without neighbors. patch by doddt * Fix: 'connect' keyword is now also allowed in neighbor scope patch by: Stacey Sheldon (Corsa) * Fix: removing protocol auto-cleanup (it should never be called and seems to cause a CG issue) reported by: Colin Petrie * Change: default to a 0 offset for ipv6 flowspec source/destination match patch by: Brian Johnson * Fix: Better PID file handling reported by: Ben Agricola * Fix: Update RIB cache families on configuration reload patch by: Brian Johnson * Fix: Backport fix on SIGUSR2 (restarting process not needing to be) patch by: Shawn Zhou * Change: group-updates now generates one UPDATE per address family (and not one per NLRI for non IPv4) patch by: Brian Johnson 3.4.17 ExaBGP 'No EPF' release ====== * Fix: does not accept IPv6 as router-id reported by: yuriya * Fix: JSON output for flow routes with rd reported by droon5 * Fix: Fix Path-Information * Fix: Bad encoding of capability when multiple families are used for add-path reported: by Alexander Bespalov * Fix: support non ASN4 use of AS_TRANS (AS23456) reported by: Todd Crane * Fix: do not exit when we can not accept incoming connection reported by: Pavel Batkov * Fix: quote where not escaped in JSON reason field reported by: Rob Barnes * Fix: decoding of IPv6 flow routes reported by: stoffi92 * Fix: decoding of Graceful Restart Capability patch by: florinz * Fix: ASN4 encoding patch by: Shu Sugimoto and Eiichiro Watanabe * Change: Run without even peers configured patch by: Jordan Gedney * Fix: JSON encoding of updates without NLRIs patch by: Dhammika Pathirana * Fix: Possible race conditions in api handling patch by: Brian Johnson * Feature: Add 'show neighbor status' api patch by: Brian Johnson * Fix: flush route api patch by: Brian Johnson * Fix: Allow asn4 peer to speak with asn2 only peer patch by: Brian Johnson * Fix: only one MP NLRI is allow per UPDATE reported by: subsecond * Change: configuration output does not includes ':' anymore patch by: doddt * Change: syslog format changed to be in line with other application patch by: Brian Johnson 3.4.16 ExaBGP 'Free YouTube' release ====== A bug fix only release * Feature: allow users to decide if processes must be run before or after we drop privileges requested by: Ben Agricola * Fix: correctly look in /etc/exabgp for programs to run when the path is relative reported by: Vincent Bernat * Fix: missing handler for NOTIFICATION patch by: minglvyy 3.4.15 ExaBGP 'skip' release ====== Do not look for 3.4.14 - it was never released. An issue with pypi forced us to skip this version. * Fix: the ttl-security parameter didn't really work. Fixed for outgoing connections now. patch by: Borja Marcos * Fix: configuration leak between processes for neighbor-changes and send-packets. reported by: spakka * Feature: add per neighbor connection port. requested by: dbarrosop * Fix: ASN4 boundary off by one * Fix: Bad peer IP when using show routes. patch by (backported): Wayne Tucker * Fix: Missing next-hop in the text api. reported by: Lisa Roach * Fix: broken route-refresh command. reported by: Bryan Schwerer * Fix: wrongly announcing connection issue with peer on the API. reported by: Bryan Schwerer 3.4.13 ExaBGP 'Madrid' release ====== * Fix: add semicolon in syslog entry so it can be parsed by tools * Fix: duplication of message following helper process death reported by: spakka * Fix: death of helper program would lead to BGP session drop reported by: spakka * Fix: mistakenly made a function private breaking some ASN4 code path reported by: Victor Sudakov * Feature: manual eor patch by: Charles Ng 3.4.12 ExaBGP 'John Glenn' release ====== * Fix: issue with unknown capabilities reported by: Sandy Breeze * Fix: notification messages were not passed to the API reported by: Florian Obser * Fix: transitivity on extended community patch by: Thomas Morin * Fix: bad reporting of VPLS information in JSON * Fix: wrong SAFI on MPLS routes reported by: Hideaki HAYASHI * Fix: bad route comparaison reported by: Alvaro Pereira * Fix: decoding of Update * Fix: Flow redirect to nexhop encoding reported by: Mickael Marchand (Thank you to Peng Xiao and Nicolas Fevrier for their help) * Fix/Improve: JSON for flow spec * Fix/Improve: redirect-to-nexthop reported by: Mickael Marchand
This commit is contained in:
parent
bfb7120cde
commit
4a079e09e5
4 changed files with 111 additions and 49 deletions
|
@ -1,15 +1,14 @@
|
|||
# $NetBSD: Makefile,v 1.19 2017/01/01 14:43:49 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.20 2017/06/20 14:10:16 he Exp $
|
||||
|
||||
VERSION= 3.4.11
|
||||
VERSION= 3.4.19
|
||||
DISTNAME= ${VERSION}
|
||||
PKGNAME= exabgp-${VERSION}
|
||||
PKGREVISION= 2
|
||||
EGG_NAME= exabgp-${VERSION}
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=Exa-Networks/exabgp/archive/}
|
||||
DIST_SUBDIR= exabgp
|
||||
|
||||
MAINTAINER= pettai@NetBSD.org
|
||||
MAINTAINER= he@NetBSD.org
|
||||
HOMEPAGE= https://github.com/Exa-Networks/exabgp/
|
||||
COMMENT= ExaBGP is a userspace BGP daemon written in python
|
||||
LICENSE= modified-bsd
|
||||
|
@ -35,6 +34,27 @@ REPLACE_PYTHON+= lib/exabgp/application/netlink.py
|
|||
REPLACE_PYTHON+= lib/exabgp/netlink/old.py
|
||||
REPLACE_PYTHON+= lib/exabgp/netlink/route.py
|
||||
REPLACE_PYTHON+= lib/exabgp/reactor/api/encoding.py
|
||||
REPLACE_PYTHON+= qa/conf/api-add-remove.run
|
||||
REPLACE_PYTHON+= qa/conf/api-announcement.run
|
||||
REPLACE_PYTHON+= qa/conf/api-api.nothing.run
|
||||
REPLACE_PYTHON+= qa/conf/api-api.receive.run
|
||||
REPLACE_PYTHON+= qa/conf/api-broken-flow.run
|
||||
REPLACE_PYTHON+= qa/conf/api-check.run
|
||||
REPLACE_PYTHON+= qa/conf/api-eor.run
|
||||
REPLACE_PYTHON+= qa/conf/api-fast.run
|
||||
REPLACE_PYTHON+= qa/conf/api-flow.run
|
||||
REPLACE_PYTHON+= qa/conf/api-multi-neighbor.run
|
||||
REPLACE_PYTHON+= qa/conf/api-multisession.run
|
||||
REPLACE_PYTHON+= qa/conf/api-nexthop-self.run
|
||||
REPLACE_PYTHON+= qa/conf/api-nexthop.run
|
||||
REPLACE_PYTHON+= qa/conf/api-notification.run
|
||||
REPLACE_PYTHON+= qa/conf/api-open.run
|
||||
REPLACE_PYTHON+= qa/conf/api-reload.run
|
||||
REPLACE_PYTHON+= qa/conf/api-teardown.run
|
||||
REPLACE_PYTHON+= qa/conf/api-vpls.run
|
||||
REPLACE_PYTHON+= qa/conf/api-vpnv4.run
|
||||
REPLACE_PYTHON+= qa/conf/manual-eor.run
|
||||
REPLACE_PYTHON+= qa/conf/watchdog.run
|
||||
|
||||
PYTHON_VERSIONS_INCOMPATIBLE= 34 35 36 # not yet ported as of 3.2.19
|
||||
|
||||
|
|
|
@ -1,4 +1,5 @@
|
|||
@comment $NetBSD: PLIST,v 1.8 2015/05/27 12:26:26 he Exp $
|
||||
@comment $NetBSD: PLIST,v 1.9 2017/06/20 14:10:16 he Exp $
|
||||
bin/exabgp
|
||||
${PYSITELIB}/${EGG_FILE}/PKG-INFO
|
||||
${PYSITELIB}/${EGG_FILE}/SOURCES.txt
|
||||
${PYSITELIB}/${EGG_FILE}/dependency_links.txt
|
||||
|
@ -7,6 +8,9 @@ ${PYSITELIB}/${EGG_FILE}/top_level.txt
|
|||
${PYSITELIB}/exabgp/__init__.py
|
||||
${PYSITELIB}/exabgp/__init__.pyc
|
||||
${PYSITELIB}/exabgp/__init__.pyo
|
||||
${PYSITELIB}/exabgp/__main__.py
|
||||
${PYSITELIB}/exabgp/__main__.pyc
|
||||
${PYSITELIB}/exabgp/__main__.pyo
|
||||
${PYSITELIB}/exabgp/application/__init__.py
|
||||
${PYSITELIB}/exabgp/application/__init__.pyc
|
||||
${PYSITELIB}/exabgp/application/__init__.pyo
|
||||
|
@ -562,15 +566,82 @@ ${PYSITELIB}/exabgp/util/usage.pyo
|
|||
${PYSITELIB}/exabgp/version.py
|
||||
${PYSITELIB}/exabgp/version.pyc
|
||||
${PYSITELIB}/exabgp/version.pyo
|
||||
bin/exabgp
|
||||
bin/healthcheck
|
||||
man/man1/exabgp.1
|
||||
man/man5/exabgp.conf.5
|
||||
share/exabgp/dynamic-1.pl
|
||||
share/exabgp/dynamic-1.sh
|
||||
share/exabgp/read-write.py
|
||||
share/exabgp/stderr-1.py
|
||||
share/exabgp/syslog-1.py
|
||||
share/exabgp/tcp-server
|
||||
share/exabgp/watchdog-1.pl
|
||||
share/exabgp/watchdog-1.sh
|
||||
share/exabgp/etc/addpath.conf
|
||||
share/exabgp/etc/api-add-remove.conf
|
||||
share/exabgp/etc/api-add-remove.run
|
||||
share/exabgp/etc/api-announcement.conf
|
||||
share/exabgp/etc/api-announcement.run
|
||||
share/exabgp/etc/api-api.conf
|
||||
share/exabgp/etc/api-api.nothing.run
|
||||
share/exabgp/etc/api-api.receive.run
|
||||
share/exabgp/etc/api-broken-flow.conf
|
||||
share/exabgp/etc/api-broken-flow.run
|
||||
share/exabgp/etc/api-check.conf
|
||||
share/exabgp/etc/api-check.run
|
||||
share/exabgp/etc/api-eor.conf
|
||||
share/exabgp/etc/api-eor.run
|
||||
share/exabgp/etc/api-fast.conf
|
||||
share/exabgp/etc/api-fast.run
|
||||
share/exabgp/etc/api-flow.conf
|
||||
share/exabgp/etc/api-flow.run
|
||||
share/exabgp/etc/api-multi-neighbor.conf
|
||||
share/exabgp/etc/api-multi-neighbor.run
|
||||
share/exabgp/etc/api-multisession.conf
|
||||
share/exabgp/etc/api-multisession.run
|
||||
share/exabgp/etc/api-nexthop-self.conf
|
||||
share/exabgp/etc/api-nexthop-self.run
|
||||
share/exabgp/etc/api-nexthop.conf
|
||||
share/exabgp/etc/api-nexthop.run
|
||||
share/exabgp/etc/api-notification.conf
|
||||
share/exabgp/etc/api-notification.run
|
||||
share/exabgp/etc/api-open.conf
|
||||
share/exabgp/etc/api-open.run
|
||||
share/exabgp/etc/api-reload.1.conf
|
||||
share/exabgp/etc/api-reload.2.conf
|
||||
share/exabgp/etc/api-reload.run
|
||||
share/exabgp/etc/api-teardown.conf
|
||||
share/exabgp/etc/api-teardown.run
|
||||
share/exabgp/etc/api-vpls.conf
|
||||
share/exabgp/etc/api-vpls.run
|
||||
share/exabgp/etc/api-vpnv4.conf
|
||||
share/exabgp/etc/api-vpnv4.run
|
||||
share/exabgp/etc/community.conf
|
||||
share/exabgp/etc/dual-neighbor.conf
|
||||
share/exabgp/etc/flow-redirect.conf
|
||||
share/exabgp/etc/flow.conf
|
||||
share/exabgp/etc/generic-attribute.conf
|
||||
share/exabgp/etc/group.conf
|
||||
share/exabgp/etc/ipv46routes4family.conf
|
||||
share/exabgp/etc/ipv46routes6family.conf
|
||||
share/exabgp/etc/ipv6grouping.conf
|
||||
share/exabgp/etc/l2vpn.conf
|
||||
share/exabgp/etc/large-mp.conf
|
||||
share/exabgp/etc/large.conf
|
||||
share/exabgp/etc/manual-eor.conf
|
||||
share/exabgp/etc/manual-eor.run
|
||||
share/exabgp/etc/md5.conf
|
||||
share/exabgp/etc/multiple-process.conf
|
||||
share/exabgp/etc/multisession.conf
|
||||
share/exabgp/etc/name.conf
|
||||
share/exabgp/etc/no-asn4.conf
|
||||
share/exabgp/etc/parity.conf
|
||||
share/exabgp/etc/path-information.conf
|
||||
share/exabgp/etc/simple-v4.conf
|
||||
share/exabgp/etc/simple-v6.conf
|
||||
share/exabgp/etc/skip.conf
|
||||
share/exabgp/etc/split.conf
|
||||
share/exabgp/etc/ttl.conf
|
||||
share/exabgp/etc/unknowncap.conf
|
||||
share/exabgp/etc/vpn.conf
|
||||
share/exabgp/etc/watchdog.conf
|
||||
share/exabgp/etc/watchdog.run
|
||||
share/exabgp/processes/dynamic-1.pl
|
||||
share/exabgp/processes/dynamic-1.sh
|
||||
share/exabgp/processes/read-write.py
|
||||
share/exabgp/processes/stderr-1.py
|
||||
share/exabgp/processes/syslog-1.py
|
||||
share/exabgp/processes/tcp-server
|
||||
share/exabgp/processes/watchdog-1.pl
|
||||
share/exabgp/processes/watchdog-1.sh
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.11 2015/11/04 00:34:59 agc Exp $
|
||||
$NetBSD: distinfo,v 1.12 2017/06/20 14:10:16 he Exp $
|
||||
|
||||
SHA1 (exabgp/3.4.11.tar.gz) = 62b4da0291cfa72ca8be6c176b97f06c1123ba87
|
||||
RMD160 (exabgp/3.4.11.tar.gz) = 4a28c954f34667165def4646d7cfd106ee0e0360
|
||||
SHA512 (exabgp/3.4.11.tar.gz) = a41bda0f159cf11669d7f8c7bbdd3811e2866e7de289af0d4a9792af7c08bfa3a03d3ec7551ad362ca34d268864136a70b3cf3bb90f4eb085eb3904472c5df99
|
||||
Size (exabgp/3.4.11.tar.gz) = 536372 bytes
|
||||
SHA1 (patch-setup.py) = 8181a726cead85e6e06d49f9b474ac97210a069c
|
||||
SHA1 (exabgp/3.4.19.tar.gz) = 8199eb40f3b533a7db1ee43e4a97213f550a4261
|
||||
RMD160 (exabgp/3.4.19.tar.gz) = 4596ea5663169e09d8be5a0b5833c2f9426a7ff2
|
||||
SHA512 (exabgp/3.4.19.tar.gz) = 92fb0aea9b2594433acacdc196cfda217867f59ea6524b409b69dff506fdc9a9a815b93807ff06d4c81404b1f6568a1a41e64178122eaf9ce7732416474f3455
|
||||
Size (exabgp/3.4.19.tar.gz) = 543475 bytes
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
$NetBSD: patch-setup.py,v 1.4 2015/03/19 09:20:30 he Exp $
|
||||
|
||||
Do away with the special handling for NetBSD, to avoid PLIST issues
|
||||
between different pkgsrc-using platforms.
|
||||
Install helper scripts outside of the config tree (use share/exabgp).
|
||||
On the other hand, only do the systemd dance on Linux.
|
||||
|
||||
--- setup.py.orig 2015-03-14 15:32:13.000000000 +0000
|
||||
+++ setup.py
|
||||
@@ -364,14 +364,10 @@ def configuration (etc):
|
||||
|
||||
os_name = platform.system()
|
||||
|
||||
-if os_name == 'NetBSD':
|
||||
- files_definition= [
|
||||
- ('share/exabgp',configuration('etc/exabgp')),
|
||||
- ]
|
||||
-else:
|
||||
- files_definition = [
|
||||
- ('etc/exabgp',configuration('etc/exabgp')),
|
||||
- ]
|
||||
+files_definition= [
|
||||
+ ('share/exabgp',configuration('etc/exabgp')),
|
||||
+]
|
||||
+if os_name == 'Linux':
|
||||
if sys.argv[-1] == 'systemd':
|
||||
files_definition.append(('/usr/lib/systemd/system',configuration('etc/systemd')))
|
||||
|
Loading…
Reference in a new issue