Update pan to 0.14.1.

New Features include:
Added support for GNet2, which adds IPv6 support to Pan.
Added Baltic Windows-1257 charset support.
Display the total score for a thread when the thread is collapsed.
Added menu buttons and shortcuts for `go to next new article' and
`go to next new thread'

Also lots of bug fixes and usability improvements.

For the complete list see http://pan.rebelbase.org/ or read the ChangeLog.
This commit is contained in:
chris 2003-08-31 00:10:28 +00:00
parent 9c379b20c7
commit 4a531b2bd5
5 changed files with 9 additions and 41 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.25 2003/07/17 22:52:09 grant Exp $
# $NetBSD: Makefile,v 1.26 2003/08/31 00:10:28 chris Exp $
#
DISTNAME= pan-0.14.0
PKGREVISION= 1
DISTNAME= pan-0.14.1
CATEGORIES= news
MASTER_SITES= http://pan.rebelbase.com/download/releases/${DISTNAME:C/pan-//}/SOURCE/
EXTRACT_SUFX= .tar.bz2
@ -23,7 +22,7 @@ LIBS= -lcompat
.include "../../converters/libiconv/buildlink2.mk"
.include "../../devel/gettext-lib/buildlink2.mk"
.include "../../devel/pkgconfig/buildlink2.mk"
.include "../../net/gnet1/buildlink2.mk"
.include "../../net/gnet/buildlink2.mk"
.include "../../textproc/gtkspell/buildlink2.mk"
.include "../../textproc/libxml2/buildlink2.mk"
.include "../../x11/gtk2/buildlink2.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.6 2003/04/15 10:28:45 wiz Exp $
@comment $NetBSD: PLIST,v 1.7 2003/08/31 00:10:28 chris Exp $
bin/pan
share/gnome/apps/Internet/pan.desktop
${PKGLOCALEDIR}/locale/am/LC_MESSAGES/pan.mo
@ -28,10 +28,11 @@ ${PKGLOCALEDIR}/locale/pt_BR/LC_MESSAGES/pan.mo
${PKGLOCALEDIR}/locale/ru/LC_MESSAGES/pan.mo
${PKGLOCALEDIR}/locale/sk/LC_MESSAGES/pan.mo
${PKGLOCALEDIR}/locale/sl/LC_MESSAGES/pan.mo
${PKGLOCALEDIR}/locale/sp/LC_MESSAGES/pan.mo
${PKGLOCALEDIR}/locale/sr/LC_MESSAGES/pan.mo
${PKGLOCALEDIR}/locale/sr@Latn/LC_MESSAGES/pan.mo
${PKGLOCALEDIR}/locale/sv/LC_MESSAGES/pan.mo
${PKGLOCALEDIR}/locale/tr/LC_MESSAGES/pan.mo
${PKGLOCALEDIR}/locale/uk/LC_MESSAGES/pan.mo
${PKGLOCALEDIR}/locale/vi/LC_MESSAGES/pan.mo
${PKGLOCALEDIR}/locale/zh_CN/LC_MESSAGES/pan.mo
share/pixmaps/pan.png

View file

@ -1,6 +1,4 @@
$NetBSD: distinfo,v 1.11 2003/05/09 10:30:20 wiz Exp $
$NetBSD: distinfo,v 1.12 2003/08/31 00:10:28 chris Exp $
SHA1 (pan-0.14.0.tar.bz2) = eefbe6fc699f214f88315e2dda85c989ee707df2
Size (pan-0.14.0.tar.bz2) = 1753632 bytes
SHA1 (patch-aa) = 8af477faa1746b9b54f691b31978ab9e882e9b56
SHA1 (patch-ag) = 4ba365c425f5f754346465d857178331ab47e307
SHA1 (pan-0.14.1.tar.bz2) = 88cfa6a5295825187dc1772a91d5fd7586f59c9c
Size (pan-0.14.1.tar.bz2) = 1832331 bytes

View file

@ -1,18 +0,0 @@
$NetBSD: patch-aa,v 1.8 2003/05/09 10:30:20 wiz Exp $
--- po/fr.po.orig Tue May 6 02:51:57 2003
+++ po/fr.po
@@ -3097,11 +3097,11 @@ msgid ""
"resume those tasks?"
msgstr ""
"Quelques tâches étaient toujours en file d'attente la dernière fois que Pan "
-"a quitté. Voulez-vous interrompre ces tâches ?"
+"a quitté. Voulez-vous relancer ces tâches ?"
#: pan/pan.c:403
msgid "_Resume"
-msgstr "_Interrompre"
+msgstr "_Relancer"
#: pan/prefs.c:218
msgid ""

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ag,v 1.3 2003/04/15 10:28:46 wiz Exp $
--- pan/text.c.orig Fri Sep 27 23:02:36 2002
+++ pan/text.c
@@ -20,6 +20,7 @@
#include <config.h>
#include <ctype.h>
+#include <stdlib.h>
#include <string.h>
#include <glib.h>