Initial import of gaim-otr-2.0.1.

This is the Off-The-Record messaging plugin for gaim.
This commit is contained in:
nathanw 2005-03-24 21:25:00 +00:00
parent 9814b8da9f
commit 4a9ff6392e
5 changed files with 86 additions and 0 deletions

18
chat/gaim-otr/DESCR Normal file
View file

@ -0,0 +1,18 @@
This is the OTR plugin for GAIM.
Off-the-Record (OTR) Messaging allows you to have private
conversations over instant messaging by providing:
Encryption
No one else can read your instant messages.
Authentication
You are assured the correspondent is who you think it is.
Deniability
The messages you send do not have digital signatures that are
checkable by a third party. Anyone can forge messages after a
conversation to make them look like they came from you. However,
during a conversation, your correspondent is assured the messages
he sees are authentic and unmodified.
Perfect forward secrecy
If you lose control of your private keys, no previous conversation
is compromised.

20
chat/gaim-otr/Makefile Normal file
View file

@ -0,0 +1,20 @@
# $NetBSD: Makefile,v 1.1.1.1 2005/03/24 21:25:00 nathanw Exp $
DISTNAME= gaim-otr-2.0.1
CATEGORIES= chat security
MASTER_SITES= http://www.cypherpunks.ca/otr/
MAINTAINER= nathanw@NetBSD.org
HOMEPAGE= http://www.cypherpunks.ca/otr/
COMMENT= Plugin for gaim to add OTR (Off-The-Record) encryption
USE_BUILDLINK3= yes
USE_GNU_TOOLS= make
.include "../../chat/libotr/buildlink3.mk"
.include "../../security/libgcrypt/buildlink3.mk"
.include "../../chat/gaim/buildlink3.mk"
.include "../../devel/glib2/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

2
chat/gaim-otr/PLIST Normal file
View file

@ -0,0 +1,2 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2005/03/24 21:25:00 nathanw Exp $
lib/gaim/gaim-otr.so

6
chat/gaim-otr/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2005/03/24 21:25:00 nathanw Exp $
SHA1 (gaim-otr-2.0.1.tar.gz) = 617e6c7cf92439c0320b57551ad26b2ccea468a0
RMD160 (gaim-otr-2.0.1.tar.gz) = 8431bb7bf214f6935dda31c0378eb061eae875ad
Size (gaim-otr-2.0.1.tar.gz) = 34691 bytes
SHA1 (patch-aa) = a7ed08cb06ec08aa80439dafb608fb7bffdd4f77

View file

@ -0,0 +1,40 @@
$NetBSD: patch-aa,v 1.1.1.1 2005/03/24 21:25:01 nathanw Exp $
--- Makefile.orig 2005-03-14 13:10:12.000000000 -0500
+++ Makefile 2005-03-14 13:13:50.000000000 -0500
@@ -2,7 +2,7 @@
GAIM_OTR_VERSION = 2.0.1
# Replace this with the path to the GAIM headers
-GAIM_SOURCE ?= /usr/include/gaim
+GAIM_SOURCE ?= ${PREFIX}/include/gaim
# If you don't have pkg-config, put the appropriate -I entry on the next line
GTK_HDRS ?= `pkg-config --cflags glib-2.0 gtk+-2.0`
@@ -10,10 +10,10 @@
# The location of the libotr include files. Note that if, for example,
# the full path of message.h is /usr/include/libotr/message.h, you
# should put /usr/include on the next line, not /usr/include/libotr
-LIBOTRINCDIR = /usr/include
+LIBOTRINCDIR = ${PREFIX}/include
# The locataion of libotr.a.
-LIBOTRLIBDIR = /usr/lib
+LIBOTRLIBDIR = ${PREFIX}/lib
# The target
TARGET = gaim-otr.so
@@ -30,11 +30,11 @@
else
FPIC = -fPIC
LDFLAGS = -module -avoid-version
-LDLIBS = -lotr -lgcrypt
+LDLIBS = -L${LIBOTRLIBDIR} -Wl,--rpath,${LIBOTRLIBDIR} -lotr -lgcrypt
endif
# Install directory
-GAIMDIR = /usr/lib/gaim
+GAIMDIR = ${PREFIX}/lib/gaim
INSTALLDIR = $(DESTDIR)$(GAIMDIR)
CC ?= gcc