GTL - C++ graph data structure library based on the STL

This commit is contained in:
jlam 2000-05-10 04:31:17 +00:00
parent 2a16a4695e
commit 4b16b62580
7 changed files with 168 additions and 0 deletions

28
devel/gtl/Makefile Normal file
View file

@ -0,0 +1,28 @@
# $NetBSD: Makefile,v 1.1.1.1 2000/05/10 04:31:17 jlam Exp $
DISTNAME= GTL-0.3.3
PKGNAME= gtl-0.3.3
CATEGORIES= devel
MASTER_SITES= http://infosun.fmi.uni-passau.de/GTL/archive/
MAINTAINER= jlam@netbsd.org
HOMEPAGE= http://www.fmi.uni-passau.de/Graphlet/GTL/
GNU_CONFIGURE= # defined
USE_LIBTOOL= # defined
LTCONFIG_OVERRIDE= ${WRKSRC}/ltconfig
GTL_VERS= 0:3
MAKE_ENV+= GTL_VERS="${GTL_VERS}"
HTMLDOCDIR= ${PREFIX}/share/doc/html/GTL
post-install:
${INSTALL_DATA_DIR} ${HTMLDOCDIR}
${INSTALL_DATA_DIR} ${HTMLDOCDIR}/icons
cd ${WRKSRC}/doc/html; \
${INSTALL_DATA} *.html ${HTMLDOCDIR}
cd ${WRKSRC}/doc/html/icons; \
${INSTALL_DATA} *.gif *.jpeg ${HTMLDOCDIR}/icons
.include "../../mk/bsd.pkg.mk"

3
devel/gtl/files/md5 Normal file
View file

@ -0,0 +1,3 @@
$NetBSD: md5,v 1.1.1.1 2000/05/10 04:31:17 jlam Exp $
MD5 (GTL-0.3.3.tar.gz) = 3fc4653715b8d3b32f9bee3f4ea01252

View file

@ -0,0 +1,3 @@
$NetBSD: patch-sum,v 1.1.1.1 2000/05/10 04:31:17 jlam Exp $
MD5 (patch-aa) = 546834f67372b1a0c1878f85731f5ea4

View file

@ -0,0 +1,22 @@
$NetBSD: patch-aa,v 1.1.1.1 2000/05/10 04:31:18 jlam Exp $
--- src/Makefile.in.orig Tue Mar 7 04:14:07 2000
+++ src/Makefile.in Tue May 9 11:46:57 2000
@@ -92,7 +92,7 @@
libGTL_la_SOURCES = gml_scanner.cpp gml_parser.cpp edge.cpp graph.cpp node.cpp dfs.cpp biconnectivity.cpp bfs.cpp topsort.cpp st_number.cpp embedding.cpp pq_node.cpp pq_tree.cpp planarity.cpp maxflow_ff.cpp maxflow_pp.cpp debug.cpp components.cpp fm_partition.cpp ratio_cut_partition.cpp
-libGTL_la_LDFLAGS = -version-info $(MINOR_VERSION):$(MINI_VERSION):0
+libGTL_la_LDFLAGS = -version-info $(GTL_VERS)
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_CLEAN_FILES =
LTLIBRARIES = $(lib_LTLIBRARIES)
@@ -112,7 +112,7 @@
CXXCOMPILE = $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
LTCXXCOMPILE = $(LIBTOOL) --mode=compile $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
CXXLD = $(CXX)
-CXXLINK = $(LIBTOOL) --mode=link $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@
+CXXLINK = $(LIBTOOL) --mode=link --cplusplus $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@
DIST_COMMON = Makefile.am Makefile.in

1
devel/gtl/pkg/COMMENT Normal file
View file

@ -0,0 +1 @@
C++ graph data structure library based on the STL

4
devel/gtl/pkg/DESCR Normal file
View file

@ -0,0 +1,4 @@
GTL is a graph library based on STL. For the design of GTL's API the
API of LEDA has served as a basis. GTL contains the classes needed to
work with graphs, nodes and edges and some basic algorithms (DFS, BFS,
topsort ...) as building blocks for more complex graph algorithms.

107
devel/gtl/pkg/PLIST Normal file
View file

@ -0,0 +1,107 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2000/05/10 04:31:18 jlam Exp $
include/GTL/GTL.h
include/GTL/algorithm.h
include/GTL/bfs.h
include/GTL/biconnectivity.h
include/GTL/components.h
include/GTL/debug.h
include/GTL/dfs.h
include/GTL/edge.h
include/GTL/edge_data.h
include/GTL/edge_map.h
include/GTL/embedding.h
include/GTL/fm_partition.h
include/GTL/gml_parser.h
include/GTL/gml_scanner.h
include/GTL/graph.h
include/GTL/maxflow_ff.h
include/GTL/maxflow_pp.h
include/GTL/ne_map.h
include/GTL/node.h
include/GTL/node_data.h
include/GTL/node_map.h
include/GTL/planarity.h
include/GTL/pq_node.h
include/GTL/pq_tree.h
include/GTL/ratio_cut_partition.h
include/GTL/st_number.h
include/GTL/symlist.h
include/GTL/topsort.h
include/GTL/version.h
lib/libGTL.a
lib/libGTL.so.0.3
share/doc/html/GTL/GML_error.html
share/doc/html/GTL/GTL-GTL-h.html
share/doc/html/GTL/GTL-algorithm-h.html
share/doc/html/GTL/GTL-bfs-h.html
share/doc/html/GTL/GTL-biconnectivity-h.html
share/doc/html/GTL/GTL-components-h.html
share/doc/html/GTL/GTL-debug-h.html
share/doc/html/GTL/GTL-dfs-h.html
share/doc/html/GTL/GTL-edge-h.html
share/doc/html/GTL/GTL-edge_data-h.html
share/doc/html/GTL/GTL-edge_map-h.html
share/doc/html/GTL/GTL-embedding-h.html
share/doc/html/GTL/GTL-fm_partition-h.html
share/doc/html/GTL/GTL-gml_parser-h.html
share/doc/html/GTL/GTL-gml_scanner-h.html
share/doc/html/GTL/GTL-graph-h.html
share/doc/html/GTL/GTL-maxflow_ff-h.html
share/doc/html/GTL/GTL-maxflow_pp-h.html
share/doc/html/GTL/GTL-ne_map-h.html
share/doc/html/GTL/GTL-node-h.html
share/doc/html/GTL/GTL-node_data-h.html
share/doc/html/GTL/GTL-node_map-h.html
share/doc/html/GTL/GTL-planarity-h.html
share/doc/html/GTL/GTL-pq_node-h.html
share/doc/html/GTL/GTL-pq_tree-h.html
share/doc/html/GTL/GTL-ratio_cut_partition-h.html
share/doc/html/GTL/GTL-st_number-h.html
share/doc/html/GTL/GTL-symlist-h.html
share/doc/html/GTL/GTL-topsort-h.html
share/doc/html/GTL/GTL-version-h.html
share/doc/html/GTL/algorithm.html
share/doc/html/GTL/bfs.html
share/doc/html/GTL/biconnectivity.html
share/doc/html/GTL/classes.html
share/doc/html/GTL/components.html
share/doc/html/GTL/dfs.html
share/doc/html/GTL/doc000.html
share/doc/html/GTL/doc001.html
share/doc/html/GTL/doc002.html
share/doc/html/GTL/doc003.html
share/doc/html/GTL/doc004.html
share/doc/html/GTL/doc005.html
share/doc/html/GTL/doc006.html
share/doc/html/GTL/doc007.html
share/doc/html/GTL/edge.html
share/doc/html/GTL/edge_map.html
share/doc/html/GTL/fm_partition.html
share/doc/html/GTL/graph.html
share/doc/html/GTL/header-list.html
share/doc/html/GTL/hier.html
share/doc/html/GTL/icons/GTL-small.gif
share/doc/html/GTL/icons/GTL.jpeg
share/doc/html/GTL/icons/contents.gif
share/doc/html/GTL/icons/next.gif
share/doc/html/GTL/icons/next_gr.gif
share/doc/html/GTL/icons/previous.gif
share/doc/html/GTL/icons/previous_gr.gif
share/doc/html/GTL/icons/up.gif
share/doc/html/GTL/icons/up_gr.gif
share/doc/html/GTL/index.html
share/doc/html/GTL/maxflow_ff.html
share/doc/html/GTL/maxflow_pp.html
share/doc/html/GTL/ne_map.html
share/doc/html/GTL/node.html
share/doc/html/GTL/node_map.html
share/doc/html/GTL/planar_embedding.html
share/doc/html/GTL/planarity.html
share/doc/html/GTL/pq_tree.html
share/doc/html/GTL/ratio_cut_partition.html
share/doc/html/GTL/refer.html
share/doc/html/GTL/st_number.html
share/doc/html/GTL/symlist.html
share/doc/html/GTL/topsort.html
@dirrm share/doc/html/GTL/icons
@dirrm share/doc/html/GTL