py-flake8: fix for py-flakes 2.0.0; revbump

This commit is contained in:
adam 2018-06-18 11:17:54 +00:00
parent b36937ed81
commit 4b26419c57
4 changed files with 19 additions and 13 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.16 2018/05/15 06:26:50 adam Exp $
# $NetBSD: Makefile,v 1.17 2018/06/18 11:17:54 adam Exp $
DISTNAME= flake8-3.5.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_PYPI:=f/flake8/}

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.12 2018/05/14 07:39:55 leot Exp $
$NetBSD: distinfo,v 1.13 2018/06/18 11:17:54 adam Exp $
SHA1 (flake8-3.5.0.tar.gz) = 302f39432917f57bb4f0f1c1573c96074913b46f
RMD160 (flake8-3.5.0.tar.gz) = 4533c09c33394ca31ab081ed09f370dfac415882
SHA512 (flake8-3.5.0.tar.gz) = ac5d1bd9c44ed76c9e5cbd941b24bb552aa76e156b24ccda6cc8440ee90f3a574fdb393665adc75298e4f57111d7ab3115ef21ef9088fb327d0a9703d442450c
Size (flake8-3.5.0.tar.gz) = 140608 bytes
SHA1 (patch-setup.cfg) = 227164e8c9e0287227fadc13f522b84d6781acca
SHA1 (patch-setup.py) = 2027b7f24cc5f99e5f77a45c97338d0cc6d69404
SHA1 (patch-setup.cfg) = f0bcf4fc363a933365c553d1957c9892ce364802
SHA1 (patch-setup.py) = b04563b206e065044d24955868cd38408b9a013f
SHA1 (patch-tox.ini) = ff417d4d05a5846db467015f19fba095e368ef70

View file

@ -1,17 +1,20 @@
$NetBSD: patch-setup.cfg,v 1.3 2018/05/14 07:39:55 leot Exp $
$NetBSD: patch-setup.cfg,v 1.4 2018/06/18 11:17:54 adam Exp $
Allow newer py-flakes.
Add support for pycodestyle-2.4.0.
From upstream commits 0273ca56, 85c503de, 68782675, e61d9d24, ef1d5cee.
--- setup.cfg.orig 2017-10-23 11:16:02.000000000 +0000
+++ setup.cfg
@@ -9,7 +9,7 @@ requires-dist =
@@ -8,8 +8,8 @@ universal = 1
requires-dist =
enum34; python_version<"3.4"
configparser; python_version<"3.2"
pyflakes >= 1.5.0, < 1.7.0
- pyflakes >= 1.5.0, < 1.7.0
- pycodestyle >= 2.0.0, < 2.4.0
+ pycodestyle >= 2.4.0, < 2.5.0
+ pyflakes >= 1.5.0
+ pycodestyle >= 2.4.0
mccabe >= 0.6.0, < 0.7.0
[egg_info]

View file

@ -1,17 +1,20 @@
$NetBSD: patch-setup.py,v 1.3 2018/05/14 07:39:55 leot Exp $
$NetBSD: patch-setup.py,v 1.4 2018/06/18 11:17:54 adam Exp $
Allow newer py-flakes.
Add support for pycodestyle-2.4.0.
From upstream commits 0273ca56, 85c503de, 68782675, e61d9d24, ef1d5cee.
--- setup.py.orig 2017-08-08 00:31:43.000000000 +0000
+++ setup.py
@@ -22,7 +22,7 @@ requires = [
@@ -21,8 +21,8 @@ requires = [
# http://flake8.pycqa.org/en/latest/faq.html#why-does-flake8-use-ranges-for-its-dependencies
# And in which releases we will update those ranges here:
# http://flake8.pycqa.org/en/latest/internal/releases.html#releasing-flake8
"pyflakes >= 1.5.0, < 1.7.0",
- "pyflakes >= 1.5.0, < 1.7.0",
- "pycodestyle >= 2.0.0, < 2.4.0",
+ "pycodestyle >= 2.4.0, < 2.5.0",
+ "pyflakes >= 1.5.0",
+ "pycodestyle >= 2.4.0",
"mccabe >= 0.6.0, < 0.7.0",
"setuptools >= 30",
]