add chipmunk-1.4:
shell-like tool for hardware debugging
This commit is contained in:
parent
cdcc6ba542
commit
4bddce4378
7 changed files with 77 additions and 0 deletions
22
misc/chipmunk/Makefile
Normal file
22
misc/chipmunk/Makefile
Normal file
|
@ -0,0 +1,22 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 1999/06/23 18:18:53 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= chipmunk-1.4
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://www.bitwizard.nl/chipmunk/
|
||||
|
||||
MAINTAINER= packages@netbsd.org
|
||||
HOMEPAGE= http://www.bitwizard.nl/chipmunk/index.html
|
||||
|
||||
DEPENDS+= readline-2.2:../../devel/readline
|
||||
|
||||
ONLY_FOR_PLATFORM= NetBSD-*-i386
|
||||
|
||||
ALL_TARGET= chipmunk
|
||||
MAKE_FLAGS= CONFIG_OPTIONS=-I$(PREFIX)/include \
|
||||
LDFLAGS=-L$(PREFIX)/lib EXTRA_LIBS=-li386
|
||||
|
||||
do-install:
|
||||
$(INSTALL_PROGRAM) $(WRKSRC)/chipmunk $(PREFIX)/sbin/chipmunk
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
misc/chipmunk/files/md5
Normal file
3
misc/chipmunk/files/md5
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 1999/06/23 18:18:56 drochner Exp $
|
||||
|
||||
MD5 (chipmunk-1.4.tar.gz) = 25cc9fc70ec62d6da4a1f28ebbab2188
|
13
misc/chipmunk/patches/patch-aa
Normal file
13
misc/chipmunk/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 1999/06/23 18:18:55 drochner Exp $
|
||||
|
||||
--- Makefile.orig Wed Jun 23 16:49:36 1999
|
||||
+++ Makefile Wed Jun 23 16:50:15 1999
|
||||
@@ -30,7 +30,7 @@
|
||||
# on succesful compilations.
|
||||
|
||||
chipmunk: $(OBJS) version
|
||||
- $(CC) $(CFLAGS) $(OBJS) $(LIBS) $(EXTRA_LIBS) -o $@
|
||||
+ $(CC) $(LDFLAGS) $(OBJS) $(LIBS) $(EXTRA_LIBS) -o $@
|
||||
|
||||
chipmunk.hp: $(OBJS) version
|
||||
$(CC) $(CFLAGS) $(OBJS) $(LIBS) $(EXTRA_LIBS) -o $@
|
30
misc/chipmunk/patches/patch-ab
Normal file
30
misc/chipmunk/patches/patch-ab
Normal file
|
@ -0,0 +1,30 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 1999/06/23 18:18:55 drochner Exp $
|
||||
|
||||
--- config.h.orig Wed Jun 23 16:52:58 1999
|
||||
+++ config.h Wed Jun 23 18:09:29 1999
|
||||
@@ -108,6 +108,25 @@
|
||||
# define USE_TESTS
|
||||
#endif
|
||||
|
||||
+#ifdef __NetBSD__
|
||||
+# define OPSYS "NetBSD"
|
||||
+# define USE_UNISTD
|
||||
+# define USE_CBREAK
|
||||
+# define USE_MMAP
|
||||
+# define USE_SIGNALS
|
||||
+# define USE_WAIT
|
||||
+# define UNIX
|
||||
+# define USE_ALLOCA
|
||||
+# define USE_READLINE
|
||||
+# define USE_MEMTEST
|
||||
+# define USE_TESTS
|
||||
+# define USE_SIGNAL_H
|
||||
+# define IN_OUT_INSTRUCTIONS
|
||||
+# define my_ioperm(x,y,z) i386_iopl(1)
|
||||
+
|
||||
+#define SIGNAL_FUNCTION_CAST (void (*)())
|
||||
+#endif
|
||||
+
|
||||
/*
|
||||
* Here starts the section that provides defaults for most systems, that
|
||||
* can be overridden for a specific OS/compiler.
|
1
misc/chipmunk/pkg/COMMENT
Normal file
1
misc/chipmunk/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
shell-like tool for hardware debugging
|
6
misc/chipmunk/pkg/DESCR
Normal file
6
misc/chipmunk/pkg/DESCR
Normal file
|
@ -0,0 +1,6 @@
|
|||
Chipmunk is a language for writing short programs to perform
|
||||
application specific hardware manipulation tasks.
|
||||
|
||||
It is specifically good at debugging hardware because you
|
||||
can interactively search for good ways to access your hardware, and
|
||||
then record it in a macro as documentation and fast repetition.
|
2
misc/chipmunk/pkg/PLIST
Normal file
2
misc/chipmunk/pkg/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 1999/06/23 18:18:56 drochner Exp $
|
||||
sbin/chipmunk
|
Loading…
Reference in a new issue