update to 0.6.4
changes: -Fix crash in the Splash renderer when T3 fonts are badly defined -Draw underlined Links correctly -utils: Fix two use after free bugs in HtmlOutputDev.cc -some fixes to the qt4 frontend
This commit is contained in:
parent
40becc0204
commit
4bebd1d790
4 changed files with 6 additions and 57 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile.common,v 1.10 2007/11/28 20:54:36 drochner Exp $
|
||||
# $NetBSD: Makefile.common,v 1.11 2008/02/01 21:12:41 drochner Exp $
|
||||
#
|
||||
|
||||
POPPLER_VERS= 0.6.2
|
||||
POPPLER_VERS= 0.6.4
|
||||
DISTNAME= poppler-${POPPLER_VERS}
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= http://poppler.freedesktop.org/
|
||||
|
|
|
@ -1,10 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.21 2007/12/12 01:25:17 markd Exp $
|
||||
$NetBSD: distinfo,v 1.22 2008/02/01 21:12:41 drochner Exp $
|
||||
|
||||
SHA1 (poppler-0.6.2.tar.gz) = 3e367cab2ba110bfe42c3ab1036597410ad591da
|
||||
RMD160 (poppler-0.6.2.tar.gz) = d582d9a22d87554a2226aa739cd37e64f3147b73
|
||||
Size (poppler-0.6.2.tar.gz) = 1289454 bytes
|
||||
SHA1 (poppler-0.6.4.tar.gz) = edd248b278ceb81f8820b1a2be8abfe05ca36465
|
||||
RMD160 (poppler-0.6.4.tar.gz) = 5ece435aeac5b6cbf4e73f89c1096932a051f23e
|
||||
Size (poppler-0.6.4.tar.gz) = 1294481 bytes
|
||||
SHA1 (patch-aa) = af2a87317bd613e64b13e49ec92d3654f3ceb689
|
||||
SHA1 (patch-ab) = 8cb260eb13eba003f5b0ecb825bdb1a4785f042b
|
||||
SHA1 (patch-ae) = 1d703170b1c9ed8a4e8f44e7b7e4854d3a2f3b7e
|
||||
SHA1 (patch-af) = 52d10976f9a31fad291eba8b5d6f52ab79fd5145
|
||||
SHA1 (patch-ag) = f47995589fa99df9ffb26b69b347817cc95ee111
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.3 2007/11/28 20:54:38 drochner Exp $
|
||||
|
||||
--- poppler/Gfx.cc.orig 2007-11-28 20:59:16.000000000 +0100
|
||||
+++ poppler/Gfx.cc
|
||||
@@ -4014,7 +4014,7 @@ void Gfx::opBeginMarkedContent(Object ar
|
||||
if (printCommands) {
|
||||
printf(" marked content: %s ", args[0].getName());
|
||||
if (numArgs == 2)
|
||||
- args[2].print(stdout);
|
||||
+ args[1].print(stdout);
|
||||
printf("\n");
|
||||
fflush(stdout);
|
||||
}
|
||||
@@ -4034,7 +4034,7 @@ void Gfx::opMarkPoint(Object args[], int
|
||||
if (printCommands) {
|
||||
printf(" mark point: %s ", args[0].getName());
|
||||
if (numArgs == 2)
|
||||
- args[2].print(stdout);
|
||||
+ args[1].print(stdout);
|
||||
printf("\n");
|
||||
fflush(stdout);
|
||||
}
|
|
@ -1,27 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.3 2007/11/28 20:54:38 drochner Exp $
|
||||
|
||||
--- glib/poppler-document.cc.orig 2007-11-28 21:04:53.000000000 +0100
|
||||
+++ glib/poppler-document.cc
|
||||
@@ -137,8 +137,20 @@ poppler_document_new_from_file (const ch
|
||||
g_free (filename);
|
||||
|
||||
password_g = NULL;
|
||||
- if (password != NULL)
|
||||
- password_g = new GooString (password);
|
||||
+ if (password != NULL) {
|
||||
+ if (g_utf8_validate (password, -1, NULL)) {
|
||||
+ gchar *password_latin;
|
||||
+
|
||||
+ password_latin = g_convert (password, -1,
|
||||
+ "ISO-8859-1",
|
||||
+ "UTF-8",
|
||||
+ NULL, NULL, NULL);
|
||||
+ password_g = new GooString (password_latin);
|
||||
+ g_free (password_latin);
|
||||
+ } else {
|
||||
+ password_g = new GooString (password);
|
||||
+ }
|
||||
+ }
|
||||
|
||||
newDoc = new PDFDoc(filename_g, password_g, password_g);
|
||||
if (password_g)
|
Loading…
Reference in a new issue